#578390. - Sync Fedora license list with Wiki revision 1.71.
This commit is contained in:
parent
f0b8d54da9
commit
e2f06ee756
@ -1 +1 @@
|
|||||||
rpmlint-0.95.tar.bz2
|
rpmlint-0.96.tar.bz2
|
||||||
|
@ -1,19 +0,0 @@
|
|||||||
Index: TagsCheck.py
|
|
||||||
===================================================================
|
|
||||||
--- TagsCheck.py (revision 1737)
|
|
||||||
+++ TagsCheck.py (revision 1738)
|
|
||||||
@@ -803,8 +803,12 @@
|
|
||||||
j += 1
|
|
||||||
i += 1
|
|
||||||
|
|
||||||
- expected = pkg.header.sprintf(
|
|
||||||
- rpm.expandMacro("%{_build_name_fmt}")).split("/")[-1]
|
|
||||||
+ expfmt = rpm.expandMacro("%{_build_name_fmt}")
|
|
||||||
+ if pkg.isSource():
|
|
||||||
+ # _build_name_fmt often (always?) ends up not outputting src/nosrc
|
|
||||||
+ # as arch for source packages, do it ourselves
|
|
||||||
+ expfmt = re.sub(r'(?i)%\{?ARCH\b\}?', pkg.arch, expfmt)
|
|
||||||
+ expected = pkg.header.sprintf(expfmt).split("/")[-1]
|
|
||||||
basename = os.path.basename(pkg.filename)
|
|
||||||
if basename != expected:
|
|
||||||
printWarning(pkg, 'non-coherent-filename', basename, expected)
|
|
@ -40,7 +40,7 @@ setOption("DanglingSymlinkExceptions", (
|
|||||||
setOption("ValidLicenses", (
|
setOption("ValidLicenses", (
|
||||||
# These are the short names for all of the Fedora approved licenses.
|
# These are the short names for all of the Fedora approved licenses.
|
||||||
# The master list is kept here: http://fedoraproject.org/wiki/Licensing
|
# The master list is kept here: http://fedoraproject.org/wiki/Licensing
|
||||||
# Last synced with revision "1.68, 18 Feb 2010" of that page.
|
# Last synced with revision "1.71, 15 Apr 2010" of that page.
|
||||||
'AAL',
|
'AAL',
|
||||||
'Adobe',
|
'Adobe',
|
||||||
'ADSL',
|
'ADSL',
|
||||||
@ -49,18 +49,19 @@ setOption("ValidLicenses", (
|
|||||||
'AGPLv3',
|
'AGPLv3',
|
||||||
'AGPLv3 with exceptions',
|
'AGPLv3 with exceptions',
|
||||||
'AMDPLPA',
|
'AMDPLPA',
|
||||||
|
'AML',
|
||||||
'AMPAS BSD',
|
'AMPAS BSD',
|
||||||
|
'APSL 2.0',
|
||||||
|
'APSL 2.0+',
|
||||||
'ARL',
|
'ARL',
|
||||||
|
'Artistic 2.0',
|
||||||
|
'Artistic clarified',
|
||||||
'ASL 1.0',
|
'ASL 1.0',
|
||||||
'ASL 1.0+',
|
'ASL 1.0+',
|
||||||
'ASL 1.1',
|
'ASL 1.1',
|
||||||
'ASL 1.1+',
|
'ASL 1.1+',
|
||||||
'ASL 2.0',
|
'ASL 2.0',
|
||||||
'ASL 2.0+',
|
'ASL 2.0+',
|
||||||
'APSL 2.0',
|
|
||||||
'APSL 2.0+',
|
|
||||||
'Artistic 2.0',
|
|
||||||
'Artistic clarified',
|
|
||||||
'Beerware',
|
'Beerware',
|
||||||
'BitTorrent',
|
'BitTorrent',
|
||||||
'Boost',
|
'Boost',
|
||||||
@ -74,10 +75,10 @@ setOption("ValidLicenses", (
|
|||||||
'CeCILL-C',
|
'CeCILL-C',
|
||||||
'CDDL',
|
'CDDL',
|
||||||
'CNRI',
|
'CNRI',
|
||||||
'CPAL',
|
|
||||||
'CPL',
|
|
||||||
'Condor',
|
'Condor',
|
||||||
'Copyright only',
|
'Copyright only',
|
||||||
|
'CPAL',
|
||||||
|
'CPL',
|
||||||
'Crystal Stacker',
|
'Crystal Stacker',
|
||||||
'DOC',
|
'DOC',
|
||||||
'dvipdfm',
|
'dvipdfm',
|
||||||
@ -150,17 +151,19 @@ setOption("ValidLicenses", (
|
|||||||
'MPLv1.1',
|
'MPLv1.1',
|
||||||
'MPLv1.1+',
|
'MPLv1.1+',
|
||||||
'MS-PL',
|
'MS-PL',
|
||||||
|
'MS-RL',
|
||||||
|
'Naumen',
|
||||||
'NCSA',
|
'NCSA',
|
||||||
'NetCDF',
|
'NetCDF',
|
||||||
'NGPL',
|
|
||||||
'NOSL',
|
|
||||||
'Naumen',
|
|
||||||
'Netscape',
|
'Netscape',
|
||||||
'Newmat',
|
'Newmat',
|
||||||
|
'NGPL',
|
||||||
'Nokia',
|
'Nokia',
|
||||||
|
'NOSL',
|
||||||
'Noweb',
|
'Noweb',
|
||||||
'OpenLDAP',
|
'OpenLDAP',
|
||||||
'OpenPBS',
|
'OpenPBS',
|
||||||
|
'OpenSSL',
|
||||||
'OReilly',
|
'OReilly',
|
||||||
'OSL 1.0',
|
'OSL 1.0',
|
||||||
'OSL 1.0+',
|
'OSL 1.0+',
|
||||||
@ -172,8 +175,6 @@ setOption("ValidLicenses", (
|
|||||||
'OSL 2.1+',
|
'OSL 2.1+',
|
||||||
'OSL 3.0',
|
'OSL 3.0',
|
||||||
'OSL 3.0+',
|
'OSL 3.0+',
|
||||||
'OpenSSL',
|
|
||||||
'OReilly',
|
|
||||||
'Phorum',
|
'Phorum',
|
||||||
'PHP',
|
'PHP',
|
||||||
'PlainTeX',
|
'PlainTeX',
|
||||||
@ -186,6 +187,7 @@ setOption("ValidLicenses", (
|
|||||||
'QPL',
|
'QPL',
|
||||||
'Rdisc',
|
'Rdisc',
|
||||||
'RiceBSD',
|
'RiceBSD',
|
||||||
|
'Romio',
|
||||||
'RPSL',
|
'RPSL',
|
||||||
'Ruby',
|
'Ruby',
|
||||||
'Saxpath',
|
'Saxpath',
|
||||||
@ -203,9 +205,9 @@ setOption("ValidLicenses", (
|
|||||||
'TOSL',
|
'TOSL',
|
||||||
'TPL',
|
'TPL',
|
||||||
'UCD',
|
'UCD',
|
||||||
'VOSTROM',
|
|
||||||
'Vim',
|
'Vim',
|
||||||
'VNLSL',
|
'VNLSL',
|
||||||
|
'VOSTROM',
|
||||||
'VSL',
|
'VSL',
|
||||||
'W3C',
|
'W3C',
|
||||||
'Webmin',
|
'Webmin',
|
||||||
@ -216,14 +218,14 @@ setOption("ValidLicenses", (
|
|||||||
'XSkat',
|
'XSkat',
|
||||||
'YPLv1.1',
|
'YPLv1.1',
|
||||||
'Zend',
|
'Zend',
|
||||||
|
'zlib',
|
||||||
|
'zlib with acknowledgement',
|
||||||
'ZPLv1.0',
|
'ZPLv1.0',
|
||||||
'ZPLv1.0+',
|
'ZPLv1.0+',
|
||||||
'ZPLv2.0',
|
'ZPLv2.0',
|
||||||
'ZPLv2.0+',
|
'ZPLv2.0+',
|
||||||
'ZPLv2.1',
|
'ZPLv2.1',
|
||||||
'ZPLv2.1+',
|
'ZPLv2.1+',
|
||||||
'zlib',
|
|
||||||
'zlib with acknowledgement',
|
|
||||||
# Documentation licenses
|
# Documentation licenses
|
||||||
'CDL',
|
'CDL',
|
||||||
'FBSDDL',
|
'FBSDDL',
|
||||||
@ -234,8 +236,8 @@ setOption("ValidLicenses", (
|
|||||||
'Public Use',
|
'Public Use',
|
||||||
# Content licenses
|
# Content licenses
|
||||||
'CC-BY',
|
'CC-BY',
|
||||||
'CC-BY-SA',
|
|
||||||
'CC-BY-ND',
|
'CC-BY-ND',
|
||||||
|
'CC-BY-SA',
|
||||||
'DMTF',
|
'DMTF',
|
||||||
'DSL',
|
'DSL',
|
||||||
'EFML',
|
'EFML',
|
||||||
|
13
rpmlint.spec
13
rpmlint.spec
@ -1,6 +1,6 @@
|
|||||||
Name: rpmlint
|
Name: rpmlint
|
||||||
Version: 0.95
|
Version: 0.96
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Tool for checking common errors in RPM packages
|
Summary: Tool for checking common errors in RPM packages
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -10,8 +10,6 @@ Source0: http://rpmlint.zarb.org/download/%{name}-%{version}.tar.bz2
|
|||||||
Source1: %{name}.config
|
Source1: %{name}.config
|
||||||
Source2: %{name}-CHANGES.package.old
|
Source2: %{name}-CHANGES.package.old
|
||||||
Source3: %{name}-etc.config
|
Source3: %{name}-etc.config
|
||||||
# http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1738/trunk/TagsCheck.py
|
|
||||||
Patch0: %{name}-0.95-srcfilename.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
@ -23,7 +21,7 @@ Requires: python >= 2.4
|
|||||||
%if ! 0%{?rhel}
|
%if ! 0%{?rhel}
|
||||||
# python-magic and python-enchant are actually optional dependencies, but
|
# python-magic and python-enchant are actually optional dependencies, but
|
||||||
# they bring quite desirable features. They're not available in RHEL/EPEL 5
|
# they bring quite desirable features. They're not available in RHEL/EPEL 5
|
||||||
# as of 2010-01-25 though.
|
# as of 2010-04-22 though.
|
||||||
Requires: python-magic
|
Requires: python-magic
|
||||||
Requires: python-enchant
|
Requires: python-enchant
|
||||||
%endif
|
%endif
|
||||||
@ -41,7 +39,6 @@ and source packages as well as spec files can be checked.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0
|
|
||||||
sed -i -e /MenuCheck/d Config.py
|
sed -i -e /MenuCheck/d Config.py
|
||||||
cp -p config config.example
|
cp -p config config.example
|
||||||
install -pm 644 %{SOURCE2} CHANGES.package.old
|
install -pm 644 %{SOURCE2} CHANGES.package.old
|
||||||
@ -81,6 +78,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 22 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.96-1
|
||||||
|
- Update to 0.96; fixes #487974, #571375, #571386, #572090, #572097, #578390.
|
||||||
|
- Sync Fedora license list with Wiki revision 1.71.
|
||||||
|
|
||||||
* Sat Mar 6 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.95-2
|
* Sat Mar 6 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.95-2
|
||||||
- Patch to fix non-coherent-filename regression for source packages.
|
- Patch to fix non-coherent-filename regression for source packages.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user