#461434. - Dist regex patch applied/superseded upstream.
This commit is contained in:
parent
94babe19aa
commit
c7594a76e0
@ -1 +1 @@
|
||||
rpmlint-0.84.tar.bz2
|
||||
rpmlint-0.85.tar.bz2
|
||||
|
@ -1,30 +0,0 @@
|
||||
diff -up rpmlint-0.84/TagsCheck.py.orig rpmlint-0.84/TagsCheck.py
|
||||
--- rpmlint-0.84/TagsCheck.py.orig 2008-05-22 16:19:31.000000000 +0300
|
||||
+++ rpmlint-0.84/TagsCheck.py 2008-07-26 21:54:06.000000000 +0300
|
||||
@@ -398,6 +398,8 @@ packager_regex=re.compile(Config.getOpti
|
||||
basename_regex=re.compile('/?([^/]+)$')
|
||||
changelog_version_regex=re.compile('[^>]([^ >]+)\s*$')
|
||||
changelog_text_version_regex=re.compile('^\s*-\s*((\d+:)?[\w\.]+-[\w\.]+)')
|
||||
+dist_regex=Config.getOption('DistRegex')
|
||||
+if dist_regex: dist_regex=re.compile(dist_regex)
|
||||
release_ext=Config.getOption('ReleaseExtension')
|
||||
extension_regex=release_ext and re.compile(release_ext + '$')
|
||||
use_version_in_changelog=Config.getOption('UseVersionInChangelog', 1)
|
||||
@@ -624,11 +626,13 @@ class TagsCheck(AbstractCheck.AbstractCh
|
||||
srpm = pkg[rpm.RPMTAG_SOURCERPM] or ''
|
||||
# only check when source name correspond to name
|
||||
if srpm[0:-8] == '%s-%s-%s' % (name, version, release):
|
||||
- expected=version + '-' + release
|
||||
+ expected=[version + '-' + release]
|
||||
if epoch is not None: # regardless of use_epoch
|
||||
- expected=str(epoch) + ':' + expected
|
||||
- if expected != ret.group(1):
|
||||
- printWarning(pkg, 'incoherent-version-in-changelog', ret.group(1), expected)
|
||||
+ expected[0]=str(epoch) + ':' + expected[0]
|
||||
+ if dist_regex:
|
||||
+ expected.append(dist_regex.sub('', expected[0]))
|
||||
+ if ret.group(1) not in expected:
|
||||
+ printWarning(pkg, 'incoherent-version-in-changelog', ret.group(1), expected[0])
|
||||
|
||||
if clt: changelog=changelog + clt
|
||||
if use_utf8 and not Pkg.is_utf8_str(' '.join(changelog)):
|
@ -5,7 +5,7 @@
|
||||
|
||||
from Config import *
|
||||
|
||||
setOption("DistRegex", '\.(fc|rhe?l|el)\d+(?=\.|$)')
|
||||
setOption("ReleaseExtension", '\.(fc|rhe?l|el)\d+(?=\.|$)')
|
||||
setOption("UseVersionInChangeLog", 1)
|
||||
setOption("UseBzip2", 0)
|
||||
setOption("UseDefaultRunlevels", 0)
|
||||
@ -249,3 +249,4 @@ addFilter("non-standard-dir-in-usr libexec")
|
||||
addFilter("^gpg-pubkey:")
|
||||
addFilter(" doc-file-dependency .* /bin/sh$")
|
||||
addFilter("hardcoded-library-path .*/lib/udev(/|$)")
|
||||
addFilter("not-standard-release-extension")
|
||||
|
14
rpmlint.spec
14
rpmlint.spec
@ -1,6 +1,6 @@
|
||||
Name: rpmlint
|
||||
Version: 0.84
|
||||
Release: 3%{?dist}
|
||||
Version: 0.85
|
||||
Release: 1%{?dist}
|
||||
Summary: Tool for checking common errors in RPM packages
|
||||
|
||||
Group: Development/Tools
|
||||
@ -9,8 +9,7 @@ URL: http://rpmlint.zarb.org/
|
||||
Source0: http://rpmlint.zarb.org/download/%{name}-%{version}.tar.bz2
|
||||
Source1: %{name}.config
|
||||
Source2: %{name}-CHANGES.package.old
|
||||
Patch0: %{name}-0.84-distregex.patch
|
||||
Patch1: %{name}-0.77-compile.patch
|
||||
Patch0: %{name}-0.77-compile.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildArch: noarch
|
||||
@ -31,8 +30,7 @@ and source packages can be checked.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1
|
||||
%patch0
|
||||
sed -i -e /MenuCheck/d Config.py
|
||||
install -pm 644 %{SOURCE2} CHANGES.package.old
|
||||
|
||||
@ -68,6 +66,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Oct 23 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.85-1
|
||||
- 0.85, fixes #355861, #450011, #455371, #456843, #461421, #461423, #461434.
|
||||
- Dist regex patch applied/superseded upstream.
|
||||
|
||||
* Fri Sep 12 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.84-3
|
||||
- Sync Fedora license list with Wiki revision 1.09
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user