Don't use the %python_sitelib macro, because it errors
See https://fedoraproject.org/wiki/Changes/PythonMacroError
This commit is contained in:
parent
9121f405a5
commit
a5d3b021f3
13
rpmlint-1.11-no-python-macro.patch
Normal file
13
rpmlint-1.11-no-python-macro.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/TagsCheck.py b/TagsCheck.py
|
||||||
|
index 4e32520..a30b485 100644
|
||||||
|
--- a/TagsCheck.py
|
||||||
|
+++ b/TagsCheck.py
|
||||||
|
@@ -437,7 +437,7 @@ oldest_changelog_timestamp = calendar.timegm(time.strptime("1995-01-01", "%Y-%m-
|
||||||
|
|
||||||
|
private_so_paths = set()
|
||||||
|
for path in ('%perl_archlib', '%perl_vendorarch', '%perl_sitearch',
|
||||||
|
- '%python_sitearch', '%python2_sitearch', '%python3_sitearch',
|
||||||
|
+ '%python2_sitearch', '%python3_sitearch',
|
||||||
|
'%ruby_sitearch', '%php_extdir'):
|
||||||
|
epath = rpm.expandMacro(path)
|
||||||
|
if epath and epath != path:
|
10
rpmlint.spec
10
rpmlint.spec
@ -20,7 +20,7 @@
|
|||||||
|
|
||||||
Name: rpmlint
|
Name: rpmlint
|
||||||
Version: 1.11
|
Version: 1.11
|
||||||
Release: 9%{?dist}
|
Release: 10%{?dist}
|
||||||
Summary: Tool for checking common errors in RPM packages
|
Summary: Tool for checking common errors in RPM packages
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: https://github.com/rpm-software-management/rpmlint
|
URL: https://github.com/rpm-software-management/rpmlint
|
||||||
@ -36,6 +36,9 @@ Patch212: rpmlint-1.11-rpm4.15.patch
|
|||||||
# https://github.com/rpm-software-management/rpmlint/pull/363
|
# https://github.com/rpm-software-management/rpmlint/pull/363
|
||||||
# This patch does the same on the 1.11 code
|
# This patch does the same on the 1.11 code
|
||||||
Patch213: rpmlint-1.11-libc-warnings.patch
|
Patch213: rpmlint-1.11-libc-warnings.patch
|
||||||
|
# Don't use the %%python_sitelib macro, because it errors
|
||||||
|
# See https://fedoraproject.org/wiki/Changes/PythonMacroError
|
||||||
|
Patch214: rpmlint-1.11-no-python-macro.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
%if %{with python3}
|
%if %{with python3}
|
||||||
@ -101,6 +104,7 @@ and source packages as well as spec files can be checked.
|
|||||||
%patch199 -p1
|
%patch199 -p1
|
||||||
%patch212 -p1
|
%patch212 -p1
|
||||||
%patch213 -p1
|
%patch213 -p1
|
||||||
|
%patch214 -p1
|
||||||
|
|
||||||
%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
|
%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
|
||||||
# TODO, take upstream (RPM 4.15 related)
|
# TODO, take upstream (RPM 4.15 related)
|
||||||
@ -158,6 +162,10 @@ make check PYTHON=%{python} PYTEST=%{pytest} FLAKE8=%{flake8}
|
|||||||
%{_mandir}/man1/rpmlint.1*
|
%{_mandir}/man1/rpmlint.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 16 2020 Miro Hrončok <mhroncok@redhat.com> - 1.11-10
|
||||||
|
- Don't use the %%python_sitelib macro, because it errors
|
||||||
|
- See https://fedoraproject.org/wiki/Changes/PythonMacroError
|
||||||
|
|
||||||
* Tue Jun 23 2020 Tom Callaway <spot@fedoraproject.org> - 1.11-9
|
* Tue Jun 23 2020 Tom Callaway <spot@fedoraproject.org> - 1.11-9
|
||||||
- use python3-file-magic on f33+
|
- use python3-file-magic on f33+
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user