turn *-not-linked-against-libc from errors to warnings (bz1749738)
This commit is contained in:
parent
02b658689b
commit
86c1640949
16
rpmlint-1.11-libc-warnings.patch
Normal file
16
rpmlint-1.11-libc-warnings.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
diff -up rpmlint-rpmlint-1.11/BinariesCheck.py.libcwarn rpmlint-rpmlint-1.11/BinariesCheck.py
|
||||||
|
--- rpmlint-rpmlint-1.11/BinariesCheck.py.libcwarn 2020-06-16 10:51:01.531299081 -0400
|
||||||
|
+++ rpmlint-rpmlint-1.11/BinariesCheck.py 2020-06-16 10:51:18.978910827 -0400
|
||||||
|
@@ -557,10 +557,10 @@ class BinariesCheck(AbstractCheck.Abstra
|
||||||
|
|
||||||
|
if not found_libc:
|
||||||
|
if is_shobj:
|
||||||
|
- printError(pkg, 'library-not-linked-against-libc',
|
||||||
|
+ printWarning(pkg, 'library-not-linked-against-libc',
|
||||||
|
fname)
|
||||||
|
else:
|
||||||
|
- printError(pkg, 'program-not-linked-against-libc',
|
||||||
|
+ printWarning(pkg, 'program-not-linked-against-libc',
|
||||||
|
fname)
|
||||||
|
|
||||||
|
if bin_info.stack:
|
10
rpmlint.spec
10
rpmlint.spec
@ -20,7 +20,7 @@
|
|||||||
|
|
||||||
Name: rpmlint
|
Name: rpmlint
|
||||||
Version: 1.11
|
Version: 1.11
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
Summary: Tool for checking common errors in RPM packages
|
Summary: Tool for checking common errors in RPM packages
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: https://github.com/rpm-software-management/rpmlint
|
URL: https://github.com/rpm-software-management/rpmlint
|
||||||
@ -32,6 +32,10 @@ Source3: %{name}-etc.config
|
|||||||
Patch199: rpmlint-1.10-suppress-locale-error.patch
|
Patch199: rpmlint-1.10-suppress-locale-error.patch
|
||||||
# https://github.com/rpm-software-management/rpmlint/pull/212
|
# https://github.com/rpm-software-management/rpmlint/pull/212
|
||||||
Patch212: rpmlint-1.11-rpm4.15.patch
|
Patch212: rpmlint-1.11-rpm4.15.patch
|
||||||
|
# Upstream changed to a warning here
|
||||||
|
# https://github.com/rpm-software-management/rpmlint/pull/363
|
||||||
|
# This patch does the same on the 1.11 code
|
||||||
|
Patch213: rpmlint-1.11-libc-warnings.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
%if %{with python3}
|
%if %{with python3}
|
||||||
@ -91,6 +95,7 @@ and source packages as well as spec files can be checked.
|
|||||||
%if %{with python3}
|
%if %{with python3}
|
||||||
%patch199 -p1
|
%patch199 -p1
|
||||||
%patch212 -p1
|
%patch212 -p1
|
||||||
|
%patch213 -p1
|
||||||
|
|
||||||
%if 0%{?fedora} >= 31
|
%if 0%{?fedora} >= 31
|
||||||
# TODO, take upstream (RPM 4.15 related)
|
# TODO, take upstream (RPM 4.15 related)
|
||||||
@ -148,6 +153,9 @@ make check PYTHON=%{python} PYTEST=%{pytest} FLAKE8=%{flake8}
|
|||||||
%{_mandir}/man1/rpmlint.1*
|
%{_mandir}/man1/rpmlint.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 16 2020 Tom Callaway <spot@fedoraproject.org> - 1.11-8
|
||||||
|
- turn *-not-linked-against-libc from errors to warnings (bz1749738)
|
||||||
|
|
||||||
* Wed Jun 10 2020 Tom Callaway <spot@fedoraproject.org> - 1.11-7
|
* Wed Jun 10 2020 Tom Callaway <spot@fedoraproject.org> - 1.11-7
|
||||||
- add /usr/bin/python[23] as valid shells
|
- add /usr/bin/python[23] as valid shells
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user