- Python byte compile patch applied/superseded upstream. - Add <lua> to list of valid scriptlet shells. - Sync Fedora license list with Wiki revision 1.53.
This commit is contained in:
parent
8662069110
commit
83a9a35aba
@ -1 +1 @@
|
|||||||
rpmlint-0.91.tar.bz2
|
rpmlint-0.92.tar.bz2
|
||||||
|
@ -1,23 +0,0 @@
|
|||||||
diff -up rpmlint-0.87/Makefile~ rpmlint-0.87/Makefile
|
|
||||||
--- rpmlint-0.87/Makefile~ 2009-03-19 23:21:37.000000000 +0200
|
|
||||||
+++ rpmlint-0.87/Makefile 2009-03-19 23:26:19.000000000 +0200
|
|
||||||
@@ -36,7 +36,7 @@ clean:
|
|
||||||
|
|
||||||
install:
|
|
||||||
-mkdir -p $(DESTDIR)$(LIBDIR) $(DESTDIR)$(BINDIR) $(DESTDIR)$(ETCDIR)/$(PACKAGE) $(DESTDIR)$(ETCDIR)/bash_completion.d $(DESTDIR)$(MANDIR)/man1
|
|
||||||
- cp -p *.py *.pyo $(DESTDIR)$(LIBDIR)
|
|
||||||
+ cp -p *.py *.pyc *.pyo $(DESTDIR)$(LIBDIR)
|
|
||||||
sed -e 's/@VERSION@/$(VERSION)/' < rpmlint.py > $(DESTDIR)$(LIBDIR)/rpmlint.py
|
|
||||||
cp -p rpmlint rpmdiff $(DESTDIR)$(BINDIR)
|
|
||||||
cp -p config $(DESTDIR)$(ETCDIR)/$(PACKAGE)
|
|
||||||
diff -up rpmlint-0.87/tools/compile.py~ rpmlint-0.87/tools/compile.py
|
|
||||||
--- rpmlint-0.87/tools/compile.py~ 2009-01-27 00:54:06.000000000 +0200
|
|
||||||
+++ rpmlint-0.87/tools/compile.py 2009-03-19 23:26:00.000000000 +0200
|
|
||||||
@@ -14,6 +14,7 @@ import sys
|
|
||||||
|
|
||||||
|
|
||||||
for f in sys.argv[2:]:
|
|
||||||
+ py_compile.compile(f, f + 'c', sys.argv[1] + f)
|
|
||||||
py_compile.compile(f, f + 'o', sys.argv[1] + f)
|
|
||||||
|
|
||||||
# compile.py ends here
|
|
@ -19,6 +19,7 @@ setOption("UseEpoch", False)
|
|||||||
setOption("UseUTF8", True)
|
setOption("UseUTF8", True)
|
||||||
setOption("ValidSrcPerms", (0664, 0644, ))
|
setOption("ValidSrcPerms", (0664, 0644, ))
|
||||||
setOption("ValidShells", (
|
setOption("ValidShells", (
|
||||||
|
"<lua>",
|
||||||
"/bin/sh",
|
"/bin/sh",
|
||||||
"/bin/bash",
|
"/bin/bash",
|
||||||
"/sbin/ldconfig",
|
"/sbin/ldconfig",
|
||||||
@ -34,7 +35,7 @@ setOption("DanglingSymlinkExceptions", (
|
|||||||
setOption("ValidLicenses", (
|
setOption("ValidLicenses", (
|
||||||
# These are the short names for all of the Fedora approved licenses.
|
# These are the short names for all of the Fedora approved licenses.
|
||||||
# The master list is kept here: http://fedoraproject.org/wiki/Licensing
|
# The master list is kept here: http://fedoraproject.org/wiki/Licensing
|
||||||
# Last synced with revision "1.49, 15 August 2009" of that page.
|
# Last synced with revision "1.53, 8 Oct 2009" of that page.
|
||||||
'AAL',
|
'AAL',
|
||||||
'Adobe',
|
'Adobe',
|
||||||
'ADSL',
|
'ADSL',
|
||||||
@ -132,6 +133,7 @@ setOption("ValidLicenses", (
|
|||||||
'MirOS',
|
'MirOS',
|
||||||
'MIT',
|
'MIT',
|
||||||
'MIT with advertising',
|
'MIT with advertising',
|
||||||
|
'mod_macro',
|
||||||
'Motosoto',
|
'Motosoto',
|
||||||
'MPLv1.0',
|
'MPLv1.0',
|
||||||
'MPLv1.0+',
|
'MPLv1.0+',
|
||||||
|
17
rpmlint.spec
17
rpmlint.spec
@ -1,5 +1,5 @@
|
|||||||
Name: rpmlint
|
Name: rpmlint
|
||||||
Version: 0.91
|
Version: 0.92
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Tool for checking common errors in RPM packages
|
Summary: Tool for checking common errors in RPM packages
|
||||||
|
|
||||||
@ -10,8 +10,6 @@ Source0: http://rpmlint.zarb.org/download/%{name}-%{version}.tar.bz2
|
|||||||
Source1: %{name}.config
|
Source1: %{name}.config
|
||||||
Source2: %{name}-CHANGES.package.old
|
Source2: %{name}-CHANGES.package.old
|
||||||
Source3: %{name}-etc.config
|
Source3: %{name}-etc.config
|
||||||
# Fedora specific, not upstreamable
|
|
||||||
Patch0: %{name}-0.87-compile.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
@ -20,8 +18,10 @@ BuildRequires: rpm-python >= 4.4
|
|||||||
BuildRequires: sed >= 3.95
|
BuildRequires: sed >= 3.95
|
||||||
Requires: rpm-python >= 4.4
|
Requires: rpm-python >= 4.4
|
||||||
Requires: python >= 2.4
|
Requires: python >= 2.4
|
||||||
# python-magic is strictly speaking an optional dep, but it's quite desirable.
|
# python-magic and python-enchant are actually optional dependencies, but
|
||||||
|
# they bring quite desirable features.
|
||||||
Requires: python-magic
|
Requires: python-magic
|
||||||
|
Requires: python-enchant
|
||||||
Requires: cpio
|
Requires: cpio
|
||||||
Requires: binutils
|
Requires: binutils
|
||||||
Requires: desktop-file-utils
|
Requires: desktop-file-utils
|
||||||
@ -36,14 +36,13 @@ and source packages as well as spec files can be checked.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
sed -i -e /MenuCheck/d Config.py
|
sed -i -e /MenuCheck/d Config.py
|
||||||
install -pm 644 %{SOURCE2} CHANGES.package.old
|
install -pm 644 %{SOURCE2} CHANGES.package.old
|
||||||
install -pm 644 %{SOURCE3} config
|
install -pm 644 %{SOURCE3} config
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make
|
make COMPILE_PYC=1
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -75,6 +74,12 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 2 2009 Ville Skyttä <ville.skytta@iki.fi> - 0.92-1
|
||||||
|
- Update to 0.92; fixes #528535, and #531102 (partially).
|
||||||
|
- Python byte compile patch applied/superseded upstream.
|
||||||
|
- Add <lua> to list of valid scriptlet shells.
|
||||||
|
- Sync Fedora license list with Wiki revision 1.53.
|
||||||
|
|
||||||
* Mon Sep 14 2009 Ville Skyttä <ville.skytta@iki.fi> - 0.91-1
|
* Mon Sep 14 2009 Ville Skyttä <ville.skytta@iki.fi> - 0.91-1
|
||||||
- Update to 0.91; fixes #513811, #515185, #516492, #519694, and #521630.
|
- Update to 0.91; fixes #513811, #515185, #516492, #519694, and #521630.
|
||||||
- Add dependencies on gzip, bzip2, and xz.
|
- Add dependencies on gzip, bzip2, and xz.
|
||||||
|
Loading…
Reference in New Issue
Block a user