#489118. - Sync Fedora license list with Wiki revision 1.38. - Configs patch included upstream.
This commit is contained in:
parent
d6011dd7f2
commit
8159ef4328
@ -1 +1 @@
|
||||
rpmlint-0.85.tar.bz2
|
||||
rpmlint-0.87.tar.bz2
|
||||
|
@ -1,50 +0,0 @@
|
||||
Index: rpmlint.py
|
||||
===================================================================
|
||||
--- rpmlint.py (revision 1466)
|
||||
+++ rpmlint.py (revision 1467)
|
||||
@@ -12,6 +12,7 @@
|
||||
import AbstractCheck
|
||||
import imp
|
||||
import getopt
|
||||
+import glob
|
||||
import Pkg
|
||||
import Config
|
||||
import os
|
||||
@@ -214,7 +215,10 @@
|
||||
info_error=0
|
||||
|
||||
# load global config files
|
||||
-for f in ('/usr/share/rpmlint/config','/etc/rpmlint/config'):
|
||||
+configs = glob.glob('/etc/rpmlint/*config')
|
||||
+configs.sort()
|
||||
+configs.insert(0, '/usr/share/rpmlint/config')
|
||||
+for f in configs:
|
||||
try:
|
||||
execfile(f)
|
||||
except IOError:
|
||||
Index: rpmlint.1
|
||||
===================================================================
|
||||
--- rpmlint.1 (revision 1466)
|
||||
+++ rpmlint.1 (revision 1467)
|
||||
@@ -55,7 +55,7 @@
|
||||
\fB/usr/share/rpmlint/config\fR
|
||||
Built-in configuration.
|
||||
.TP
|
||||
-\fB/etc/rpmlint/config\fR
|
||||
+\fB/etc/rpmlint/*config\fR
|
||||
System wide configuration.
|
||||
.TP
|
||||
\fB~/.rpmlintrc\fR
|
||||
Index: README
|
||||
===================================================================
|
||||
--- README (revision 1466)
|
||||
+++ README (revision 1467)
|
||||
@@ -30,7 +30,7 @@
|
||||
o Rpm file checks (RpmFileCheck).
|
||||
|
||||
If you want to change configuration options or the list of checks, use
|
||||
-the global configuration file /etc/rpmlint/config or in the user
|
||||
+the global configuration files /etc/rpmlint/*config or the user
|
||||
configuration file ~/.rpmlintrc.
|
||||
|
||||
Configuration files are Python source files and should begin with the
|
@ -1,23 +1,23 @@
|
||||
diff -up rpmlint-0.85/compile.py.orig rpmlint-0.85/compile.py
|
||||
--- rpmlint-0.85/compile.py.orig 2006-04-01 11:09:19.000000000 +0300
|
||||
+++ rpmlint-0.85/compile.py 2008-10-23 23:33:03.000000000 +0300
|
||||
@@ -12,6 +12,7 @@ import py_compile
|
||||
import sys
|
||||
|
||||
for f in sys.argv[2:]:
|
||||
+ py_compile.compile(f, f + 'c', sys.argv[1] + f)
|
||||
py_compile.compile(f, f + 'o', sys.argv[1] + f)
|
||||
|
||||
# compile.py ends here
|
||||
diff -up rpmlint-0.85/Makefile.orig rpmlint-0.85/Makefile
|
||||
--- rpmlint-0.85/Makefile.orig 2008-10-23 22:47:48.000000000 +0300
|
||||
+++ rpmlint-0.85/Makefile 2008-10-23 23:33:03.000000000 +0300
|
||||
diff -up rpmlint-0.87/Makefile~ rpmlint-0.87/Makefile
|
||||
--- rpmlint-0.87/Makefile~ 2009-03-19 23:21:37.000000000 +0200
|
||||
+++ rpmlint-0.87/Makefile 2009-03-19 23:26:19.000000000 +0200
|
||||
@@ -36,7 +36,7 @@ clean:
|
||||
|
||||
install:
|
||||
-mkdir -p $(DESTDIR)$(LIBDIR) $(DESTDIR)$(BINDIR) $(DESTDIR)$(ETCDIR)/$(PACKAGE) $(DESTDIR)$(ETCDIR)/bash_completion.d $(DESTDIR)$(MANDIR)/man1
|
||||
- cp -p *.py *.pyo $(DESTDIR)$(LIBDIR)
|
||||
+ cp -p *.py *.pyc *.pyo $(DESTDIR)$(LIBDIR)
|
||||
rm -f $(DESTDIR)$(LIBDIR)/compile.py*
|
||||
sed -e 's/@VERSION@/$(VERSION)/' < rpmlint.py > $(DESTDIR)$(LIBDIR)/rpmlint.py
|
||||
cp -p rpmlint rpmdiff $(DESTDIR)$(BINDIR)
|
||||
cp -p config $(DESTDIR)$(ETCDIR)/$(PACKAGE)
|
||||
diff -up rpmlint-0.87/tools/compile.py~ rpmlint-0.87/tools/compile.py
|
||||
--- rpmlint-0.87/tools/compile.py~ 2009-01-27 00:54:06.000000000 +0200
|
||||
+++ rpmlint-0.87/tools/compile.py 2009-03-19 23:26:00.000000000 +0200
|
||||
@@ -14,6 +14,7 @@ import sys
|
||||
|
||||
|
||||
for f in sys.argv[2:]:
|
||||
+ py_compile.compile(f, f + 'c', sys.argv[1] + f)
|
||||
py_compile.compile(f, f + 'o', sys.argv[1] + f)
|
||||
|
||||
# compile.py ends here
|
@ -28,7 +28,7 @@ setOption("DanglingSymlinkExceptions", (
|
||||
setOption("ValidLicenses", (
|
||||
# These are the short names for all of the Fedora approved licenses.
|
||||
# The master list is kept here: http://fedoraproject.org/wiki/Licensing
|
||||
# Last synced with revision "1.34, 22 Dec 2008" of that page.
|
||||
# Last synced with revision "1.38, 27 Feb 2009" of that page.
|
||||
'AAL',
|
||||
'Adobe',
|
||||
'ADSL',
|
||||
@ -82,6 +82,7 @@ setOption("ValidLicenses", (
|
||||
'gnuplot',
|
||||
'GPL+',
|
||||
'GPL+ or Artistic',
|
||||
'GPL+ with exceptions',
|
||||
'GPLv1',
|
||||
'GPLv2 or Artistic',
|
||||
'GPLv2+ or Artistic',
|
||||
@ -159,11 +160,13 @@ setOption("ValidLicenses", (
|
||||
'RiceBSD',
|
||||
'RPSL',
|
||||
'Ruby',
|
||||
'SCEA',
|
||||
'SCRIP',
|
||||
'Sendmail',
|
||||
'Sleepycat',
|
||||
'SISSL',
|
||||
'SLIB',
|
||||
'SNIA',
|
||||
'SPL',
|
||||
'TCL',
|
||||
'Teeworlds',
|
||||
|
27
rpmlint.spec
27
rpmlint.spec
@ -1,6 +1,6 @@
|
||||
Name: rpmlint
|
||||
Version: 0.85
|
||||
Release: 4%{?dist}
|
||||
Version: 0.87
|
||||
Release: 1%{?dist}
|
||||
Summary: Tool for checking common errors in RPM packages
|
||||
|
||||
Group: Development/Tools
|
||||
@ -11,31 +11,29 @@ Source1: %{name}.config
|
||||
Source2: %{name}-CHANGES.package.old
|
||||
Source3: %{name}-etc.config
|
||||
# Fedora specific, not upstreamable
|
||||
Patch0: %{name}-0.85-compile.patch
|
||||
# From upstream svn
|
||||
Patch1: %{name}-0.85-configs.patch
|
||||
Patch0: %{name}-0.87-compile.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: python >= 2.2
|
||||
BuildRequires: rpm-python
|
||||
BuildRequires: python >= 2.4
|
||||
BuildRequires: rpm-python >= 4.4
|
||||
BuildRequires: sed >= 3.95
|
||||
Requires: rpm-python
|
||||
Requires: python >= 2.2
|
||||
Requires: rpm-python >= 4.4
|
||||
Requires: python >= 2.4
|
||||
# python-magic is strictly speaking an optional dep, but it's quite desirable.
|
||||
Requires: python-magic
|
||||
Requires: cpio
|
||||
Requires: binutils
|
||||
Requires: desktop-file-utils
|
||||
Requires: file
|
||||
|
||||
%description
|
||||
rpmlint is a tool for checking common errors in RPM packages. Binary
|
||||
and source packages can be checked.
|
||||
and source packages as well as spec files can be checked.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p0
|
||||
sed -i -e /MenuCheck/d Config.py
|
||||
install -pm 644 %{SOURCE2} CHANGES.package.old
|
||||
install -pm 644 %{SOURCE3} config
|
||||
@ -70,6 +68,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Mar 19 2009 Ville Skyttä <ville.skytta at iki.fi> - 0.87-1
|
||||
- 0.87; fixes #480664, #483196, #483199, #486748, #488146, #488930, #489118.
|
||||
- Sync Fedora license list with Wiki revision 1.38.
|
||||
- Configs patch included upstream.
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.85-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user