- Apply upstream patch to load all *config from /etc/rpmlint.
This commit is contained in:
parent
db474668e1
commit
7600974212
50
rpmlint-0.85-configs.patch
Normal file
50
rpmlint-0.85-configs.patch
Normal file
@ -0,0 +1,50 @@
|
|||||||
|
Index: rpmlint.py
|
||||||
|
===================================================================
|
||||||
|
--- rpmlint.py (revision 1466)
|
||||||
|
+++ rpmlint.py (revision 1467)
|
||||||
|
@@ -12,6 +12,7 @@
|
||||||
|
import AbstractCheck
|
||||||
|
import imp
|
||||||
|
import getopt
|
||||||
|
+import glob
|
||||||
|
import Pkg
|
||||||
|
import Config
|
||||||
|
import os
|
||||||
|
@@ -214,7 +215,10 @@
|
||||||
|
info_error=0
|
||||||
|
|
||||||
|
# load global config files
|
||||||
|
-for f in ('/usr/share/rpmlint/config','/etc/rpmlint/config'):
|
||||||
|
+configs = glob.glob('/etc/rpmlint/*config')
|
||||||
|
+configs.sort()
|
||||||
|
+configs.insert(0, '/usr/share/rpmlint/config')
|
||||||
|
+for f in configs:
|
||||||
|
try:
|
||||||
|
execfile(f)
|
||||||
|
except IOError:
|
||||||
|
Index: rpmlint.1
|
||||||
|
===================================================================
|
||||||
|
--- rpmlint.1 (revision 1466)
|
||||||
|
+++ rpmlint.1 (revision 1467)
|
||||||
|
@@ -55,7 +55,7 @@
|
||||||
|
\fB/usr/share/rpmlint/config\fR
|
||||||
|
Built-in configuration.
|
||||||
|
.TP
|
||||||
|
-\fB/etc/rpmlint/config\fR
|
||||||
|
+\fB/etc/rpmlint/*config\fR
|
||||||
|
System wide configuration.
|
||||||
|
.TP
|
||||||
|
\fB~/.rpmlintrc\fR
|
||||||
|
Index: README
|
||||||
|
===================================================================
|
||||||
|
--- README (revision 1466)
|
||||||
|
+++ README (revision 1467)
|
||||||
|
@@ -30,7 +30,7 @@
|
||||||
|
o Rpm file checks (RpmFileCheck).
|
||||||
|
|
||||||
|
If you want to change configuration options or the list of checks, use
|
||||||
|
-the global configuration file /etc/rpmlint/config or in the user
|
||||||
|
+the global configuration files /etc/rpmlint/*config or the user
|
||||||
|
configuration file ~/.rpmlintrc.
|
||||||
|
|
||||||
|
Configuration files are Python source files and should begin with the
|
2
rpmlint-etc.config
Normal file
2
rpmlint-etc.config
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
# Add local system wide rpmlint configuration here or in other *config files
|
||||||
|
# in this directory.
|
@ -28,7 +28,7 @@ setOption("DanglingSymlinkExceptions", (
|
|||||||
setOption("ValidLicenses", (
|
setOption("ValidLicenses", (
|
||||||
# These are the short names for all of the Fedora approved licenses.
|
# These are the short names for all of the Fedora approved licenses.
|
||||||
# The master list is kept here: http://fedoraproject.org/wiki/Licensing
|
# The master list is kept here: http://fedoraproject.org/wiki/Licensing
|
||||||
# Last synced with revision "1.19, 23 Oct 2008" of that page.
|
# Last synced with revision "1.20, 30 Oct 2008" of that page.
|
||||||
'AAL',
|
'AAL',
|
||||||
'Adobe',
|
'Adobe',
|
||||||
'ADSL',
|
'ADSL',
|
||||||
|
13
rpmlint.spec
13
rpmlint.spec
@ -1,6 +1,6 @@
|
|||||||
Name: rpmlint
|
Name: rpmlint
|
||||||
Version: 0.85
|
Version: 0.85
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Tool for checking common errors in RPM packages
|
Summary: Tool for checking common errors in RPM packages
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -9,7 +9,11 @@ URL: http://rpmlint.zarb.org/
|
|||||||
Source0: http://rpmlint.zarb.org/download/%{name}-%{version}.tar.bz2
|
Source0: http://rpmlint.zarb.org/download/%{name}-%{version}.tar.bz2
|
||||||
Source1: %{name}.config
|
Source1: %{name}.config
|
||||||
Source2: %{name}-CHANGES.package.old
|
Source2: %{name}-CHANGES.package.old
|
||||||
|
Source3: %{name}-etc.config
|
||||||
|
# Fedora specific, not upstreamable
|
||||||
Patch0: %{name}-0.85-compile.patch
|
Patch0: %{name}-0.85-compile.patch
|
||||||
|
# From upstream svn
|
||||||
|
Patch1: %{name}-0.85-configs.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
@ -31,8 +35,10 @@ and source packages can be checked.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p0
|
||||||
sed -i -e /MenuCheck/d Config.py
|
sed -i -e /MenuCheck/d Config.py
|
||||||
install -pm 644 %{SOURCE2} CHANGES.package.old
|
install -pm 644 %{SOURCE2} CHANGES.package.old
|
||||||
|
install -pm 644 %{SOURCE3} config
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -44,8 +50,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
touch rpmlint.pyc rpmlint.pyo # just for the %%exclude to work everywhere
|
touch rpmlint.pyc rpmlint.pyo # just for the %%exclude to work everywhere
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT ETCDIR=%{_sysconfdir} MANDIR=%{_mandir} \
|
make install DESTDIR=$RPM_BUILD_ROOT ETCDIR=%{_sysconfdir} MANDIR=%{_mandir} \
|
||||||
LIBDIR=%{_datadir}/rpmlint BINDIR=%{_bindir}
|
LIBDIR=%{_datadir}/rpmlint BINDIR=%{_bindir}
|
||||||
echo "# Add local system wide rpmlint configuration here." \
|
|
||||||
> $RPM_BUILD_ROOT%{_sysconfdir}/rpmlint/config
|
|
||||||
install -pm 644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/rpmlint/config
|
install -pm 644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/rpmlint/config
|
||||||
|
|
||||||
|
|
||||||
@ -66,6 +70,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 30 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.85-2
|
||||||
|
- Apply upstream patch to load all *config from /etc/rpmlint.
|
||||||
|
|
||||||
* Thu Oct 23 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.85-1
|
* Thu Oct 23 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.85-1
|
||||||
- 0.85, fixes #355861, #450011, #455371, #456843, #461421, #461423, #461434.
|
- 0.85, fixes #355861, #450011, #455371, #456843, #461421, #461423, #461434.
|
||||||
- Mute some explicit-lib-dependency false positives (#458290).
|
- Mute some explicit-lib-dependency false positives (#458290).
|
||||||
|
Loading…
Reference in New Issue
Block a user