- 0.76.
Mon Mar 27 2006 Ville Skyttä <ville.skytta at iki.fi> - Don't pass -T to objdump for *.debug files (#185227). - lib64 library path fixes (#185228). Wed Mar 15 2006 Ville Skyttä <ville.skytta at iki.fi> - Accept zlib License (#185501). Tue Feb 28 2006 Ville Skyttä <ville.skytta at iki.fi> - Accept Ruby License (#183384) and SIL Open Font License (#176405).
This commit is contained in:
parent
0a44b85bcc
commit
503da0b02c
@ -1 +1 @@
|
|||||||
rpmlint-0.75.tar.bz2
|
rpmlint-0.76.tar.bz2
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
Index: FilesCheck.py
|
|
||||||
===================================================================
|
|
||||||
RCS file: /cooker/soft/rpmlint/FilesCheck.py,v
|
|
||||||
retrieving revision 1.96
|
|
||||||
diff -u -U1 -r1.96 FilesCheck.py
|
|
||||||
--- FilesCheck.py 15 Jan 2006 09:59:04 -0000 1.96
|
|
||||||
+++ FilesCheck.py 15 Jan 2006 21:08:24 -0000
|
|
||||||
@@ -565,3 +565,3 @@
|
|
||||||
|
|
||||||
- if mode & 0111 == 0:
|
|
||||||
+ if mode & 0111 == 0 and not doc_regex.search(f):
|
|
||||||
printError(pkg, 'non-executable-script', f, oct(perm))
|
|
@ -1,16 +0,0 @@
|
|||||||
Index: FilesCheck.py
|
|
||||||
===================================================================
|
|
||||||
RCS file: /cooker/soft/rpmlint/FilesCheck.py,v
|
|
||||||
retrieving revision 1.96
|
|
||||||
diff -u -U1 -r1.96 FilesCheck.py
|
|
||||||
--- FilesCheck.py 15 Jan 2006 09:59:04 -0000 1.96
|
|
||||||
+++ FilesCheck.py 15 Jan 2006 21:08:59 -0000
|
|
||||||
@@ -189,2 +189,3 @@
|
|
||||||
script_regex=re.compile('^/((usr/)?s?bin|etc/(rc.d/init.d|profile.d|X11/xinit.d|cron.(hourly|daily|monthly|weekly)))/')
|
|
||||||
+libtool_archive_regex=re.compile('\.la$')
|
|
||||||
lib64python_regex=re.compile('^/usr/lib64/python')
|
|
||||||
@@ -562,3 +563,3 @@
|
|
||||||
printError(pkg, 'wrong-script-interpreter', f, '"' + res.group(1) + '"')
|
|
||||||
- else:
|
|
||||||
+ elif not (lib_path_regex.search(f) and libtool_archive_regex.search(f)):
|
|
||||||
printError(pkg, 'script-without-shellbang', f)
|
|
@ -1,44 +0,0 @@
|
|||||||
Index: SpecCheck.py
|
|
||||||
===================================================================
|
|
||||||
RCS file: /cooker/soft/rpmlint/SpecCheck.py,v
|
|
||||||
retrieving revision 1.32
|
|
||||||
diff -u -r1.32 SpecCheck.py
|
|
||||||
--- SpecCheck.py 15 Jan 2006 09:59:04 -0000 1.32
|
|
||||||
+++ SpecCheck.py 15 Jan 2006 21:05:12 -0000
|
|
||||||
@@ -45,6 +45,7 @@
|
|
||||||
biarch_package_regex=re.compile(DEFAULT_BIARCH_PACKAGES)
|
|
||||||
hardcoded_lib_path_exceptions_regex=re.compile(Config.getOption('HardcodedLibPathExceptions', DEFAULT_HARDCODED_LIB_PATH_EXCEPTIONS))
|
|
||||||
prereq_regex=re.compile('^PreReq:\s*(.+?)\s*$', re.IGNORECASE)
|
|
||||||
+buildprereq_regex=re.compile('^BuildPreReq:\s*(.+?)\s*$', re.IGNORECASE)
|
|
||||||
use_utf8=Config.getOption('UseUTF8', Config.USEUTF8_DEFAULT)
|
|
||||||
|
|
||||||
# Only check for /lib, /usr/lib, /usr/X11R6/lib
|
|
||||||
@@ -190,7 +191,11 @@
|
|
||||||
|
|
||||||
res=prereq_regex.search(line)
|
|
||||||
if res:
|
|
||||||
- printError(pkg, 'prereq-use', res.group(1))
|
|
||||||
+ printWarning(pkg, 'prereq-use', res.group(1))
|
|
||||||
+
|
|
||||||
+ res=buildprereq_regex.search(line)
|
|
||||||
+ if res:
|
|
||||||
+ printWarning(pkg, 'buildprereq-use', res.group(1))
|
|
||||||
|
|
||||||
if not buildroot:
|
|
||||||
printError(pkg, 'no-buildroot-tag')
|
|
||||||
@@ -284,8 +289,13 @@
|
|
||||||
patch to be effective only on a given arch.''',
|
|
||||||
|
|
||||||
'prereq-use',
|
|
||||||
-'''The use of PreReq is deprecated. You should use Requires(pre), Requires(post),
|
|
||||||
-Requires(preun) or Requires(postun) according to your needs.''',
|
|
||||||
+'''The use of PreReq is deprecated. In the majority of cases, a plain Requires
|
|
||||||
+is enough and the right thing to do. Sometimes Requires(pre), Requires(post),
|
|
||||||
+Requires(preun) and/or Requires(postun) can also be used instead of PreReq.''',
|
|
||||||
+
|
|
||||||
+'buildprereq-use',
|
|
||||||
+'''The use of BuildPreReq is deprecated, build dependencies are always required
|
|
||||||
+before a package can be built. Use plain BuildRequires instead.''',
|
|
||||||
|
|
||||||
)
|
|
||||||
|
|
@ -1,7 +0,0 @@
|
|||||||
--- TagsCheck.py 31 Jan 2006 10:49:33 -0000 1.90
|
|
||||||
+++ TagsCheck.py 17 Feb 2006 22:55:43 -0000 1.91
|
|
||||||
@@ -553,3 +553,3 @@
|
|
||||||
elif version:
|
|
||||||
- if use_epoch:
|
|
||||||
+ if epoch is not None: # regardless of use_epoch
|
|
||||||
expected=str(epoch) + ":" + version
|
|
13
rpmlint-0.76-debuginfo.patch
Normal file
13
rpmlint-0.76-debuginfo.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Index: FilesCheck.py
|
||||||
|
===================================================================
|
||||||
|
--- FilesCheck.py (revision 1144)
|
||||||
|
+++ FilesCheck.py (working copy)
|
||||||
|
@@ -158,7 +158,7 @@
|
||||||
|
includefile_regex=re.compile('\.(c|h|a|cmi)$')
|
||||||
|
buildconfigfile_regex=re.compile('(\.pc|/bin/.+-config)$')
|
||||||
|
sofile_regex=re.compile('/lib(64)?/[^/]+\.so$')
|
||||||
|
-devel_regex=re.compile('-(devel|source)$')
|
||||||
|
+devel_regex=re.compile('-(debug(info)?|devel|source)$')
|
||||||
|
lib_regex=re.compile('lib(64)?/lib[^/]*\.so\..*')
|
||||||
|
ldconfig_regex=re.compile('^[^#]*ldconfig', re.MULTILINE)
|
||||||
|
depmod_regex=re.compile('^[^#]*depmod', re.MULTILINE)
|
@ -1,10 +1,10 @@
|
|||||||
--- TagsCheck.py~ 2006-01-15 23:33:42.000000000 +0200
|
--- TagsCheck.py~ 2006-04-05 19:21:45.000000000 +0300
|
||||||
+++ TagsCheck.py 2006-01-15 23:34:30.000000000 +0200
|
+++ TagsCheck.py 2006-04-08 23:04:04.000000000 +0300
|
||||||
@@ -424,2 +424,3 @@
|
@@ -342,2 +342,3 @@
|
||||||
changelog_version_regex=re.compile('[^>]([^ >]+)\s*$')
|
changelog_version_regex=re.compile('[^>]([^ >]+)\s*$')
|
||||||
+fedora_disttag_regex=re.compile('\.(fc|rhe?l)\d+$')
|
+fedora_disttag_regex=re.compile('\.(fc|rhe?l)\d+$')
|
||||||
release_ext=Config.getOption('ReleaseExtension', 'mdk')
|
release_ext=Config.getOption('ReleaseExtension')
|
||||||
@@ -636,3 +637,3 @@
|
@@ -556,3 +557,3 @@
|
||||||
expected=str(epoch) + ':' + expected
|
expected=str(epoch) + ':' + expected
|
||||||
- if expected != ret.group(1):
|
- if expected != ret.group(1):
|
||||||
+ if ret.group(1) not in (expected, fedora_disttag_regex.sub('', expected)):
|
+ if ret.group(1) not in (expected, fedora_disttag_regex.sub('', expected)):
|
@ -4,9 +4,6 @@
|
|||||||
|
|
||||||
from Config import *
|
from Config import *
|
||||||
|
|
||||||
setOption("ReleaseExtension", '')
|
|
||||||
setOption("ValidBuildHost", ".*")
|
|
||||||
setOption("Packager", ".*")
|
|
||||||
setOption("UseVersionInChangeLog", 1)
|
setOption("UseVersionInChangeLog", 1)
|
||||||
setOption("UseBzip2", 0)
|
setOption("UseBzip2", 0)
|
||||||
setOption("UseDefaultRunlevels", 0)
|
setOption("UseDefaultRunlevels", 0)
|
||||||
@ -65,8 +62,11 @@ setOption("ValidLicenses", (
|
|||||||
"Public Domain",
|
"Public Domain",
|
||||||
"Python Software Foundation License",
|
"Python Software Foundation License",
|
||||||
"QPL",
|
"QPL",
|
||||||
|
"Ruby License",
|
||||||
"Sun Public License",
|
"Sun Public License",
|
||||||
|
"SIL Open Font License",
|
||||||
"W3C Software License",
|
"W3C Software License",
|
||||||
|
"zlib License",
|
||||||
"Zope Public License",
|
"Zope Public License",
|
||||||
))
|
))
|
||||||
setOption("ValidShells", (
|
setOption("ValidShells", (
|
||||||
@ -82,22 +82,23 @@ setOption("DanglingSymlinkExceptions", (
|
|||||||
))
|
))
|
||||||
|
|
||||||
# Output filters
|
# Output filters
|
||||||
addFilter("W: .* source-or-patch-not-[bg]zipped .*")
|
addFilter("source-or-patch-not-[bg]zipped")
|
||||||
addFilter("E: .* lib-package-without-%mklibname")
|
addFilter("%mklibname")
|
||||||
addFilter("E: .* no-dependency-on (perl|python)-base.*")
|
addFilter("no-dependency-on (perl|python)-base")
|
||||||
addFilter("E: .* no-dependency-on locales-.*")
|
addFilter("no-dependency-on locales-")
|
||||||
addFilter("W: .* (python|perl5)-naming-policy-not-applied.*")
|
addFilter("(python|perl5)-naming-policy-not-applied")
|
||||||
addFilter("W: .* invalid-(distribution|vendor) .*")
|
addFilter("no-(packager-tag|signature)")
|
||||||
addFilter("E: .* no-(packager-tag|signature)")
|
addFilter("incoherent-version-in-name")
|
||||||
addFilter("E: .* incoherent-version-in-name.*")
|
addFilter("invalid-build-requires")
|
||||||
addFilter("E: .* invalid-build-requires .*")
|
addFilter("ghost-files-without-postin")
|
||||||
addFilter("W: .* ghost-files-without-postin")
|
addFilter("postin-without-ghost-file-creation")
|
||||||
addFilter("W: .* postin-without-ghost-file-creation .*")
|
addFilter("no-major-in-name")
|
||||||
addFilter("W: .* no-major-in-name .*")
|
addFilter("no-provides")
|
||||||
addFilter("W: .* no-provides .*")
|
addFilter("executable-in-library-package")
|
||||||
addFilter("E: .* executable-in-library-package .*")
|
addFilter("non-versioned-file-in-library-package")
|
||||||
addFilter("E: .* non-versioned-file-in-library-package .*")
|
addFilter("requires-on-release")
|
||||||
addFilter("E: .* requires-on-release .*")
|
addFilter("jar-not-indexed")
|
||||||
addFilter("W: .* jar-not-indexed .*")
|
addFilter("invalid-(lc-messages|locale-man)-dir")
|
||||||
addFilter("E: .* invalid-(lc-messages|locale-man)-dir .*")
|
addFilter("outside-libdir-files")
|
||||||
addFilter("E: .* outside-libdir-files .*")
|
addFilter('-debuginfo no-documentation')
|
||||||
|
addFilter('-debuginfo [^ ]+ /usr/lib/debug/')
|
||||||
|
54
rpmlint.spec
54
rpmlint.spec
@ -1,19 +1,19 @@
|
|||||||
|
# TODO:
|
||||||
|
# - don't override upstream default valid groups, just add "Development/Debug"
|
||||||
|
# - switch to upstream valid license list?
|
||||||
|
|
||||||
Name: rpmlint
|
Name: rpmlint
|
||||||
Version: 0.75
|
Version: 0.76
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Tool for checking common errors in RPM packages
|
Summary: Tool for checking common errors in RPM packages
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: GPL
|
License: GPL
|
||||||
URL: http://people.mandriva.com/~flepied/projects/rpmlint/
|
URL: http://rpmlint.zarb.org/
|
||||||
#Source0: http://people.mandriva.com/~flepied/projects/rpmlint/dist/%{name}-%{version}.tar.bz2
|
Source0: http://rpmlint.zarb.org/download/%{name}-%{version}.tar.bz2
|
||||||
Source0: http://www.zarb.org/~misc/%{name}-%{version}.tar.bz2
|
|
||||||
Source1: %{name}-fedora-config
|
Source1: %{name}-fedora-config
|
||||||
Patch0: %{name}-0.71-disttag.patch
|
Patch0: %{name}-0.76-disttag.patch
|
||||||
Patch1: %{name}-0.75-develdep.patch
|
Patch1: %{name}-0.76-debuginfo.patch
|
||||||
Patch2: %{name}-0.71-prereq.patch
|
|
||||||
Patch3: %{name}-0.71-la-exec.patch
|
|
||||||
Patch4: %{name}-0.71-doc-exec.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
@ -34,14 +34,8 @@ and source packages can be checked.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0
|
%patch0
|
||||||
%patch1
|
%patch1
|
||||||
%patch2
|
|
||||||
%patch3
|
|
||||||
%patch4
|
|
||||||
sed -i -e 's|/etc/httpd/webapps\.d|%{_sysconfdir}/httpd/conf.d|' \
|
sed -i -e 's|/etc/httpd/webapps\.d|%{_sysconfdir}/httpd/conf.d|' \
|
||||||
FilesCheck.py I18NCheck.py
|
FilesCheck.py I18NCheck.py
|
||||||
for f in AUTHORS ChangeLog ; do
|
|
||||||
iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
|
|
||||||
done
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -50,15 +44,16 @@ make
|
|||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=$RPM_BUILD_ROOT ETCDIR=%{_sysconfdir} MANDIR=%{_mandir} \
|
||||||
rm $RPM_BUILD_ROOT%{_datadir}/rpmlint/check-install.py*
|
LIBDIR=%{_datadir}/rpmlint BINDIR=%{_bindir}
|
||||||
install -Dpm 644 rpmlint.bash-completion \
|
echo "# Add local rpmlint configuration here." \
|
||||||
$RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/rpmlint
|
> $RPM_BUILD_ROOT%{_sysconfdir}/rpmlint/config
|
||||||
install -pm 644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpmlint/config
|
install -pm 644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/rpmlint/config
|
||||||
|
|
||||||
# Take care of files that may be generated later.
|
# Take care of files that may be generated later.
|
||||||
touch $RPM_BUILD_ROOT%{_sysconfdir}/rpmlint/config{c,o}
|
touch $RPM_BUILD_ROOT{%{_datadir},%{_sysconfdir}}/rpmlint/config{c,o}
|
||||||
echo '%ghost %{_sysconfdir}/rpmlint/config?' > %{name}-%{version}-files.list
|
echo '%ghost %{_sysconfdir}/rpmlint/config?' > %{name}-%{version}-files.list
|
||||||
|
echo '%ghost %{_datadir}/rpmlint/config?' >> %{name}-%{version}-files.list
|
||||||
for f in `find $RPM_BUILD_ROOT%{_datadir}/rpmlint -type f -name "*.py"` ; do
|
for f in `find $RPM_BUILD_ROOT%{_datadir}/rpmlint -type f -name "*.py"` ; do
|
||||||
f=`echo "$f" | sed "s|^$RPM_BUILD_ROOT||"`
|
f=`echo "$f" | sed "s|^$RPM_BUILD_ROOT||"`
|
||||||
echo "$f" >> %{name}-%{version}-files.list
|
echo "$f" >> %{name}-%{version}-files.list
|
||||||
@ -82,13 +77,28 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc AUTHORS COPYING ChangeLog README
|
%doc AUTHORS COPYING ChangeLog README
|
||||||
%dir %{_sysconfdir}/rpmlint/
|
%dir %{_sysconfdir}/rpmlint/
|
||||||
%config(noreplace) %{_sysconfdir}/rpmlint/config
|
%config(noreplace) %{_sysconfdir}/rpmlint/config
|
||||||
|
%{_sysconfdir}/bash_completion.d/
|
||||||
%{_bindir}/rpmdiff
|
%{_bindir}/rpmdiff
|
||||||
%{_bindir}/rpmlint
|
%{_bindir}/rpmlint
|
||||||
%dir %{_datadir}/rpmlint/
|
%dir %{_datadir}/rpmlint/
|
||||||
%{_sysconfdir}/bash_completion.d/
|
%{_datadir}/rpmlint/config
|
||||||
|
%{_mandir}/man1/rpmlint.1*
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 11 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.76-1
|
||||||
|
- 0.76.
|
||||||
|
|
||||||
|
* Mon Mar 27 2006 Ville Skyttä <ville.skytta at iki.fi>
|
||||||
|
- Don't pass -T to objdump for *.debug files (#185227).
|
||||||
|
- lib64 library path fixes (#185228).
|
||||||
|
|
||||||
|
* Wed Mar 15 2006 Ville Skyttä <ville.skytta at iki.fi>
|
||||||
|
- Accept zlib License (#185501).
|
||||||
|
|
||||||
|
* Tue Feb 28 2006 Ville Skyttä <ville.skytta at iki.fi>
|
||||||
|
- Accept Ruby License (#183384) and SIL Open Font License (#176405).
|
||||||
|
|
||||||
* Sat Feb 18 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.75-1
|
* Sat Feb 18 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.75-1
|
||||||
- 0.75 + -devel Epoch version check patch from CVS.
|
- 0.75 + -devel Epoch version check patch from CVS.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user