fix bz 741298 and 745446
This commit is contained in:
parent
76c1090bd2
commit
32994cd899
21
rpmlint-1.3-svn1886-ghost-fix.patch
Normal file
21
rpmlint-1.3-svn1886-ghost-fix.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -up rpmlint-1.3/FilesCheck.py.ghostfix rpmlint-1.3/FilesCheck.py
|
||||||
|
--- rpmlint-1.3/FilesCheck.py.ghostfix 2011-10-12 14:46:28.290703772 -0400
|
||||||
|
+++ rpmlint-1.3/FilesCheck.py 2011-10-12 14:46:35.254619020 -0400
|
||||||
|
@@ -748,7 +748,7 @@ class FilesCheck(AbstractCheck.AbstractC
|
||||||
|
res = man_base_regex.search(f)
|
||||||
|
if res:
|
||||||
|
man_basenames.add(res.group(1))
|
||||||
|
- if use_utf8:
|
||||||
|
+ if use_utf8 and chunk:
|
||||||
|
# TODO: better shell escaping or seq based invocation
|
||||||
|
cmd = commands.getstatusoutput(
|
||||||
|
'env LC_ALL=C %s "%s" | gtbl | '
|
||||||
|
@@ -807,7 +807,7 @@ class FilesCheck(AbstractCheck.AbstractC
|
||||||
|
fsf_wrong_address_regex.search(chunk):
|
||||||
|
printError(pkg, 'incorrect-fsf-address', f)
|
||||||
|
|
||||||
|
- elif is_doc and compr_regex.search(f):
|
||||||
|
+ elif is_doc and chunk and compr_regex.search(f):
|
||||||
|
ff = compr_regex.sub('', f)
|
||||||
|
if not skipdocs_regex.search(ff):
|
||||||
|
# compressed docs, eg. info and man files etc
|
@ -40,7 +40,7 @@ setOption("DanglingSymlinkExceptions", (
|
|||||||
setOption("ValidLicenses", (
|
setOption("ValidLicenses", (
|
||||||
# These are the short names for all of the Fedora approved licenses.
|
# These are the short names for all of the Fedora approved licenses.
|
||||||
# The master list is kept here: http://fedoraproject.org/wiki/Licensing
|
# The master list is kept here: http://fedoraproject.org/wiki/Licensing
|
||||||
# Last synced with revision "1.85, 21 October 2010" of that page.
|
# Last synced with revision "1.94, 20 September 2011" of that page.
|
||||||
'AAL',
|
'AAL',
|
||||||
'Abstyles',
|
'Abstyles',
|
||||||
'Adobe',
|
'Adobe',
|
||||||
@ -64,12 +64,15 @@ setOption("ValidLicenses", (
|
|||||||
'ASL 2.0',
|
'ASL 2.0',
|
||||||
'ASL 2.0+',
|
'ASL 2.0+',
|
||||||
'Barr',
|
'Barr',
|
||||||
|
'Beerware',
|
||||||
'BeOpen',
|
'BeOpen',
|
||||||
'BitTorrent',
|
'BitTorrent',
|
||||||
'Boost',
|
'Boost',
|
||||||
|
'Borceux',
|
||||||
'BSD',
|
'BSD',
|
||||||
'BSD Protection',
|
'BSD Protection',
|
||||||
'BSD with advertising',
|
'BSD with advertising',
|
||||||
|
'BSD with attribution',
|
||||||
'CATOSL',
|
'CATOSL',
|
||||||
'CC0',
|
'CC0',
|
||||||
'CeCILL',
|
'CeCILL',
|
||||||
@ -85,12 +88,14 @@ setOption("ValidLicenses", (
|
|||||||
'Crystal Stacker',
|
'Crystal Stacker',
|
||||||
'DOC',
|
'DOC',
|
||||||
'Dotseqn',
|
'Dotseqn',
|
||||||
|
'DSDP',
|
||||||
'dvipdfm',
|
'dvipdfm',
|
||||||
'ECL 1.0',
|
'ECL 1.0',
|
||||||
'ECL 2.0',
|
'ECL 2.0',
|
||||||
'eCos',
|
'eCos',
|
||||||
'EFL 2.0',
|
'EFL 2.0',
|
||||||
'EFL 2.0+',
|
'EFL 2.0+',
|
||||||
|
'eGenix',
|
||||||
'Entessa',
|
'Entessa',
|
||||||
'EPL',
|
'EPL',
|
||||||
'ERPL',
|
'ERPL',
|
||||||
@ -102,6 +107,7 @@ setOption("ValidLicenses", (
|
|||||||
'Giftware',
|
'Giftware',
|
||||||
'GL2PS',
|
'GL2PS',
|
||||||
'Glide',
|
'Glide',
|
||||||
|
'Glulxe',
|
||||||
'gnuplot',
|
'gnuplot',
|
||||||
'GPL+',
|
'GPL+',
|
||||||
'GPL+ or Artistic',
|
'GPL+ or Artistic',
|
||||||
@ -212,6 +218,7 @@ setOption("ValidLicenses", (
|
|||||||
'Teeworlds',
|
'Teeworlds',
|
||||||
'Threeparttable',
|
'Threeparttable',
|
||||||
'TMate',
|
'TMate',
|
||||||
|
'TORQUEv1.1',
|
||||||
'TOSL',
|
'TOSL',
|
||||||
'TPL',
|
'TPL',
|
||||||
'UCD',
|
'UCD',
|
||||||
|
11
rpmlint.spec
11
rpmlint.spec
@ -1,6 +1,6 @@
|
|||||||
Name: rpmlint
|
Name: rpmlint
|
||||||
Version: 1.3
|
Version: 1.3
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Tool for checking common errors in RPM packages
|
Summary: Tool for checking common errors in RPM packages
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -14,6 +14,9 @@ Source3: %{name}-etc.config
|
|||||||
Source4: %{name}.config.el4
|
Source4: %{name}.config.el4
|
||||||
# EL-5 specific config
|
# EL-5 specific config
|
||||||
Source5: %{name}.config.el5
|
Source5: %{name}.config.el5
|
||||||
|
# http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1886
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=745446
|
||||||
|
Patch0: rpmlint-1.3-svn1886-ghost-fix.patch
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: python >= 2.4
|
BuildRequires: python >= 2.4
|
||||||
BuildRequires: rpm-python >= 4.4
|
BuildRequires: rpm-python >= 4.4
|
||||||
@ -41,6 +44,7 @@ and source packages as well as spec files can be checked.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .ghostfix
|
||||||
sed -i -e /MenuCheck/d Config.py
|
sed -i -e /MenuCheck/d Config.py
|
||||||
cp -p config config.example
|
cp -p config config.example
|
||||||
install -pm 644 %{SOURCE2} CHANGES.package.old
|
install -pm 644 %{SOURCE2} CHANGES.package.old
|
||||||
@ -81,6 +85,11 @@ make check
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 12 2011 Tom Callaway <spot@fedoraproject.org> - 1.3-2
|
||||||
|
- apply upstream fix for false error on checking ghosted man pages for
|
||||||
|
encoding (bz745446)
|
||||||
|
- update config to reflect new licenses (bz741298)
|
||||||
|
|
||||||
* Tue Jul 12 2011 Tom Callaway <spot@fedoraproject.org> - 1.3-1
|
* Tue Jul 12 2011 Tom Callaway <spot@fedoraproject.org> - 1.3-1
|
||||||
- update to 1.3
|
- update to 1.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user