- Fedora licensing patch applied upstream. - Move pre-2007 changelog entries to CHANGES.package.old.
This commit is contained in:
parent
5bfc533375
commit
31f59b4666
@ -1 +1 @@
|
|||||||
rpmlint-0.82.tar.bz2
|
rpmlint-0.83.tar.bz2
|
||||||
|
@ -1,47 +0,0 @@
|
|||||||
--- TagsCheck.py~ 2007-08-29 23:46:39.000000000 +0300
|
|
||||||
+++ TagsCheck.py 2007-09-03 19:54:09.000000000 +0300
|
|
||||||
@@ -403,6 +403,7 @@
|
|
||||||
invalid_url_regex=re.compile(Config.getOption('InvalidURL'), re.IGNORECASE)
|
|
||||||
lib_regex=re.compile('^lib.*?(\.so.*)?$')
|
|
||||||
leading_space_regex=re.compile('^\s+')
|
|
||||||
+license_regex=re.compile('\(([^)]+)\)|\s(?:and|or)\s')
|
|
||||||
invalid_version_regex=re.compile('([0-9](?:rc|alpha|beta|pre).*)', re.IGNORECASE)
|
|
||||||
# () are here for grouping purpose in the regexp
|
|
||||||
forbidden_words_regex=re.compile('(' + Config.getOption('ForbiddenWords') + ')', re.IGNORECASE)
|
|
||||||
@@ -628,16 +629,20 @@
|
|
||||||
# printWarning(pkg, 'package-provides-itself')
|
|
||||||
# break
|
|
||||||
|
|
||||||
+ def split_license(license):
|
|
||||||
+ return map(string.strip, [l for l in license_regex.split(license) if l])
|
|
||||||
+
|
|
||||||
rpm_license = pkg[rpm.RPMTAG_LICENSE]
|
|
||||||
if not rpm_license:
|
|
||||||
printError(pkg, 'no-license')
|
|
||||||
else:
|
|
||||||
if rpm_license not in VALID_LICENSES:
|
|
||||||
- licenses = re.split('(?:[- ]like|/|ish|[- ]style|[- ]Style|and|or|&|\s|-)+', rpm_license)
|
|
||||||
- for l in licenses:
|
|
||||||
- if l != '' and not l in VALID_LICENSES:
|
|
||||||
- printWarning(pkg, 'invalid-license', rpm_license)
|
|
||||||
- break
|
|
||||||
+ for l1 in split_license(rpm_license):
|
|
||||||
+ if l1 in VALID_LICENSES:
|
|
||||||
+ continue
|
|
||||||
+ for l2 in split_license(l1):
|
|
||||||
+ if l2 not in VALID_LICENSES:
|
|
||||||
+ printWarning(pkg, 'invalid-license', l2)
|
|
||||||
|
|
||||||
url=pkg[rpm.RPMTAG_URL]
|
|
||||||
if url and url != 'none':
|
|
||||||
@@ -808,9 +813,7 @@
|
|
||||||
|
|
||||||
'invalid-license',
|
|
||||||
'''The value of the License tag was not recognized. Known values are:
|
|
||||||
-%s
|
|
||||||
-If the license is close to an existing one, you can use '<license> style'.''' \
|
|
||||||
-% fill('"' + '", "'.join(VALID_LICENSES) + '".', 78),
|
|
||||||
+%s''' % fill('"' + '", "'.join(VALID_LICENSES) + '".', 78),
|
|
||||||
|
|
||||||
'invalid-url',
|
|
||||||
'''Your URL is not valid. It must begin with http, https or ftp and must no
|
|
@ -1,3 +1,46 @@
|
|||||||
|
* Sun Oct 15 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.78-2
|
||||||
|
- Accumulated bugfixes since 0.78: #209876, #209889, #210110, 210261.
|
||||||
|
- Filter messages about gpg-pubkeys for now.
|
||||||
|
|
||||||
|
* Sun Sep 24 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.78-1
|
||||||
|
- 0.78, fixes #198605, #198616, #198705, #198707, #200032, #206383.
|
||||||
|
- /etc/profile.d/* filtering no longer needed.
|
||||||
|
|
||||||
|
* Sat Sep 16 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.77-2
|
||||||
|
- Filter false positives for /etc/profile.d/* file modes.
|
||||||
|
- Ship *.pyc and *.pyo as usual.
|
||||||
|
|
||||||
|
* Thu Jun 29 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.77-1
|
||||||
|
- 0.77, fixes #194466, #195962, #196008, #196985.
|
||||||
|
- Make "disttag" configurable using the DistRegex config file option.
|
||||||
|
- Sync standard users and groups with the FC setup package.
|
||||||
|
- Disable MenuCheck by default, it's currently Mandriva specific.
|
||||||
|
- Use upstream default valid License tag list, fixes #191078.
|
||||||
|
- Use upstream default valid Group tag list (dynamically retrieved from
|
||||||
|
the GROUPS file shipped with rpm).
|
||||||
|
- Allow /usr/libexec, fixes #195992.
|
||||||
|
|
||||||
|
* Tue Apr 11 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.76-1
|
||||||
|
- 0.76.
|
||||||
|
|
||||||
|
* Mon Mar 27 2006 Ville Skyttä <ville.skytta at iki.fi>
|
||||||
|
- Don't pass -T to objdump for *.debug files (#185227).
|
||||||
|
- lib64 library path fixes (#185228).
|
||||||
|
|
||||||
|
* Wed Mar 15 2006 Ville Skyttä <ville.skytta at iki.fi>
|
||||||
|
- Accept zlib License (#185501).
|
||||||
|
|
||||||
|
* Tue Feb 28 2006 Ville Skyttä <ville.skytta at iki.fi>
|
||||||
|
- Accept Ruby License (#183384) and SIL Open Font License (#176405).
|
||||||
|
|
||||||
|
* Sat Feb 18 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.75-1
|
||||||
|
- 0.75 + -devel Epoch version check patch from CVS.
|
||||||
|
|
||||||
|
* Tue Jan 17 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.71-3
|
||||||
|
- Sync with upstream CVS as of 2006-01-15, includes improved versions of
|
||||||
|
most of the earlier patches.
|
||||||
|
- Add dependency on binutils.
|
||||||
|
|
||||||
* Sun Nov 20 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.71-2
|
* Sun Nov 20 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.71-2
|
||||||
- Take file based dependencies into account in dangling symlink checks
|
- Take file based dependencies into account in dangling symlink checks
|
||||||
(completes the fix for #165839).
|
(completes the fix for #165839).
|
||||||
|
54
rpmlint.spec
54
rpmlint.spec
@ -1,6 +1,6 @@
|
|||||||
Name: rpmlint
|
Name: rpmlint
|
||||||
Version: 0.82
|
Version: 0.83
|
||||||
Release: 3%{?dist}
|
Release: 0.1%{?dist}
|
||||||
Summary: Tool for checking common errors in RPM packages
|
Summary: Tool for checking common errors in RPM packages
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -11,7 +11,6 @@ Source1: %{name}.config
|
|||||||
Source2: %{name}-CHANGES.package.old
|
Source2: %{name}-CHANGES.package.old
|
||||||
Patch0: %{name}-0.78-distregex.patch
|
Patch0: %{name}-0.78-distregex.patch
|
||||||
Patch1: %{name}-0.77-compile.patch
|
Patch1: %{name}-0.77-compile.patch
|
||||||
Patch2: %{name}-0.81-fedoralicensing.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
@ -34,7 +33,6 @@ and source packages can be checked.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0
|
%patch0
|
||||||
%patch1
|
%patch1
|
||||||
%patch2
|
|
||||||
sed -i -e /MenuCheck/d Config.py
|
sed -i -e /MenuCheck/d Config.py
|
||||||
install -pm 644 %{SOURCE2} CHANGES.package.old
|
install -pm 644 %{SOURCE2} CHANGES.package.old
|
||||||
|
|
||||||
@ -70,6 +68,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 27 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.83-1
|
||||||
|
- 0.83, fixes #237204, #428096, #430206, #433783, #434694, #444441.
|
||||||
|
- Fedora licensing patch applied upstream.
|
||||||
|
- Move pre-2007 changelog entries to CHANGES.package.old.
|
||||||
|
|
||||||
* Tue May 20 2008 Todd Zullinger <tmz@pobox.com>
|
* Tue May 20 2008 Todd Zullinger <tmz@pobox.com>
|
||||||
- Sync Fedora license list with Revision 0.83 (Wiki rev 131).
|
- Sync Fedora license list with Revision 0.83 (Wiki rev 131).
|
||||||
|
|
||||||
@ -114,46 +117,3 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
- 0.79, fixes #211417, #212491, #214605, #218250, #219068, #220061, #221116,
|
- 0.79, fixes #211417, #212491, #214605, #218250, #219068, #220061, #221116,
|
||||||
#222585, and #226879.
|
#222585, and #226879.
|
||||||
- Accept *.elX disttags in default config.
|
- Accept *.elX disttags in default config.
|
||||||
|
|
||||||
* Sun Oct 15 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.78-2
|
|
||||||
- Accumulated bugfixes since 0.78: #209876, #209889, #210110, 210261.
|
|
||||||
- Filter messages about gpg-pubkeys for now.
|
|
||||||
|
|
||||||
* Sun Sep 24 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.78-1
|
|
||||||
- 0.78, fixes #198605, #198616, #198705, #198707, #200032, #206383.
|
|
||||||
- /etc/profile.d/* filtering no longer needed.
|
|
||||||
|
|
||||||
* Sat Sep 16 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.77-2
|
|
||||||
- Filter false positives for /etc/profile.d/* file modes.
|
|
||||||
- Ship *.pyc and *.pyo as usual.
|
|
||||||
|
|
||||||
* Thu Jun 29 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.77-1
|
|
||||||
- 0.77, fixes #194466, #195962, #196008, #196985.
|
|
||||||
- Make "disttag" configurable using the DistRegex config file option.
|
|
||||||
- Sync standard users and groups with the FC setup package.
|
|
||||||
- Disable MenuCheck by default, it's currently Mandriva specific.
|
|
||||||
- Use upstream default valid License tag list, fixes #191078.
|
|
||||||
- Use upstream default valid Group tag list (dynamically retrieved from
|
|
||||||
the GROUPS file shipped with rpm).
|
|
||||||
- Allow /usr/libexec, fixes #195992.
|
|
||||||
|
|
||||||
* Tue Apr 11 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.76-1
|
|
||||||
- 0.76.
|
|
||||||
|
|
||||||
* Mon Mar 27 2006 Ville Skyttä <ville.skytta at iki.fi>
|
|
||||||
- Don't pass -T to objdump for *.debug files (#185227).
|
|
||||||
- lib64 library path fixes (#185228).
|
|
||||||
|
|
||||||
* Wed Mar 15 2006 Ville Skyttä <ville.skytta at iki.fi>
|
|
||||||
- Accept zlib License (#185501).
|
|
||||||
|
|
||||||
* Tue Feb 28 2006 Ville Skyttä <ville.skytta at iki.fi>
|
|
||||||
- Accept Ruby License (#183384) and SIL Open Font License (#176405).
|
|
||||||
|
|
||||||
* Sat Feb 18 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.75-1
|
|
||||||
- 0.75 + -devel Epoch version check patch from CVS.
|
|
||||||
|
|
||||||
* Tue Jan 17 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.71-3
|
|
||||||
- Sync with upstream CVS as of 2006-01-15, includes improved versions of
|
|
||||||
most of the earlier patches.
|
|
||||||
- Add dependency on binutils.
|
|
||||||
|
Loading…
Reference in New Issue
Block a user