- 0.71, confmsg patch and bits from initvars patch applied upstream.
- Filter out Mandriva-specific errors about missing locales-* deps (#165457). - Patch to not warn about non-empty *.bs (in Perl packages). - Patch to clarify PreReq explanation, make it a warning instead of an error. - Patch to warn about use of BuildPreReq.
This commit is contained in:
parent
35717146ab
commit
0bd46f0df3
@ -1 +1 @@
|
||||
rpmlint-0.70.tar.bz2
|
||||
rpmlint-0.71.tar.bz2
|
||||
|
@ -1,20 +0,0 @@
|
||||
Index: FilesCheck.py
|
||||
===================================================================
|
||||
RCS file: /cooker/soft/rpmlint/FilesCheck.py,v
|
||||
retrieving revision 1.87
|
||||
diff -u -r1.87 FilesCheck.py
|
||||
--- FilesCheck.py 17 Jun 2005 09:48:34 -0000 1.87
|
||||
+++ FilesCheck.py 20 Jun 2005 10:30:43 -0000
|
||||
@@ -692,9 +692,9 @@
|
||||
Please remove it and rebuild your package.''',
|
||||
|
||||
'non-conffile-in-etc',
|
||||
-'''A file in your package is being installed in /etc, but is not a
|
||||
-configuration file. All the files in /etc MUST be configuration files
|
||||
-(add the %config option to the file in the spec file).''',
|
||||
+'''A non-executable file in your package is being installed in /etc, but is not
|
||||
+a configuration file. All non-executable files in /etc should be configuration
|
||||
+files. Mark the file as %config in the spec file.''',
|
||||
|
||||
'compressed-symlink-with-wrong-ext',
|
||||
'''The symlink points to a compressed file but doesn't use the same extension.''',
|
@ -79,6 +79,7 @@ setOption("ValidShells", (
|
||||
addFilter("W: .* source-or-patch-not-[bg]zipped .*")
|
||||
addFilter("E: .* lib-package-without-%mklibname")
|
||||
addFilter("E: .* no-dependency-on (perl|python)-base.*")
|
||||
addFilter("E: .* no-dependency-on locales-.*")
|
||||
addFilter("W: .* (python|perl5)-naming-policy-not-applied.*")
|
||||
addFilter("W: .* invalid-(distribution|vendor) .*")
|
||||
addFilter("E: .* no-(packager-tag|signature)")
|
||||
|
@ -1,19 +1,5 @@
|
||||
Index: InitScriptCheck.py
|
||||
===================================================================
|
||||
RCS file: /cooker/soft/rpmlint/InitScriptCheck.py,v
|
||||
retrieving revision 1.14
|
||||
diff -u -r1.14 InitScriptCheck.py
|
||||
--- InitScriptCheck.py 15 Apr 2005 20:01:46 -0000 1.14
|
||||
+++ InitScriptCheck.py 6 Jul 2005 14:19:22 -0000
|
||||
@@ -17,7 +17,7 @@
|
||||
|
||||
rc_regex=re.compile('^/etc(/rc.d)?/init.d/')
|
||||
chkconfig_content_regex=re.compile('# +chkconfig: +([-0-9]+) +[-0-9]+ +[-0-9]+', re.MULTILINE)
|
||||
-subsys_regex=re.compile('/var/lock/subsys/([^/\n ]+)', re.MULTILINE)
|
||||
+subsys_regex=re.compile('/var/lock/subsys/([^/"\'\n ]+)', re.MULTILINE)
|
||||
chkconfig_regex=re.compile('^[^#]*(chkconfig|add-service|del-service)', re.MULTILINE)
|
||||
status_regex=re.compile('^[^#]*status', re.MULTILINE)
|
||||
reload_regex=re.compile('^[^#]*reload', re.MULTILINE)
|
||||
--- InitScriptCheck.py 10 Aug 2005 01:51:34 -0000 1.15
|
||||
+++ InitScriptCheck.py 10 Aug 2005 13:12:39 -0000
|
||||
@@ -86,7 +86,7 @@
|
||||
error=1
|
||||
if name[0] == '$':
|
||||
|
11
rpmlint-perl-bs.patch
Normal file
11
rpmlint-perl-bs.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- FilesCheck.py 10 Aug 2005 01:46:30 -0000 1.88
|
||||
+++ FilesCheck.py 10 Aug 2005 13:29:12 -0000
|
||||
@@ -160,7 +160,7 @@
|
||||
depmod_regex=re.compile('^[^#]*depmod', re.MULTILINE)
|
||||
info_regex=re.compile('^/usr/share/info')
|
||||
install_info_regex=re.compile('^[^#]*install-info', re.MULTILINE)
|
||||
-perl_temp_file=re.compile('.*perl.*(\.bs|/\.packlist|/perllocal\.pod)$')
|
||||
+perl_temp_file=re.compile('.*perl.*(/\.packlist|/perllocal\.pod)$')
|
||||
scm_regex=re.compile('/CVS/[^/]+$|/.cvsignore$|/\.svn/|/(\.arch-ids|{arch})/')
|
||||
htaccess_regex=re.compile('\.htaccess$')
|
||||
games_path_regex=re.compile('/usr/(lib/)?/games')
|
41
rpmlint-prereq.patch
Normal file
41
rpmlint-prereq.patch
Normal file
@ -0,0 +1,41 @@
|
||||
--- SpecCheck.py 10 Aug 2005 06:10:39 -0000 1.29
|
||||
+++ SpecCheck.py 10 Aug 2005 13:14:46 -0000
|
||||
@@ -44,6 +44,7 @@
|
||||
biarch_package_regex=re.compile(DEFAULT_BIARCH_PACKAGES)
|
||||
hardcoded_lib_path_exceptions_regex=re.compile(Config.getOption('HardcodedLibPathExceptions', DEFAULT_HARDCODED_LIB_PATH_EXCEPTIONS))
|
||||
prereq_regex=re.compile('^PreReq:\s*(.+?)\s*$', re.IGNORECASE)
|
||||
+buildprereq_regex=re.compile('^BuildPreReq:\s*(.+?)\s*$', re.IGNORECASE)
|
||||
|
||||
# Only check for /lib, /usr/lib, /usr/X11R6/lib
|
||||
# TODO: better handling of X libraries and modules.
|
||||
@@ -185,8 +186,12 @@
|
||||
|
||||
res=prereq_regex.search(line)
|
||||
if res:
|
||||
- printError(pkg, 'prereq-use', res.group(1))
|
||||
-
|
||||
+ printWarning(pkg, 'prereq-use', res.group(1))
|
||||
+
|
||||
+ res=buildprereq_regex.search(line)
|
||||
+ if res:
|
||||
+ printWarning(pkg, 'buildprereq-use', res.group(1))
|
||||
+
|
||||
if not buildroot:
|
||||
printError(pkg, 'no-buildroot-tag')
|
||||
|
||||
@@ -272,8 +277,13 @@
|
||||
patch to be effective only on a given arch.''',
|
||||
|
||||
'prereq-use',
|
||||
-'''The use of PreReq is deprecated. You should use Requires(pre), Requires(post),
|
||||
-Requires(preun) or Requires(postun) according to your needs.''',
|
||||
+'''The use of PreReq is deprecated. In the majority of cases, a plain Requires
|
||||
+is enough and the right thing to do. Sometimes Requires(pre), Requires(post),
|
||||
+Requires(preun) and/or Requires(postun) can also be used instead of PreReq.''',
|
||||
+
|
||||
+'buildprereq-use',
|
||||
+'''The use of BuildPreReq is deprecated, build dependencies are always required
|
||||
+before a package can be built. Use plain BuildRequires instead.''',
|
||||
|
||||
)
|
||||
|
15
rpmlint.spec
15
rpmlint.spec
@ -1,6 +1,6 @@
|
||||
Name: rpmlint
|
||||
Version: 0.70
|
||||
Release: 4%{?dist}
|
||||
Version: 0.71
|
||||
Release: 1%{?dist}
|
||||
Summary: Tool for checking common errors in RPM packages
|
||||
|
||||
Group: Development/Tools
|
||||
@ -9,10 +9,11 @@ URL: http://people.mandriva.com/~flepied/projects/rpmlint/
|
||||
Source0: http://people.mandriva.com/~flepied/projects/rpmlint/dist/%{name}-%{version}.tar.bz2
|
||||
Source1: %{name}-fedora-config
|
||||
Patch0: %{name}-svcdefault.patch
|
||||
Patch1: %{name}-confmsg.patch
|
||||
Patch1: %{name}-prereq.patch
|
||||
Patch2: %{name}-disttag.patch
|
||||
Patch3: %{name}-initvars.patch
|
||||
Patch4: %{name}-execs.patch
|
||||
Patch5: %{name}-perl-bs.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildArch: noarch
|
||||
@ -35,6 +36,7 @@ and source packages can be checked.
|
||||
%patch2
|
||||
%patch3
|
||||
%patch4
|
||||
%patch5
|
||||
sed -i -e 's|/etc/httpd/webapps\.d|%{_sysconfdir}/httpd/conf.d|' \
|
||||
FilesCheck.py I18NCheck.py
|
||||
for f in AUTHORS ChangeLog ; do
|
||||
@ -86,6 +88,13 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Aug 10 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.71-1
|
||||
- 0.71, confmsg patch and bits from initvars patch applied upstream.
|
||||
- Filter out Mandriva-specific errors about missing locales-* deps (#165457).
|
||||
- Patch to not warn about non-empty *.bs (in Perl packages).
|
||||
- Patch to clarify PreReq explanation, make it a warning instead of an error.
|
||||
- Patch to warn about use of BuildPreReq.
|
||||
|
||||
* Thu Jul 7 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.70-4
|
||||
- Fix false "positives" from libtool archives confused as scripts,
|
||||
non-executable scripts installed in docs, FE disttags, unsuccessfully
|
||||
|
Loading…
Reference in New Issue
Block a user