import rpmdevtools-9.5-1.el9

This commit is contained in:
CentOS Sources 2022-01-11 12:10:11 -05:00 committed by Stepan Oksanichenko
parent 436c307e01
commit 48933bb187
5 changed files with 15 additions and 49 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/rpmdevtools-9.3.tar.xz
SOURCES/rpmdevtools-9.5.tar.xz

View File

@ -1 +1 @@
96ec493f96144a744e7cfde1ad7c20bde7972ec1 SOURCES/rpmdevtools-9.3.tar.xz
4432c26735efe656fcf67febb984c3e9b71c587d SOURCES/rpmdevtools-9.5.tar.xz

View File

@ -1,33 +0,0 @@
From 6a582f49fa958e4ba3e374d0e77d814524111dfb Mon Sep 17 00:00:00 2001
From: Miro Hrončok <miro@hroncok.cz>
Date: Jan 23 2021 13:15:35 +0000
Subject: Use Accept-Encoding: identity together with decode_content=False
This should fix both the issues:
- gzips decompressed: https://pagure.io/rpmdevtools/issue/72
- texts compressed: https://pagure.io/rpmdevtools/issue/76
$ file tor-0.4.5.4-rc.tar.gz tor-0.4.5.4-rc.tar.gz.asc xrootd-5.0.3.tar.gz
tor-0.4.5.4-rc.tar.gz: gzip compressed data, max compression, from Unix, original size modulo 2^32 35962880
tor-0.4.5.4-rc.tar.gz.asc: PGP signature Signature (old)
xrootd-5.0.3.tar.gz: gzip compressed data, max compression, from Unix, original size modulo 2^32 981462405
---
diff --git a/rpmdev-spectool b/rpmdev-spectool
index 56a2d43..a324fab 100755
--- a/rpmdev-spectool
+++ b/rpmdev-spectool
@@ -239,6 +239,9 @@ def download(url, target, headers=None, tracker: Optional[ProgressTracker] = Non
headers = {}
headers.setdefault("User-Agent", "rpmdev-spectool")
+ # identity should prevent servers from sending gzip-compressed text
+ # which would later not be decompressed because we set decode_content=False
+ headers.setdefault("Accept-Encoding", "identity")
ret = requests.get(url, headers=headers, stream=True)
ret.raise_for_status()

View File

@ -1,16 +1,16 @@
diff -up rpmdevtools-9.3/Makefile.am.orig rpmdevtools-9.3/Makefile.am
--- rpmdevtools-9.3/Makefile.am.orig 2021-01-22 17:16:13.001772708 +0100
+++ rpmdevtools-9.3/Makefile.am 2021-01-22 17:16:29.477084436 +0100
diff -up rpmdevtools-9.5/Makefile.am.orig rpmdevtools-9.5/Makefile.am
--- rpmdevtools-9.5/Makefile.am.orig 2021-12-10 11:37:29.889405680 +0100
+++ rpmdevtools-9.5/Makefile.am 2021-12-10 11:37:34.637495820 +0100
@@ -1,4 +1,4 @@
-SUBDIRS = emacs qa-robot
+SUBDIRS = emacs
pkgsysconfdir = $(sysconfdir)/rpmdevtools
bashcompdir = @bashcompdir@
diff -up rpmdevtools-9.3/Makefile.in.orig rpmdevtools-9.3/Makefile.in
--- rpmdevtools-9.3/Makefile.in.orig 2021-01-22 17:16:05.401628907 +0100
+++ rpmdevtools-9.3/Makefile.in 2021-01-22 17:16:23.122964213 +0100
@@ -316,7 +316,7 @@ target_alias = @target_alias@
diff -up rpmdevtools-9.5/Makefile.in.orig rpmdevtools-9.5/Makefile.in
--- rpmdevtools-9.5/Makefile.in.orig 2021-12-10 11:37:31.073428158 +0100
+++ rpmdevtools-9.5/Makefile.in 2021-12-10 11:37:38.304565439 +0100
@@ -317,7 +317,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@

View File

@ -1,6 +1,6 @@
Name: rpmdevtools
Version: 9.3
Release: 7%{?dist}
Version: 9.5
Release: 1%{?dist}
Summary: RPM Development Tools
# rpmdev-setuptree is GPLv2, everything else GPLv2+
@ -9,17 +9,13 @@ URL: https://pagure.io/rpmdevtools
Source0: https://releases.pagure.org/rpmdevtools/%{name}-%{version}.tar.xz
Source1: progressbar.py
# Use Accept-Encoding: identity together with decode_content=False
# This is to avoid text files downloaded gzipped
Patch1: https://pagure.io/rpmdevtools/pull-request/77.patch
# Fedora-specific downstream patches
## Force legacy datestamp by default until rhbz#1715412 is resolved
Patch1001: 0001-Force-legacy-datestamp-while-RHBZ-1715412-is-still-a.patch
# RHEL-specific downstream patches
## Remove fakeroot dependency (rhbz#1905465)
Patch2001: rpmdevtools-9.3-no_qa_robot.patch
Patch2001: rpmdevtools-9.5-no_qa_robot.patch
BuildArch: noarch
# help2man, pod2man, *python for creating man pages
@ -134,6 +130,9 @@ cp %{SOURCE1} %{buildroot}%{_datadir}/rpmdevtools/
%changelog
* Fri Dec 10 2021 Michal Domonkos <mdomonko@redhat.com> - 9.5-1
- Rebase to 9.5 (#2005756)
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 9.3-7
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688