- don't treat %patch numberless if -P parameter is present (#463942)
This commit is contained in:
parent
9ba3bc75c8
commit
ff9e0e6430
22
rpm-4.5.90-patch-P.patch
Normal file
22
rpm-4.5.90-patch-P.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
commit c4fa73c573f63d2e2b53e75d25feafbf65ebf671
|
||||||
|
Author: Jindrich Novy <jnovy@redhat.com>
|
||||||
|
Date: Wed Sep 24 18:39:43 2008 +0200
|
||||||
|
|
||||||
|
Don't treat %patch numberless if -P parameter is present
|
||||||
|
|
||||||
|
diff --git a/build/parsePrep.c b/build/parsePrep.c
|
||||||
|
index 2be0693..bfef325 100644
|
||||||
|
--- a/build/parsePrep.c
|
||||||
|
+++ b/build/parsePrep.c
|
||||||
|
@@ -431,7 +431,10 @@ static rpmRC doPatchMacro(rpmSpec spec, const char *line)
|
||||||
|
if (! strchr(" \t\n", line[6])) {
|
||||||
|
rasprintf(&buf, "%%patch -P %s", line + 6);
|
||||||
|
} else {
|
||||||
|
- rasprintf(&buf, "%%patch -P %d %s", INT_MAX, line + 6); /* INT_MAX denotes not numbered %patch */
|
||||||
|
+ if (strstr(line+6, " -P") == NULL)
|
||||||
|
+ rasprintf(&buf, "%%patch -P %d %s", INT_MAX, line + 6); /* INT_MAX denotes not numbered %patch */
|
||||||
|
+ else
|
||||||
|
+ buf = strdup(line); /* it is not numberless patch because -P is present */
|
||||||
|
}
|
||||||
|
poptParseArgvString(buf, &argc, &argv);
|
||||||
|
free(buf);
|
7
rpm.spec
7
rpm.spec
@ -18,7 +18,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: 0.%{snapver}.7
|
Release: 0.%{snapver}.8
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||||
@ -42,6 +42,7 @@ Patch205: rpm-4.5.90-topdir.patch
|
|||||||
Patch206: rpm-4.5.90-rpmbuild-dirs.patch
|
Patch206: rpm-4.5.90-rpmbuild-dirs.patch
|
||||||
Patch207: rpm-4.5.90-cpio-hardlink.patch
|
Patch207: rpm-4.5.90-cpio-hardlink.patch
|
||||||
Patch208: rpm-4.5.90-macro-args.patch
|
Patch208: rpm-4.5.90-macro-args.patch
|
||||||
|
Patch209: rpm-4.5.90-patch-P.patch
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch300: rpm-4.5.90-posttrans.patch
|
Patch300: rpm-4.5.90-posttrans.patch
|
||||||
@ -182,6 +183,7 @@ that will manipulate RPM packages and databases.
|
|||||||
%patch206 -p1 -b .rpmbuild-dirs
|
%patch206 -p1 -b .rpmbuild-dirs
|
||||||
%patch207 -p1 -b .cpio-hardlink
|
%patch207 -p1 -b .cpio-hardlink
|
||||||
%patch208 -p1 -b .macro-args
|
%patch208 -p1 -b .macro-args
|
||||||
|
%patch209 -p1 -b .patch-P
|
||||||
|
|
||||||
# needs a bit of upstream love first...
|
# needs a bit of upstream love first...
|
||||||
#%patch300 -p1 -b .posttrans
|
#%patch300 -p1 -b .posttrans
|
||||||
@ -360,6 +362,9 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 25 2008 Jindrich Novy <jnovy@redhat.com>
|
||||||
|
- don't treat %patch numberless if -P parameter is present (#463942)
|
||||||
|
|
||||||
* Thu Sep 11 2008 Panu Matilainen <pmatilai@redhat.com>
|
* Thu Sep 11 2008 Panu Matilainen <pmatilai@redhat.com>
|
||||||
- add hack to support extracting gstreamer plugin provides (#438225)
|
- add hack to support extracting gstreamer plugin provides (#438225)
|
||||||
- fix another macro argument handling regression (#461180)
|
- fix another macro argument handling regression (#461180)
|
||||||
|
Loading…
Reference in New Issue
Block a user