- load macros before creating directories on src.rpm install (#489104)
This commit is contained in:
parent
b60210f8a6
commit
fc85648d1e
32
rpm-4.7.0-beta1-srcrpm-macros.patch
Normal file
32
rpm-4.7.0-beta1-srcrpm-macros.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
commit 7a813e149fe40bbb9beee7dbf9898ab0c1906da2
|
||||||
|
Author: Panu Matilainen <pmatilai@redhat.com>
|
||||||
|
Date: Sun Mar 8 11:33:22 2009 +0200
|
||||||
|
|
||||||
|
Load macros before creating directories (rhbz#489104)
|
||||||
|
- %_sourcedir and friends can have things like %{name}, load macros
|
||||||
|
before trying to create any directories when installing src.rpms
|
||||||
|
(cherry picked from commit ac7c3412278a03da6633758bca999827d4b59038)
|
||||||
|
|
||||||
|
diff --git a/lib/psm.c b/lib/psm.c
|
||||||
|
index 3b2fd7c..112d344 100644
|
||||||
|
--- a/lib/psm.c
|
||||||
|
+++ b/lib/psm.c
|
||||||
|
@@ -275,6 +275,9 @@ rpmRC rpmInstallSourcePackage(rpmts ts, FD_t fd,
|
||||||
|
if (rootdir && strcmp(rootdir, "/") == 0)
|
||||||
|
rootdir = NULL;
|
||||||
|
|
||||||
|
+ /* Macros need to be added before trying to create directories */
|
||||||
|
+ rpmInstallLoadMacros(h);
|
||||||
|
+
|
||||||
|
if (specix >= 0) {
|
||||||
|
const char *bn;
|
||||||
|
|
||||||
|
@@ -301,8 +304,6 @@ rpmRC rpmInstallSourcePackage(rpmts ts, FD_t fd,
|
||||||
|
goto exit;
|
||||||
|
}
|
||||||
|
|
||||||
|
- rpmInstallLoadMacros(h);
|
||||||
|
-
|
||||||
|
te = rpmtsElement(ts, 0);
|
||||||
|
if (te == NULL) { /* XXX can't happen */
|
||||||
|
goto exit;
|
8
rpm.spec
8
rpm.spec
@ -25,7 +25,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: 0.%{snapver}.1%{?dist}
|
Release: 0.%{snapver}.2%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||||
@ -43,6 +43,7 @@ Patch2: rpm-4.5.90-gstreamer-provides.patch
|
|||||||
Patch3: rpm-4.6.0-fedora-specspo.patch
|
Patch3: rpm-4.6.0-fedora-specspo.patch
|
||||||
|
|
||||||
# Patches already in upstream
|
# Patches already in upstream
|
||||||
|
Patch200: rpm-4.7.0-beta1-srcrpm-macros.patch
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch300: rpm-4.7.0-extra-provides.patch
|
Patch300: rpm-4.7.0-extra-provides.patch
|
||||||
@ -183,6 +184,8 @@ that will manipulate RPM packages and databases.
|
|||||||
%patch2 -p1 -b .gstreamer-prov
|
%patch2 -p1 -b .gstreamer-prov
|
||||||
%patch3 -p1 -b .fedora-specspo
|
%patch3 -p1 -b .fedora-specspo
|
||||||
|
|
||||||
|
%patch200 -p1 -b .srcrpm-macros
|
||||||
|
|
||||||
%patch300 -p1 -b .extra-prov
|
%patch300 -p1 -b .extra-prov
|
||||||
|
|
||||||
%if %{with int_bdb}
|
%if %{with int_bdb}
|
||||||
@ -388,6 +391,9 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Mar 08 2009 Panu Matilainen <pmatilai@redhat.com> - 4.7.0-0.beta1.2
|
||||||
|
- load macros before creating directories on src.rpm install (#489104)
|
||||||
|
|
||||||
* Fri Mar 06 2009 Panu Matilainen <pmatilai@redhat.com> - 4.7.0-0.beta1.1
|
* Fri Mar 06 2009 Panu Matilainen <pmatilai@redhat.com> - 4.7.0-0.beta1.1
|
||||||
- update to 4.7.0-beta1 (http://rpm.org/wiki/Releases/4.7.0)
|
- update to 4.7.0-beta1 (http://rpm.org/wiki/Releases/4.7.0)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user