Fixed null pointer problem in rpmfcELF() DT_GNU_HASH handling.
This commit is contained in:
parent
534eb1d6ac
commit
f713820f42
@ -1,5 +1,5 @@
|
|||||||
--- rpm-4.4.2/build/rpmfc.c.gnuhash 2006-07-11 07:32:22.000000000 -0400
|
--- rpm-4.4.2/build/rpmfc.c.gnuhash 2006-07-14 16:59:43.000000000 -0400
|
||||||
+++ rpm-4.4.2/build/rpmfc.c 2006-07-11 07:53:46.000000000 -0400
|
+++ rpm-4.4.2/build/rpmfc.c 2006-07-14 17:01:40.000000000 -0400
|
||||||
@@ -12,6 +12,11 @@
|
@@ -12,6 +12,11 @@
|
||||||
|
|
||||||
#if HAVE_GELF_H
|
#if HAVE_GELF_H
|
||||||
@ -34,7 +34,7 @@
|
|||||||
case DT_DEBUG:
|
case DT_DEBUG:
|
||||||
gotDEBUG = 1;
|
gotDEBUG = 1;
|
||||||
/*@innercontinue@*/ continue;
|
/*@innercontinue@*/ continue;
|
||||||
@@ -1107,6 +1120,16 @@
|
@@ -1107,6 +1120,18 @@
|
||||||
}
|
}
|
||||||
/*@=branchstate =uniondef @*/
|
/*@=branchstate =uniondef @*/
|
||||||
|
|
||||||
@ -44,6 +44,8 @@
|
|||||||
+ ds = rpmdsSingle(RPMTAG_REQUIRENAME, "rtld(GNU_HASH)", "",
|
+ ds = rpmdsSingle(RPMTAG_REQUIRENAME, "rtld(GNU_HASH)", "",
|
||||||
+ RPMSENSE_FIND_REQUIRES);
|
+ RPMSENSE_FIND_REQUIRES);
|
||||||
+ rpmdsMerge(&fc->requires, ds);
|
+ rpmdsMerge(&fc->requires, ds);
|
||||||
|
+ buf[0] = '\0';
|
||||||
|
+ t = buf;
|
||||||
+ rpmfcSaveArg(&fc->ddict, rpmfcFileDep(t, fc->ix, ds));
|
+ rpmfcSaveArg(&fc->ddict, rpmfcFileDep(t, fc->ix, ds));
|
||||||
+ ds = rpmdsFree(ds);
|
+ ds = rpmdsFree(ds);
|
||||||
+ }
|
+ }
|
||||||
|
5
rpm.spec
5
rpm.spec
@ -20,7 +20,7 @@ Name: rpm
|
|||||||
%define version 4.4.2
|
%define version 4.4.2
|
||||||
Version: %{version}
|
Version: %{version}
|
||||||
%{expand: %%define rpm_version %{version}}
|
%{expand: %%define rpm_version %{version}}
|
||||||
Release: 28
|
Release: 29
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Source: ftp://wraptastic.org/pub/rpm-4.4.x/rpm-%{rpm_version}.tar.gz
|
Source: ftp://wraptastic.org/pub/rpm-4.4.x/rpm-%{rpm_version}.tar.gz
|
||||||
Source1: mono-find-provides
|
Source1: mono-find-provides
|
||||||
@ -595,6 +595,9 @@ exit 0
|
|||||||
%{__includedir}/popt.h
|
%{__includedir}/popt.h
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 14 2006 David Cantrell <dcantrell@redhat.com> - 4.4.2-29
|
||||||
|
- Fixed null pointer problem in rpmfcELF() DT_GNU_HASH handling
|
||||||
|
|
||||||
* Tue Jul 11 2006 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-28
|
* Tue Jul 11 2006 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-28
|
||||||
- Detect and provide a requirement for DT_GNU_HASH
|
- Detect and provide a requirement for DT_GNU_HASH
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user