- reduce the double separator spec parse error into a warning (#1065563)
This commit is contained in:
parent
2970ed07c9
commit
f22eb5b4ba
17
rpm-4.11.2-double-separator-warning.patch
Normal file
17
rpm-4.11.2-double-separator-warning.patch
Normal file
@ -0,0 +1,17 @@
|
||||
diff -up rpm-4.11.2/build/parseReqs.c.double-sep-warning rpm-4.11.2/build/parseReqs.c
|
||||
--- rpm-4.11.2/build/parseReqs.c.double-sep-warning 2014-02-18 08:59:32.692891895 +0200
|
||||
+++ rpm-4.11.2/build/parseReqs.c 2014-02-18 09:00:17.572769945 +0200
|
||||
@@ -166,8 +166,11 @@ rpmRC parseRCPOT(rpmSpec spec, Package p
|
||||
if (rpmCharCheck(spec, EVR, ve-v, ".-_+:%{}~")) goto exit;
|
||||
|
||||
/* While ':' and '-' are valid, only one of each is valid. */
|
||||
- if (checkSep(EVR, '-', &emsg) || checkSep(EVR, ':', &emsg))
|
||||
- goto exit;
|
||||
+ if (checkSep(EVR, '-', &emsg) || checkSep(EVR, ':', &emsg)) {
|
||||
+ rpmlog(RPMLOG_WARNING, _("line %d: %s: %s\n"),
|
||||
+ spec->lineNum, emsg, spec->line);
|
||||
+ emsg = _free(emsg);
|
||||
+ }
|
||||
|
||||
re = ve; /* ==> next token after EVR string starts here */
|
||||
} else
|
11
rpm.spec
11
rpm.spec
@ -22,7 +22,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}1%{?dist}
|
||||
Release: %{?snapver:0.%{snapver}.}2%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/rpm-4.11.x/%{name}-%{srcver}.tar.bz2
|
||||
@ -48,6 +48,10 @@ Patch6: rpm-4.9.0-armhfp-logic.patch
|
||||
# Generate kmod(basename.ko) provides for kernel
|
||||
Patch7: rpm-4.11.1-kmod-find-provides.patch
|
||||
|
||||
# Fedora has big package stacks based on broken dependency EVRs, reduce the
|
||||
# double separator error into an error on released versions (#1065563)
|
||||
Patch10: rpm-4.11.2-double-separator-warning.patch
|
||||
|
||||
# Patches already in upstream
|
||||
# Filter soname dependencies by name
|
||||
Patch100: rpm-4.11.x-filter-soname-deps.patch
|
||||
@ -253,6 +257,8 @@ packages on a system.
|
||||
%patch4 -p1 -b .use-gpg2
|
||||
%patch7 -p1 -b .kmod-provides
|
||||
|
||||
%patch10 -p1 -b .double-sep-warning
|
||||
|
||||
%patch100 -p1 -b .filter-soname-deps
|
||||
%patch101 -p1 -b .dont-filter-ld64
|
||||
|
||||
@ -513,6 +519,9 @@ exit 0
|
||||
%doc COPYING doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Tue Feb 18 2014 Panu Matilainen <pmatilai@redhat.com> - 4.11.2-2
|
||||
- reduce the double separator spec parse error into a warning (#1065563)
|
||||
|
||||
* Thu Feb 13 2014 Panu Matilainen <pmatilai@redhat.com> - 4.11.2-1
|
||||
- update to 4.11.2 final (http://rpm.org/wiki/Releases/4.11.2)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user