Remove ppc64 inline asm (#233145)
This commit is contained in:
parent
6de7840333
commit
eb6953f551
30
rpm-4.4.2-no-ppc-asm.patch
Normal file
30
rpm-4.4.2-no-ppc-asm.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
--- rpm-4.3.3/lib/rpmrc.c.asm 2005-09-19 13:17:02.000000000 -0400
|
||||||
|
+++ rpm-4.3.3/lib/rpmrc.c 2005-09-19 13:17:23.000000000 -0400
|
||||||
|
@@ -1278,27 +1278,6 @@
|
||||||
|
}
|
||||||
|
# endif
|
||||||
|
|
||||||
|
-# if defined(__linux__) && defined(__powerpc__)
|
||||||
|
- {
|
||||||
|
- unsigned pvr = 0;
|
||||||
|
- __sighandler_t oldh = signal(SIGILL, mfspr_ill);
|
||||||
|
- if (setjmp(mfspr_jmpbuf) == 0) {
|
||||||
|
- __asm__ __volatile__ ("mfspr %0, 287" : "=r" (pvr));
|
||||||
|
- }
|
||||||
|
- signal(SIGILL, oldh);
|
||||||
|
-
|
||||||
|
- if ( pvr ) {
|
||||||
|
- pvr >>= 16;
|
||||||
|
- if ( pvr >= 0x40)
|
||||||
|
- strcpy(un.machine, "ppcpseries");
|
||||||
|
- else if ( (pvr == 0x36) || (pvr == 0x37) )
|
||||||
|
- strcpy(un.machine, "ppciseries");
|
||||||
|
- else
|
||||||
|
- strcpy(un.machine, "ppc");
|
||||||
|
- }
|
||||||
|
- }
|
||||||
|
-# endif
|
||||||
|
-
|
||||||
|
/* the uname() result goes through the arch_canon table */
|
||||||
|
canon = lookupInCanonTable(un.machine,
|
||||||
|
tables[RPM_MACHTABLE_INSTARCH].canons,
|
9
rpm.spec
9
rpm.spec
@ -1,4 +1,4 @@
|
|||||||
%define with_python_version 2.4%{nil}
|
%define with_python_version 2.5%{nil}
|
||||||
%define with_apidocs 1%{nil}
|
%define with_apidocs 1%{nil}
|
||||||
|
|
||||||
# XXX legacy requires './' payload prefix to be omitted from rpm packages.
|
# XXX legacy requires './' payload prefix to be omitted from rpm packages.
|
||||||
@ -17,7 +17,7 @@ Summary: The RPM package management system
|
|||||||
Name: rpm
|
Name: rpm
|
||||||
Version: 4.4.2
|
Version: 4.4.2
|
||||||
%{expand: %%define rpm_version %{version}}
|
%{expand: %%define rpm_version %{version}}
|
||||||
Release: 41%{?dist}
|
Release: 42%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source: rpm-%{rpm_version}.tar.gz
|
Source: rpm-%{rpm_version}.tar.gz
|
||||||
@ -62,6 +62,7 @@ Patch35: rpm-4.4.2-query-flushbuffer.patch
|
|||||||
Patch36: rpm-4.4.2-unicodekey.patch
|
Patch36: rpm-4.4.2-unicodekey.patch
|
||||||
Patch37: rpm-4.4.2-noneon.patch
|
Patch37: rpm-4.4.2-noneon.patch
|
||||||
Patch38: rpm-4.4.2-debugedit-canonicalize-path.patch
|
Patch38: rpm-4.4.2-debugedit-canonicalize-path.patch
|
||||||
|
Patch39: rpm-4.4.2-no-ppc-asm.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
Requires: patch > 2.5
|
Requires: patch > 2.5
|
||||||
Prereq: shadow-utils
|
Prereq: shadow-utils
|
||||||
@ -202,6 +203,7 @@ shell-like rules.
|
|||||||
%patch36 -p1 -b .unicode
|
%patch36 -p1 -b .unicode
|
||||||
%patch37 -p1 -b .noneon
|
%patch37 -p1 -b .noneon
|
||||||
%patch38 -p0 -b .debugcan
|
%patch38 -p0 -b .debugcan
|
||||||
|
%patch39 -p1 -b .noppcasm
|
||||||
|
|
||||||
# rebuild configure for ipv6
|
# rebuild configure for ipv6
|
||||||
autoconf
|
autoconf
|
||||||
@ -560,6 +562,9 @@ exit 0
|
|||||||
%{__includedir}/popt.h
|
%{__includedir}/popt.h
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 04 2007 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-42
|
||||||
|
- Remove ppc64 inline asm (#233145)
|
||||||
|
|
||||||
* Tue Mar 13 2007 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-41
|
* Tue Mar 13 2007 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-41
|
||||||
- Fix potential segfault when no rpmloc_path (#231146)
|
- Fix potential segfault when no rpmloc_path (#231146)
|
||||||
- Fix debugedit for relative paths (#232222)
|
- Fix debugedit for relative paths (#232222)
|
||||||
|
Loading…
Reference in New Issue
Block a user