parent
9fa2c4edfb
commit
e972e4365d
@ -43,3 +43,29 @@ index 0f39732..af1deb8 100644
|
||||
--
|
||||
1.9.3
|
||||
|
||||
From ee72c41d8b9994e4b1086c116927e8541a6ba592 Mon Sep 17 00:00:00 2001
|
||||
From: Lubos Kardos <lkardos@redhat.com>
|
||||
Date: Mon, 30 Mar 2015 09:31:15 +0200
|
||||
Subject: [PATCH] Fix off-by-one error (rhbz:#1206750)
|
||||
|
||||
- Caused by commit b598ce37d76bde5b8a6029008531aba6d2fbf594
|
||||
---
|
||||
lib/transaction.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/transaction.c b/lib/transaction.c
|
||||
index af1deb8..f9ffd10 100644
|
||||
--- a/lib/transaction.c
|
||||
+++ b/lib/transaction.c
|
||||
@@ -852,7 +852,7 @@ static void skipInstallFiles(const rpmts ts, rpmfiles files, rpmfs fs)
|
||||
|
||||
/* Skip (now empty) directories that had skipped files. */
|
||||
/* Iterate over dirs in reversed order to solve subdirs at first */
|
||||
- for (j = dc; j >= 0; j--) {
|
||||
+ for (j = dc - 1; j >= 0; j--) {
|
||||
const char * dn, * bn;
|
||||
size_t dnlen, bnlen;
|
||||
|
||||
--
|
||||
1.9.3
|
||||
|
||||
|
5
rpm.spec
5
rpm.spec
@ -27,7 +27,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}11%{?dist}
|
||||
Release: %{?snapver:0.%{snapver}.}12%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/rpm-4.12.x/%{name}-%{srcver}.tar.bz2
|
||||
@ -547,6 +547,9 @@ exit 0
|
||||
%doc doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Mon Mar 30 2015 Lubos Kardos <lkardos@redhat.com> 4.12.0-12
|
||||
- Fix segmentation fault (#1206750)
|
||||
|
||||
* Fri Mar 27 2015 Lubos Kardos <lkardos@redhat.com> 4.12.0-11
|
||||
- Pass _find_debuginfo_opts -g to eu-strip for executables (#1186563)
|
||||
- add_minidebug is not ran when strip_g is set (#1186563)
|
||||
|
Loading…
Reference in New Issue
Block a user