- python: dbmatch keys can be unicode objects also (#219008)
This commit is contained in:
parent
ef3fe1a1a5
commit
e6f84e9f86
11
rpm-4.4.2-unicodekey.patch
Normal file
11
rpm-4.4.2-unicodekey.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- rpm-4.4.2/python/rpmts-py.c.unicode 2006-12-11 13:32:38.000000000 -0500
|
||||
+++ rpm-4.4.2/python/rpmts-py.c 2006-12-11 13:33:13.000000000 -0500
|
||||
@@ -1362,7 +1362,7 @@
|
||||
|
||||
if (Key) {
|
||||
/*@-branchstate@*/
|
||||
- if (PyString_Check(Key)) {
|
||||
+ if (PyString_Check(Key) || PyUnicode_Check(Key)) {
|
||||
key = PyString_AsString(Key);
|
||||
len = PyString_Size(Key);
|
||||
} else if (PyInt_Check(Key)) {
|
7
rpm.spec
7
rpm.spec
@ -20,7 +20,7 @@ Name: rpm
|
||||
%define version 4.4.2
|
||||
Version: %{version}
|
||||
%{expand: %%define rpm_version %{version}}
|
||||
Release: 37%{?dist}
|
||||
Release: 38%{?dist}
|
||||
Group: System Environment/Base
|
||||
Source: ftp://wraptastic.org/pub/rpm-4.4.x/rpm-%{rpm_version}.tar.gz
|
||||
Source1: mono-find-provides
|
||||
@ -61,6 +61,7 @@ Patch32: rpm-4.4.2-debugpaths.patch
|
||||
Patch33: rpm-4.4.2-transaction-order.patch
|
||||
Patch34: rpm-4.4.2-debugopt.patch
|
||||
Patch35: rpm-4.4.2-query-flushbuffer.patch
|
||||
Patch36: rpm-4.4.2-unicodekey.patch
|
||||
License: GPL
|
||||
Conflicts: patch < 2.5
|
||||
%ifos linux
|
||||
@ -209,6 +210,7 @@ shell-like rules.
|
||||
%patch33 -p1 -b .order
|
||||
%patch34 -p1 -b .dbgopt
|
||||
%patch35 -p1 -b .flush
|
||||
%patch36 -p1 -b .unicode
|
||||
|
||||
# rebuild configure for ipv6
|
||||
autoconf
|
||||
@ -605,6 +607,9 @@ exit 0
|
||||
%{__includedir}/popt.h
|
||||
|
||||
%changelog
|
||||
* Mon Dec 11 2006 Jeremy Katz <katzj@redhat.com> - 4.4.2-38
|
||||
- python: dbmatch keys can be unicode objects also (#219008)
|
||||
|
||||
* Wed Dec 6 2006 Jeremy Katz <katzj@redhat.com> - 4.4.2-37
|
||||
- rebuild for python 2.5
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user