- fix pkg-config provide generation when pc's depend on each other
(#473814)
This commit is contained in:
parent
e603aec249
commit
dd1fdd8b26
13
rpm-4.6.0-rc2-pkgconfig-provides.patch
Normal file
13
rpm-4.6.0-rc2-pkgconfig-provides.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/scripts/pkgconfigdeps.sh b/scripts/pkgconfigdeps.sh
|
||||||
|
index 882d195..6baa0f1 100755
|
||||||
|
--- a/scripts/pkgconfigdeps.sh
|
||||||
|
+++ b/scripts/pkgconfigdeps.sh
|
||||||
|
@@ -17,6 +17,8 @@ case $1 in
|
||||||
|
case "${filename}" in
|
||||||
|
*.pc)
|
||||||
|
# Query the dependencies of the package.
|
||||||
|
+ DIR="`dirname ${filename}`"
|
||||||
|
+ export PKG_CONFIG_PATH="$DIR:$DIR/../../share/pkgconfig"
|
||||||
|
$pkgconfig --print-provides "$filename" 2> /dev/null | while read n r v ; do
|
||||||
|
# We have a dependency. Make a note that we need the pkgconfig
|
||||||
|
# tool for this package.
|
7
rpm.spec
7
rpm.spec
@ -18,7 +18,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: 0.%{snapver}.5
|
Release: 0.%{snapver}.6
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||||
@ -30,6 +30,7 @@ Patch0: rpm-4.5.90-devel-autodep.patch
|
|||||||
Patch1: rpm-4.5.90-pkgconfig-path.patch
|
Patch1: rpm-4.5.90-pkgconfig-path.patch
|
||||||
Patch2: rpm-4.5.90-gstreamer-provides.patch
|
Patch2: rpm-4.5.90-gstreamer-provides.patch
|
||||||
Patch3: rpm-4.5.90-rpmfileutil.patch
|
Patch3: rpm-4.5.90-rpmfileutil.patch
|
||||||
|
Patch4: rpm-4.6.0-rc2-pkgconfig-provides.patch
|
||||||
|
|
||||||
# Patches already in upstream
|
# Patches already in upstream
|
||||||
|
|
||||||
@ -164,6 +165,7 @@ that will manipulate RPM packages and databases.
|
|||||||
%patch1 -p1 -b .pkgconfig-path
|
%patch1 -p1 -b .pkgconfig-path
|
||||||
%patch2 -p1 -b .gstreamer-prov
|
%patch2 -p1 -b .gstreamer-prov
|
||||||
%patch3 -p1 -b .rpmfileutil
|
%patch3 -p1 -b .rpmfileutil
|
||||||
|
%patch4 -p1 -b .pkgconfig-provides
|
||||||
|
|
||||||
# needs a bit of upstream love first...
|
# needs a bit of upstream love first...
|
||||||
#%patch300 -p1 -b .posttrans
|
#%patch300 -p1 -b .posttrans
|
||||||
@ -354,6 +356,9 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 02 2008 Panu Matilainen <pmatilai@redhat.com>
|
||||||
|
- fix pkg-config provide generation when pc's depend on each other (#473814)
|
||||||
|
|
||||||
* Mon Dec 01 2008 Jindrich Novy <jnovy@redhat.com>
|
* Mon Dec 01 2008 Jindrich Novy <jnovy@redhat.com>
|
||||||
- include rpmfileutil.h from rpmmacro.h, unbreaks
|
- include rpmfileutil.h from rpmmacro.h, unbreaks
|
||||||
net-snmp (#473420)
|
net-snmp (#473420)
|
||||||
|
Loading…
Reference in New Issue
Block a user