- Fix wrong use of variable strip_g in find-debuginfo.sh
- resolves: #1207434
This commit is contained in:
parent
e972e4365d
commit
dabd097bc0
@ -91,7 +91,7 @@
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
+ # strip -g implies we have full symtab, don't add mini symtab in that case.
|
+ # strip -g implies we have full symtab, don't add mini symtab in that case.
|
||||||
+ strip_g || ($include_minidebug && add_minidebug "${debugfn}" "$f")
|
+ $strip_g || ($include_minidebug && add_minidebug "${debugfn}" "$f")
|
||||||
+
|
+
|
||||||
if [ -n "$id" ]; then
|
if [ -n "$id" ]; then
|
||||||
make_id_link "$id" "$dn/$(basename $f)"
|
make_id_link "$id" "$dn/$(basename $f)"
|
||||||
|
@ -29,7 +29,7 @@
|
|||||||
@@ -316,6 +318,8 @@
|
@@ -316,6 +318,8 @@
|
||||||
|
|
||||||
# strip -g implies we have full symtab, don't add mini symtab in that case.
|
# strip -g implies we have full symtab, don't add mini symtab in that case.
|
||||||
strip_g || ($include_minidebug && add_minidebug "${debugfn}" "$f")
|
$strip_g || ($include_minidebug && add_minidebug "${debugfn}" "$f")
|
||||||
+
|
+
|
||||||
+ echo "./${f#$RPM_BUILD_ROOT}" >> "$ELFBINSFILE"
|
+ echo "./${f#$RPM_BUILD_ROOT}" >> "$ELFBINSFILE"
|
||||||
|
|
||||||
|
5
rpm.spec
5
rpm.spec
@ -27,7 +27,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: %{?snapver:0.%{snapver}.}12%{?dist}
|
Release: %{?snapver:0.%{snapver}.}13%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/rpm-4.12.x/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/rpm-4.12.x/%{name}-%{srcver}.tar.bz2
|
||||||
@ -547,6 +547,9 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 31 2015 Lubos Kardos <lkardos@redhat.com> 4.12.0-13
|
||||||
|
- Fix wrong use of variable strip_g in find-debuginfo.sh (#1207434)
|
||||||
|
|
||||||
* Mon Mar 30 2015 Lubos Kardos <lkardos@redhat.com> 4.12.0-12
|
* Mon Mar 30 2015 Lubos Kardos <lkardos@redhat.com> 4.12.0-12
|
||||||
- Fix segmentation fault (#1206750)
|
- Fix segmentation fault (#1206750)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user