Fix verbose source uncompress regression (#2079127)
This commit is contained in:
parent
2f2f9ed291
commit
d849b13cc8
@ -0,0 +1,27 @@
|
||||
From bb36aac905cf8eb470f085574641d92c8d8ca20f Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <bb36aac905cf8eb470f085574641d92c8d8ca20f.1651042591.git.pmatilai@redhat.com>
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Wed, 27 Apr 2022 07:54:58 +0200
|
||||
Subject: [PATCH] Fix a typo in doUntar that breaks verbose uncompression
|
||||
|
||||
See https://bugzilla.redhat.com/show_bug.cgi?id=2079127
|
||||
---
|
||||
build/parsePrep.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/build/parsePrep.c b/build/parsePrep.c
|
||||
index 8cd2b84e6..bee820d11 100644
|
||||
--- a/build/parsePrep.c
|
||||
+++ b/build/parsePrep.c
|
||||
@@ -130,7 +130,7 @@ static char *doUntar(rpmSpec spec, uint32_t c, int quietly)
|
||||
}
|
||||
|
||||
buf = rpmExpand("%{__rpmuncompress} -x ",
|
||||
- quietly ? "" : "-v", sp->path, NULL);
|
||||
+ quietly ? "" : "-v ", sp->path, NULL);
|
||||
rstrcat(&buf,
|
||||
"\nSTATUS=$?\n"
|
||||
"if [ $STATUS -ne 0 ]; then\n"
|
||||
--
|
||||
2.35.1
|
||||
|
6
rpm.spec
6
rpm.spec
@ -30,7 +30,7 @@
|
||||
|
||||
%global rpmver 4.18.0
|
||||
%global snapver alpha1
|
||||
%global baserelease 4
|
||||
%global baserelease 5
|
||||
%global sover 9
|
||||
|
||||
%global srcver %{rpmver}%{?snapver:-%{snapver}}
|
||||
@ -59,6 +59,7 @@ Patch3: rpm-4.9.90-no-man-dirs.patch
|
||||
Patch100: 0001-Fix-OpenPGP-key-ID-parsing-regression.patch
|
||||
Patch101: 0001-Revert-Fix-shared-colored-files-not-removed-on-erasu.patch
|
||||
Patch102: 0001-Fix-regressions-on-dynamic-buildrequires-cli-switche.patch
|
||||
Patch103: 0001-Fix-a-typo-in-doUntar-that-breaks-verbose-uncompress.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch906: rpm-4.7.1-geode-i686.patch
|
||||
@ -613,6 +614,9 @@ fi
|
||||
%doc docs/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Wed Apr 27 2022 Panu Matilainen <pmatilai@redhat.com> - 4.18.0-0.alpha1.5
|
||||
- Fix verbose source uncompress regression (#2079127)
|
||||
|
||||
* Tue Apr 26 2022 Panu Matilainen <pmatilai@redhat.com> - 4.18.0-0.alpha1.4
|
||||
- Further dynamic buildrequires cli switch regression fixes (#2078744)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user