- Fix last occurence of PyString
This commit is contained in:
parent
659760a576
commit
d407fb640c
33
rpm-4.12.90-remove-pystring.patch
Normal file
33
rpm-4.12.90-remove-pystring.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From aec4f88ed585aedae1b35f447ee730a9054d6a4a Mon Sep 17 00:00:00 2001
|
||||
From: Thierry Vignaud <thierry.vignaud@gmail.com>
|
||||
Date: Mon, 10 Aug 2015 04:38:47 -0400
|
||||
Subject: [PATCH] Fix last occurence of PyString
|
||||
|
||||
This should have been done in
|
||||
commit 1866fc41c8fdf5a82705cee7f1043d5fb634c3be
|
||||
This fixes:
|
||||
|
||||
$ python3 -c 'import rpm._rpmb'
|
||||
Traceback (most recent call last):
|
||||
File "<string>", line 1, in <module>
|
||||
ImportError: /usr/lib64/python3.4/site-packages/rpm/_rpmb.cpython-34m.so: undefined symbol: PyString_FromString
|
||||
---
|
||||
python/spec-py.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/python/spec-py.c b/python/spec-py.c
|
||||
index 728b63c..f710f5c 100644
|
||||
--- a/python/spec-py.c
|
||||
+++ b/python/spec-py.c
|
||||
@@ -51,7 +51,7 @@ static PyObject *pkgGetSection(rpmSpecPkg pkg, int section)
|
||||
{
|
||||
char *sect = rpmSpecPkgGetSection(pkg, section);
|
||||
if (sect != NULL) {
|
||||
- PyObject *ps = PyString_FromString(sect);
|
||||
+ PyObject *ps = PyBytes_FromString(sect);
|
||||
free(sect);
|
||||
if (ps != NULL)
|
||||
return ps;
|
||||
--
|
||||
1.9.3
|
||||
|
6
rpm.spec
6
rpm.spec
@ -27,7 +27,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}6%{?dist}
|
||||
Release: %{?snapver:0.%{snapver}.}7%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/rpm-4.12.x/%{name}-%{srcver}.tar.bz2
|
||||
@ -56,6 +56,7 @@ Patch102: rpm-4.12.90-fix-macro-warning.patch
|
||||
Patch103: rpm-4.12.90-modify-rpmisglob.patch
|
||||
Patch104: rpm-4.12.90-try-unglobbed.patch
|
||||
Patch105: rpm-4.12.90-show-filetriggers.patch
|
||||
Patch106: rpm-4.12.90-remove-pystring.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch302: rpm-4.7.1-geode-i686.patch
|
||||
@ -540,6 +541,9 @@ exit 0
|
||||
%doc doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Mon Aug 10 2015 Lubos Kardos <lkardos@redhat.com> - 4.12.90-7
|
||||
- Fix last occurence of PyString
|
||||
|
||||
* Thu Aug 06 2015 Lubos Kardos <lkardos@redhat.com> - 4.12.90-6
|
||||
- Add --filetriggers option to show info about file triggers.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user