parent
8082f33da7
commit
d25c1c785c
41
rpm-4.4.2.2-debugedit-fpc.patch
Normal file
41
rpm-4.4.2.2-debugedit-fpc.patch
Normal file
@ -0,0 +1,41 @@
|
||||
diff -r f531397e7635 -r 751cf2c7614e tools/debugedit.c
|
||||
--- a/tools/debugedit.c Sun Oct 14 12:49:18 2007 +0300
|
||||
+++ b/tools/debugedit.c Thu Oct 18 09:34:54 2007 +0300
|
||||
@@ -560,11 +560,16 @@ edit_dwarf2_line (DSO *dso, uint_32 off,
|
||||
}
|
||||
else
|
||||
{
|
||||
- memcpy (s, comp_dir, comp_dir_len);
|
||||
- s[comp_dir_len] = '/';
|
||||
- memcpy (s + comp_dir_len + 1, dirt[value], dir_len);
|
||||
- s[comp_dir_len + 1 + dir_len] = '/';
|
||||
- memcpy (s + comp_dir_len + 1 + dir_len + 1, file, file_len + 1);
|
||||
+ char *p = s;
|
||||
+ if (comp_dir_len != 0)
|
||||
+ {
|
||||
+ memcpy (s, comp_dir, comp_dir_len);
|
||||
+ s[comp_dir_len] = '/';
|
||||
+ p += comp_dir_len + 1;
|
||||
+ }
|
||||
+ memcpy (p, dirt[value], dir_len);
|
||||
+ p[dir_len] = '/';
|
||||
+ memcpy (p + dir_len + 1, file, file_len + 1);
|
||||
}
|
||||
canonicalize_path (s, s);
|
||||
if (list_file_fd != -1)
|
||||
@@ -822,6 +827,7 @@ edit_attributes (DSO *dso, unsigned char
|
||||
|
||||
switch (form)
|
||||
{
|
||||
+ case DW_FORM_ref_addr: /* ptr_size in DWARF 2, offset in DWARF 3 */
|
||||
case DW_FORM_addr:
|
||||
ptr += ptr_size;
|
||||
break;
|
||||
@@ -847,7 +853,6 @@ edit_attributes (DSO *dso, unsigned char
|
||||
case DW_FORM_udata:
|
||||
read_uleb128 (ptr);
|
||||
break;
|
||||
- case DW_FORM_ref_addr:
|
||||
case DW_FORM_strp:
|
||||
ptr += 4;
|
||||
break;
|
7
rpm.spec
7
rpm.spec
@ -6,7 +6,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: 4.4.2.2
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source: http://rpm.org/releases/rpm-4.4.x/%{name}-%{version}.tar.gz
|
||||
@ -19,6 +19,7 @@ Patch6: rpm-4.4.2.2-matchpathcon.patch
|
||||
Patch7: rpm-4.4.2.1-no-popt.patch
|
||||
Patch8: rpm-4.4.2.2-nonutf-comment.patch
|
||||
Patch9: rpm-4.4.2.2-osgideps.patch
|
||||
Patch10: rpm-4.4.2.2-debugedit-fpc.patch
|
||||
|
||||
# XXX Beware, this is one murky license, partially GPL/LGPL dual-licensed
|
||||
# and several different components with their own licenses included...
|
||||
@ -143,6 +144,7 @@ that will manipulate RPM packages and databases.
|
||||
%patch7 -p1 -b .no-popt
|
||||
%patch8 -p1 -b .nonutf-comment
|
||||
%patch9 -p1 -b .osgideps
|
||||
%patch10 -p1 -b .debugedit-fpc
|
||||
|
||||
# force external popt
|
||||
rm -rf popt/
|
||||
@ -405,6 +407,9 @@ exit 0
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Oct 18 2007 Panu Matilainen <pmatilai@redhat.com> 4.4.2.2-4
|
||||
- debugedit fixes from Roland McGrath (#336951, #337011)
|
||||
|
||||
* Fri Oct 12 2007 Panu Matilainen <pmatilai@redhat.com> 4.4.2.2-3
|
||||
- add OSGi dependency generator script
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user