- add patch to fix segfault with non-merged hdlists
This commit is contained in:
parent
c3f9d9ab37
commit
ca3040616f
11
rpm-4.4.1-nonmerged.patch
Normal file
11
rpm-4.4.1-nonmerged.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- rpm-4.4.1/lib/rpmal.c~ 2005-04-26 16:29:57.000000000 -0400
|
||||||
|
+++ rpm-4.4.1/lib/rpmal.c 2005-04-27 00:01:59.000000000 -0400
|
||||||
|
@@ -744,7 +744,7 @@
|
||||||
|
|
||||||
|
/*@-branchstate@*/ /* FIX: ret is a problem */
|
||||||
|
for (found = 0, ret = NULL;
|
||||||
|
- die <= al->dirs + al->numDirs && dieCompare(die, dieNeedle) == 0;
|
||||||
|
+ die < al->dirs + al->numDirs && dieCompare(die, dieNeedle) == 0;
|
||||||
|
die++)
|
||||||
|
{
|
||||||
|
|
7
rpm.spec
7
rpm.spec
@ -20,7 +20,7 @@ Name: rpm
|
|||||||
%define version 4.4.1
|
%define version 4.4.1
|
||||||
Version: %{version}
|
Version: %{version}
|
||||||
%{expand: %%define rpm_version %{version}}
|
%{expand: %%define rpm_version %{version}}
|
||||||
Release: 9
|
Release: 10
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Source: ftp://jbj.org/pub/rpm-devel/rpm-%{rpm_version}.tar.gz
|
Source: ftp://jbj.org/pub/rpm-devel/rpm-%{rpm_version}.tar.gz
|
||||||
Patch0: rpm-4.4.1-posttrans.patch
|
Patch0: rpm-4.4.1-posttrans.patch
|
||||||
@ -29,6 +29,7 @@ Patch2: rpm-4.4.1-hkp-disable.patch
|
|||||||
Patch3: rpm-4.4.1-read-macro.patch
|
Patch3: rpm-4.4.1-read-macro.patch
|
||||||
Patch4: rpm-4.4.1-fileconflicts.patch
|
Patch4: rpm-4.4.1-fileconflicts.patch
|
||||||
Patch5: rpm-4.4.1-prereq.patch
|
Patch5: rpm-4.4.1-prereq.patch
|
||||||
|
Patch6: rpm-4.4.1-nonmerged.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
Conflicts: patch < 2.5
|
Conflicts: patch < 2.5
|
||||||
%ifos linux
|
%ifos linux
|
||||||
@ -143,6 +144,7 @@ shell-like rules.
|
|||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch4 -p1 -b .fileconflicts
|
%patch4 -p1 -b .fileconflicts
|
||||||
%patch5 -p1 -b .prereq
|
%patch5 -p1 -b .prereq
|
||||||
|
%patch6 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -513,6 +515,9 @@ exit 0
|
|||||||
%{__includedir}/popt.h
|
%{__includedir}/popt.h
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 4.4.1-10
|
||||||
|
- add patch to fix segfault with non-merged hdlists
|
||||||
|
|
||||||
* Thu Mar 31 2005 Thomas Woerner <twoerner@redhat.com> 4.4.1-9
|
* Thu Mar 31 2005 Thomas Woerner <twoerner@redhat.com> 4.4.1-9
|
||||||
- enabled prereqs again
|
- enabled prereqs again
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user