- update to 4.10.1
This commit is contained in:
parent
71102f1372
commit
c9d5915d63
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
|||||||
/rpm-4.9.90.git11536.tar.bz2
|
/rpm-4.9.90.git11536.tar.bz2
|
||||||
/rpm-4.10.0-beta1.tar.bz2
|
/rpm-4.10.0-beta1.tar.bz2
|
||||||
/rpm-4.10.0.tar.bz2
|
/rpm-4.10.0.tar.bz2
|
||||||
|
/rpm-4.10.1.tar.bz2
|
||||||
|
@ -1,32 +0,0 @@
|
|||||||
diff --git a/lib/rpmrc.c b/lib/rpmrc.c
|
|
||||||
index ba156fe..96f05ce 100644
|
|
||||||
--- a/lib/rpmrc.c
|
|
||||||
+++ b/lib/rpmrc.c
|
|
||||||
@@ -1093,8 +1093,11 @@ static void defaultMachine(const char ** arch,
|
|
||||||
# if defined(__linux__) && defined(__powerpc__)
|
|
||||||
{
|
|
||||||
int powerlvl;
|
|
||||||
- if (sscanf(rpmat.platform, "power%d", &powerlvl) == 1 && powerlvl > 6)
|
|
||||||
+ if (!rstreq(un.machine, "ppc") &&
|
|
||||||
+ sscanf(rpmat.platform, "power%d", &powerlvl) == 1 &&
|
|
||||||
+ powerlvl > 6) {
|
|
||||||
strcpy(un.machine, "ppc64p7");
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
# endif /* ppc64*-linux */
|
|
||||||
|
|
||||||
diff --git a/macros.in b/macros.in
|
|
||||||
index 4c77bbb..4a4a1e4 100644
|
|
||||||
--- a/macros.in
|
|
||||||
+++ b/macros.in
|
|
||||||
@@ -998,6 +998,10 @@ done \
|
|
||||||
# arch macro for all supported Alpha processors
|
|
||||||
%alpha alpha alphaev56 alphaev6 alphaev67
|
|
||||||
|
|
||||||
+#------------------------------------------------------------------------------
|
|
||||||
+# arch macro for all supported PowerPC 64 processors
|
|
||||||
+%power64 ppc64 ppc64p7
|
|
||||||
+
|
|
||||||
#------------------------------------------------------------------------
|
|
||||||
# Use in %install to generate locale specific file lists. For example,
|
|
||||||
#
|
|
11
rpm.spec
11
rpm.spec
@ -11,7 +11,7 @@
|
|||||||
|
|
||||||
%define rpmhome /usr/lib/rpm
|
%define rpmhome /usr/lib/rpm
|
||||||
|
|
||||||
%define rpmver 4.10.0
|
%define rpmver 4.10.1
|
||||||
%define srcver %{rpmver}%{?snapver:-%{snapver}}
|
%define srcver %{rpmver}%{?snapver:-%{snapver}}
|
||||||
|
|
||||||
%define bdbname libdb
|
%define bdbname libdb
|
||||||
@ -21,7 +21,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: %{?snapver:0.%{snapver}.}6%{?dist}
|
Release: %{?snapver:0.%{snapver}.}1%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/rpm-4.10.x/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/rpm-4.10.x/%{name}-%{srcver}.tar.bz2
|
||||||
@ -45,7 +45,6 @@ Patch5: rpm-4.9.90-armhfp.patch
|
|||||||
Patch6: rpm-4.9.0-armhfp-logic.patch
|
Patch6: rpm-4.9.0-armhfp-logic.patch
|
||||||
|
|
||||||
# Patches already in upstream
|
# Patches already in upstream
|
||||||
Patch100: rpm-4.10.0-ppc64p7-fixes.patch
|
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch301: rpm-4.6.0-niagara.patch
|
Patch301: rpm-4.6.0-niagara.patch
|
||||||
@ -219,8 +218,6 @@ packages on a system.
|
|||||||
%patch3 -p1 -b .no-man-dirs
|
%patch3 -p1 -b .no-man-dirs
|
||||||
%patch4 -p1 -b .use-gpg2
|
%patch4 -p1 -b .use-gpg2
|
||||||
|
|
||||||
%patch100 -p1 -b .ppc647p-fixes
|
|
||||||
|
|
||||||
%patch301 -p1 -b .niagara
|
%patch301 -p1 -b .niagara
|
||||||
%patch302 -p1 -b .geode
|
%patch302 -p1 -b .geode
|
||||||
%patch304 -p1 -b .ldflags
|
%patch304 -p1 -b .ldflags
|
||||||
@ -379,6 +376,7 @@ exit 0
|
|||||||
%{rpmhome}/rpmdb_*
|
%{rpmhome}/rpmdb_*
|
||||||
%{rpmhome}/rpm.daily
|
%{rpmhome}/rpm.daily
|
||||||
%{rpmhome}/rpm.log
|
%{rpmhome}/rpm.log
|
||||||
|
%{rpmhome}/rpm.supp
|
||||||
%{rpmhome}/rpm2cpio.sh
|
%{rpmhome}/rpm2cpio.sh
|
||||||
%{rpmhome}/tgpg
|
%{rpmhome}/tgpg
|
||||||
|
|
||||||
@ -450,6 +448,9 @@ exit 0
|
|||||||
%doc COPYING doc/librpm/html/*
|
%doc COPYING doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 03 2012 Panu Matilainen <pmatilai@redhat.com> - 4.10.1-1
|
||||||
|
- update to 4.10.1 ((http://rpm.org/wiki/Releases/4.10.1)
|
||||||
|
|
||||||
* Mon Jul 30 2012 Panu Matilainen <pmatilai@redhat.com> - 4.10.0-6
|
* Mon Jul 30 2012 Panu Matilainen <pmatilai@redhat.com> - 4.10.0-6
|
||||||
- move our tmpfiles config to more politically correct location (#840192)
|
- move our tmpfiles config to more politically correct location (#840192)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user