parent
cbb5072683
commit
c542e5e8af
@ -1 +1 @@
|
|||||||
rpm-4.6.0-rc2.tar.bz2
|
rpm-4.6.0-rc3.tar.bz2
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
commit 0b80d38f32b438d81d47fc61074b1f163518d68f
|
|
||||||
Author: Jindrich Novy <jnovy@redhat.com>
|
|
||||||
Date: Mon Dec 1 12:16:56 2008 +0100
|
|
||||||
|
|
||||||
Include rpmfileutil.h from rpmmacro.h so that
|
|
||||||
prototype for rpmGenPath() is included (rhbz#473420)
|
|
||||||
- unbreaks net-snmp
|
|
||||||
|
|
||||||
diff --git a/rpmio/rpmmacro.h b/rpmio/rpmmacro.h
|
|
||||||
index 7391efd..765c78c 100644
|
|
||||||
--- a/rpmio/rpmmacro.h
|
|
||||||
+++ b/rpmio/rpmmacro.h
|
|
||||||
@@ -9,6 +9,7 @@
|
|
||||||
#include <stddef.h>
|
|
||||||
|
|
||||||
#include <rpm/rpmutil.h>
|
|
||||||
+#include <rpm/rpmfileutil.h>
|
|
||||||
|
|
||||||
#ifdef __cplusplus
|
|
||||||
extern "C" {
|
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/scripts/pkgconfigdeps.sh b/scripts/pkgconfigdeps.sh
|
|
||||||
index 882d195..6baa0f1 100755
|
|
||||||
--- a/scripts/pkgconfigdeps.sh
|
|
||||||
+++ b/scripts/pkgconfigdeps.sh
|
|
||||||
@@ -17,6 +17,8 @@ case $1 in
|
|
||||||
case "${filename}" in
|
|
||||||
*.pc)
|
|
||||||
# Query the dependencies of the package.
|
|
||||||
+ DIR="`dirname ${filename}`"
|
|
||||||
+ export PKG_CONFIG_PATH="$DIR:$DIR/../../share/pkgconfig"
|
|
||||||
$pkgconfig --print-provides "$filename" 2> /dev/null | while read n r v ; do
|
|
||||||
# We have a dependency. Make a note that we need the pkgconfig
|
|
||||||
# tool for this package.
|
|
12
rpm.spec
12
rpm.spec
@ -10,7 +10,7 @@
|
|||||||
%define rpmhome /usr/lib/rpm
|
%define rpmhome /usr/lib/rpm
|
||||||
|
|
||||||
%define rpmver 4.6.0
|
%define rpmver 4.6.0
|
||||||
%define snapver rc2
|
%define snapver rc3
|
||||||
%define srcver %{rpmver}-%{snapver}
|
%define srcver %{rpmver}-%{snapver}
|
||||||
|
|
||||||
%define bdbver 4.5.20
|
%define bdbver 4.5.20
|
||||||
@ -18,7 +18,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: 0.%{snapver}.9
|
Release: 0.%{snapver}.1
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||||
@ -29,8 +29,6 @@ Source1: db-%{bdbver}.tar.gz
|
|||||||
Patch0: rpm-4.5.90-devel-autodep.patch
|
Patch0: rpm-4.5.90-devel-autodep.patch
|
||||||
Patch1: rpm-4.5.90-pkgconfig-path.patch
|
Patch1: rpm-4.5.90-pkgconfig-path.patch
|
||||||
Patch2: rpm-4.5.90-gstreamer-provides.patch
|
Patch2: rpm-4.5.90-gstreamer-provides.patch
|
||||||
Patch3: rpm-4.5.90-rpmfileutil.patch
|
|
||||||
Patch4: rpm-4.6.0-rc2-pkgconfig-provides.patch
|
|
||||||
|
|
||||||
# Patches already in upstream
|
# Patches already in upstream
|
||||||
|
|
||||||
@ -165,8 +163,6 @@ that will manipulate RPM packages and databases.
|
|||||||
%patch0 -p1 -b .devel-autodep
|
%patch0 -p1 -b .devel-autodep
|
||||||
%patch1 -p1 -b .pkgconfig-path
|
%patch1 -p1 -b .pkgconfig-path
|
||||||
%patch2 -p1 -b .gstreamer-prov
|
%patch2 -p1 -b .gstreamer-prov
|
||||||
%patch3 -p1 -b .rpmfileutil
|
|
||||||
%patch4 -p1 -b .pkgconfig-provides
|
|
||||||
|
|
||||||
# needs a bit of upstream love first...
|
# needs a bit of upstream love first...
|
||||||
#%patch300 -p1 -b .posttrans
|
#%patch300 -p1 -b .posttrans
|
||||||
@ -357,6 +353,10 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 09 2008 Panu Matilainen <pmatilai@redhat.com> - 4.6.0-0.rc3.1
|
||||||
|
- update to rpm 4.6.0-rc3
|
||||||
|
- fixes #475214, #474550, #473239
|
||||||
|
|
||||||
* Wed Dec 3 2008 Jeremy Katz <katzj@redhat.com> - 4.6.0-0.rc2.9
|
* Wed Dec 3 2008 Jeremy Katz <katzj@redhat.com> - 4.6.0-0.rc2.9
|
||||||
- I built into the wrong place
|
- I built into the wrong place
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user