Rebase to rpm 4.17.0 rc1
This commit is contained in:
parent
a66e966a5f
commit
c37b0e75b2
1
.gitignore
vendored
1
.gitignore
vendored
@ -48,3 +48,4 @@
|
||||
/rpm-4.16.1.3.tar.bz2
|
||||
/rpm-4.16.90-git15395.tar.bz2
|
||||
/rpm-4.17.0-beta1.tar.bz2
|
||||
/rpm-4.17.0-rc1.tar.bz2
|
||||
|
@ -1,25 +0,0 @@
|
||||
From 9772abc058ae7183dbfb2356ec0af0a3d610c2c9 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <9772abc058ae7183dbfb2356ec0af0a3d610c2c9.1624424665.git.pmatilai@redhat.com>
|
||||
From: Florian Festi <ffesti@redhat.com>
|
||||
Date: Tue, 22 Jun 2021 16:52:35 +0200
|
||||
Subject: [PATCH 1/2] Also add rendered Japanese man pages
|
||||
|
||||
---
|
||||
docs/man/Makefile.am | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/docs/man/Makefile.am b/docs/man/Makefile.am
|
||||
index 124a94d94..595444ad5 100644
|
||||
--- a/docs/man/Makefile.am
|
||||
+++ b/docs/man/Makefile.am
|
||||
@@ -63,6 +63,7 @@ EXTRA_DIST += fr/rpm.8
|
||||
man_ja_man8dir = $(mandir)/ja/man8
|
||||
man_ja_man8_DATA = ja/rpm.8 ja/rpm2cpio.8 ja/rpmbuild.8 ja/rpmgraph.8
|
||||
EXTRA_DIST += ja/rpm.8.md ja/rpm2cpio.8.md ja/rpmbuild.8.md ja/rpmgraph.8.md
|
||||
+EXTRA_DIST += ja/rpm.8 ja/rpm2cpio.8 ja/rpmbuild.8 ja/rpmgraph.8
|
||||
|
||||
man_ko_man8dir = $(mandir)/ko/man8
|
||||
man_ko_man8_DATA = ko/rpm.8 ko/rpm2cpio.8
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,33 +0,0 @@
|
||||
From 89eb448b6c5941921acdc7e8b5e18050900e9f20 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <89eb448b6c5941921acdc7e8b5e18050900e9f20.1624424665.git.pmatilai@redhat.com>
|
||||
In-Reply-To: <9772abc058ae7183dbfb2356ec0af0a3d610c2c9.1624424665.git.pmatilai@redhat.com>
|
||||
References: <9772abc058ae7183dbfb2356ec0af0a3d610c2c9.1624424665.git.pmatilai@redhat.com>
|
||||
From: Florian Festi <ffesti@redhat.com>
|
||||
Date: Tue, 22 Jun 2021 16:53:13 +0200
|
||||
Subject: [PATCH 2/2] Don't depend on translation sub directories
|
||||
|
||||
just create them. Otherwise their date messes up the man page
|
||||
genenration and triggers a rebuild when on wanted (e.g. when building
|
||||
form the tar ball)
|
||||
|
||||
Resolves: #1729
|
||||
---
|
||||
docs/man/Makefile.am | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/docs/man/Makefile.am b/docs/man/Makefile.am
|
||||
index 595444ad5..e10959255 100644
|
||||
--- a/docs/man/Makefile.am
|
||||
+++ b/docs/man/Makefile.am
|
||||
@@ -87,7 +87,7 @@ man_sk_man8_DATA = sk/rpm.8
|
||||
EXTRA_DIST += sk/rpm.8.md
|
||||
EXTRA_DIST += sk/rpm.8
|
||||
|
||||
-%: $(srcdir)/%.md fr ja ko pl ru sk
|
||||
+%: $(srcdir)/%.md
|
||||
@$(MKDIR_P) `dirname $@`
|
||||
${PANDOC} -s -t man $(srcdir)/$@.md -o $@
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
24
rpm.spec
24
rpm.spec
@ -29,7 +29,7 @@
|
||||
%define rpmhome /usr/lib/rpm
|
||||
|
||||
%global rpmver 4.17.0
|
||||
%global snapver beta1
|
||||
%global snapver rc1
|
||||
%global rel 0
|
||||
%global sover 9
|
||||
|
||||
@ -39,7 +39,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}%{rel}%{?dist}.2
|
||||
Release: %{?snapver:0.%{snapver}.}%{rel}%{?dist}
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://ftp.rpm.org/releases/%{srcdir}/rpm-%{srcver}.tar.bz2
|
||||
|
||||
@ -51,8 +51,6 @@ Patch1: rpm-4.17.x-siteconfig.patch
|
||||
Patch3: rpm-4.9.90-no-man-dirs.patch
|
||||
|
||||
# Patches already upstream:
|
||||
Patch100: 0001-Also-add-rendered-Japanese-man-pages.patch
|
||||
Patch101: 0002-Don-t-depend-on-translation-sub-directories.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch906: rpm-4.7.1-geode-i686.patch
|
||||
@ -306,6 +304,16 @@ Requires: rpm-libs%{_isa} = %{version}-%{release}
|
||||
See https://people.redhat.com/sgrubb/fapolicyd/ for information about
|
||||
the fapolicyd daemon.
|
||||
|
||||
%package plugin-dbus-announce
|
||||
Summary: Rpm plugin for announcing transactions on the DBUS
|
||||
Requires: rpm-libs%{_isa} = %{version}-%{release}
|
||||
|
||||
%description plugin-dbus-announce
|
||||
The plugin announces basic information about rpm transactions to the
|
||||
system DBUS - like packages installed or removed. Other programs can
|
||||
subscribe to the signals to get notified when packages on the system
|
||||
change.
|
||||
|
||||
# with plugins
|
||||
%endif
|
||||
|
||||
@ -507,6 +515,11 @@ fi
|
||||
%{_libdir}/rpm-plugins/audit.so
|
||||
%{_mandir}/man8/rpm-plugin-audit.8*
|
||||
# with plugins
|
||||
|
||||
%files plugin-dbus-announce
|
||||
%{_libdir}/rpm-plugins/dbus_announce.so
|
||||
%{_mandir}/man8/rpm-plugin-dbus-announce.8*
|
||||
%{_sysconfdir}/dbus-1/system.d/org.rpm.conf
|
||||
%endif
|
||||
|
||||
%files build-libs
|
||||
@ -563,6 +576,9 @@ fi
|
||||
%doc docs/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Thu Aug 19 2021 Panu Matilainen <pmatilai@redhat.com> - 4.17.0-0.rc1.1
|
||||
- Rebase to 4.17.0 rc1
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 4.17.0-0.beta1.0.2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (rpm-4.17.0-beta1.tar.bz2) = 4d3dab794492fff249443994daaa8a95014748003aa19b56b985834c3e02955c67d33ecb23e1a3fd7a5664767a6221e26871fedca9a5153c1f320255109c0589
|
||||
SHA512 (rpm-4.17.0-rc1.tar.bz2) = e31c6c589ce44ed68c6aa8c020b93211605a9f04bf20dc46f2b73c3b609e06bf9f167fa26080cb405c9a7339e9da0c64a2c36fbe3e63fd18c0210787bd70e498
|
||||
|
Loading…
Reference in New Issue
Block a user