Revert generation of binary packages in parallel
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
68ce99e7f4
commit
c065605b86
@ -0,0 +1,44 @@
|
|||||||
|
From cb9e874ba52d866a86164ae8675ab6f07a35845e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||||
|
Date: Tue, 11 Jun 2019 00:07:49 +0200
|
||||||
|
Subject: [PATCH] Revert "Run binary package generation in parallel threads"
|
||||||
|
|
||||||
|
https://github.com/rpm-software-management/rpm/issues/742
|
||||||
|
|
||||||
|
This reverts commit 18c92e6fe76df334fed8d5f04b5f40b776daba8c.
|
||||||
|
---
|
||||||
|
build/pack.c | 13 +------------
|
||||||
|
1 file changed, 1 insertion(+), 12 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/build/pack.c b/build/pack.c
|
||||||
|
index 447e3ec94..e8d4c220c 100644
|
||||||
|
--- a/build/pack.c
|
||||||
|
+++ b/build/pack.c
|
||||||
|
@@ -744,23 +744,12 @@ rpmRC packageBinaries(rpmSpec spec, const char *cookie, int cheating)
|
||||||
|
rpmRC rc = RPMRC_OK;
|
||||||
|
Package pkg;
|
||||||
|
|
||||||
|
- /* Run binary creation in parallel */
|
||||||
|
- #pragma omp parallel
|
||||||
|
- #pragma omp single
|
||||||
|
for (pkg = spec->packages; pkg != NULL; pkg = pkg->next) {
|
||||||
|
- #pragma omp task
|
||||||
|
- {
|
||||||
|
pkg->rc = packageBinary(spec, pkg, cookie, cheating, &pkg->filename);
|
||||||
|
- rpmlog(RPMLOG_DEBUG,
|
||||||
|
- _("Finished binary package job, result %d, filename %s\n"),
|
||||||
|
- pkg->rc, pkg->filename);
|
||||||
|
if (pkg->rc) {
|
||||||
|
- #pragma omp critical
|
||||||
|
rc = pkg->rc;
|
||||||
|
- }
|
||||||
|
- } /* omp task */
|
||||||
|
- if (rc)
|
||||||
|
break;
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
|
||||||
|
/* Now check the package set if enabled */
|
||||||
|
--
|
||||||
|
2.22.0.rc3
|
||||||
|
|
9
rpm.spec
9
rpm.spec
@ -21,7 +21,7 @@
|
|||||||
|
|
||||||
%global rpmver 4.14.90
|
%global rpmver 4.14.90
|
||||||
%global snapver git14653
|
%global snapver git14653
|
||||||
%global rel 9
|
%global rel 10
|
||||||
|
|
||||||
%global srcver %{version}%{?snapver:-%{snapver}}
|
%global srcver %{version}%{?snapver:-%{snapver}}
|
||||||
%global srcdir %{?snapver:testing}%{!?snapver:%{name}-%(echo %{version} | cut -d'.' -f1-2).x}
|
%global srcdir %{?snapver:testing}%{!?snapver:%{name}-%(echo %{version} | cut -d'.' -f1-2).x}
|
||||||
@ -49,6 +49,8 @@ Patch3: rpm-4.9.90-no-man-dirs.patch
|
|||||||
Patch5: rpm-4.12.0-rpm2cpio-hack.patch
|
Patch5: rpm-4.12.0-rpm2cpio-hack.patch
|
||||||
# https://github.com/rpm-software-management/rpm/pull/473
|
# https://github.com/rpm-software-management/rpm/pull/473
|
||||||
Patch6: 0001-find-debuginfo.sh-decompress-DWARF-compressed-ELF-se.patch
|
Patch6: 0001-find-debuginfo.sh-decompress-DWARF-compressed-ELF-se.patch
|
||||||
|
# https://github.com/rpm-software-management/rpm/issues/742
|
||||||
|
Patch7: 0001-Revert-Run-binary-package-generation-in-parallel-thr.patch
|
||||||
|
|
||||||
# Patches already upstream:
|
# Patches already upstream:
|
||||||
|
|
||||||
@ -57,8 +59,6 @@ Patch906: rpm-4.7.1-geode-i686.patch
|
|||||||
# Probably to be upstreamed in slightly different form
|
# Probably to be upstreamed in slightly different form
|
||||||
Patch907: rpm-4.15.x-ldflags.patch
|
Patch907: rpm-4.15.x-ldflags.patch
|
||||||
|
|
||||||
Patch999: test.diff
|
|
||||||
|
|
||||||
# Partially GPL/LGPL dual-licensed and some bits with BSD
|
# Partially GPL/LGPL dual-licensed and some bits with BSD
|
||||||
# SourceLicense: (GPLv2+ and LGPLv2+ with exceptions) and BSD
|
# SourceLicense: (GPLv2+ and LGPLv2+ with exceptions) and BSD
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
@ -539,6 +539,9 @@ make check || (cat tests/rpmtests.log; exit 0)
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 11 00:08:50 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.14.90-0.git14653.10
|
||||||
|
- Revert generation of binary packages in parallel
|
||||||
|
|
||||||
* Mon Jun 10 2019 Panu Matilainen <pmatilai@redhat.com> - 4.14.90-0.git14653.1
|
* Mon Jun 10 2019 Panu Matilainen <pmatilai@redhat.com> - 4.14.90-0.git14653.1
|
||||||
- Update to 4.15.0 alpha
|
- Update to 4.15.0 alpha
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user