Issue deprecation warning when creating BDB databases (#1787311)
This commit is contained in:
parent
c691aaf809
commit
b47d15685e
@ -0,0 +1,28 @@
|
||||
From 5a80033676f331de2b0979fe7be9557279b6bff3 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <5a80033676f331de2b0979fe7be9557279b6bff3.1603865959.git.pmatilai@redhat.com>
|
||||
From: Panu Matilainen <pmatilai@redhat.com>
|
||||
Date: Wed, 28 Oct 2020 08:14:55 +0200
|
||||
Subject: [PATCH] Issue deprecation warning when creating BDB databases
|
||||
|
||||
---
|
||||
lib/backend/db3.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/lib/backend/db3.c b/lib/backend/db3.c
|
||||
index 68cfa6fb2..cb31676e7 100644
|
||||
--- a/lib/backend/db3.c
|
||||
+++ b/lib/backend/db3.c
|
||||
@@ -874,6 +874,10 @@ static int db3_dbiOpen(rpmdb rdb, rpmDbiTagVal rpmtag, dbiIndex * dbip, int flag
|
||||
oflags &= ~DB_RDONLY;
|
||||
dbtype = (rpmtag == RPMDBI_PACKAGES) ? DB_HASH : DB_BTREE;
|
||||
retry_open--;
|
||||
+ if (rpmtag == RPMDBI_PACKAGES) {
|
||||
+ rpmlog(RPMLOG_WARNING,
|
||||
+ "using deprecated bdb database backend");
|
||||
+ }
|
||||
} else {
|
||||
retry_open = 0;
|
||||
}
|
||||
--
|
||||
2.28.0
|
||||
|
6
rpm.spec
6
rpm.spec
@ -25,7 +25,7 @@
|
||||
|
||||
%global rpmver 4.16.0
|
||||
#global snapver rc1
|
||||
%global rel 2
|
||||
%global rel 3
|
||||
|
||||
%global srcver %{rpmver}%{?snapver:-%{snapver}}
|
||||
%global srcdir %{?snapver:testing}%{!?snapver:rpm-%(echo %{rpmver} | cut -d'.' -f1-2).x}
|
||||
@ -57,6 +57,7 @@ Patch3: rpm-4.9.90-no-man-dirs.patch
|
||||
Patch5: rpm-4.12.0-rpm2cpio-hack.patch
|
||||
# https://github.com/rpm-software-management/rpm/pull/473
|
||||
Patch6: 0001-find-debuginfo.sh-decompress-DWARF-compressed-ELF-se.patch
|
||||
Patch7: 0001-Issue-deprecation-warning-when-creating-BDB-database.patch
|
||||
|
||||
# Patches already upstream:
|
||||
|
||||
@ -552,6 +553,9 @@ fi
|
||||
%doc doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Wed Oct 28 2020 Panu Matilainen <pmatilai@redhat.com> - 4.16.0-3
|
||||
- Issue deprecation warning when creating BDB databases (#1787311)
|
||||
|
||||
* Mon Oct 05 2020 Panu Matilainen <pmatilai@redhat.com> - 4.16.0-2
|
||||
- Clean up after test-suite which leaves a read-only tree behind
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user