- fix build and sign module initialization in python3 (#1064758)
This commit is contained in:
parent
600ff28b8e
commit
af2c060789
38
rpm-4.11.2-python3-buildsign.patch
Normal file
38
rpm-4.11.2-python3-buildsign.patch
Normal file
@ -0,0 +1,38 @@
|
||||
commit 0073376965ee8d8df63c21b0da634fc315c97d0b
|
||||
Author: Panu Matilainen <pmatilai@redhat.com>
|
||||
Date: Thu Feb 13 12:54:41 2014 +0200
|
||||
|
||||
Fix build and sign module initialization in python3 (RhBug:1064758)
|
||||
|
||||
- PyInit_foo() name needs to match the module name. Doh.
|
||||
|
||||
diff --git a/python/rpmbmodule.c b/python/rpmbmodule.c
|
||||
index f6e1491..ad30570 100644
|
||||
--- a/python/rpmbmodule.c
|
||||
+++ b/python/rpmbmodule.c
|
||||
@@ -66,8 +66,8 @@ static struct PyModuleDef moduledef = {
|
||||
NULL /* m_free */
|
||||
};
|
||||
|
||||
-PyObject * PyInit__rpm(void); /* XXX eliminate gcc warning */
|
||||
-PyObject * PyInit__rpm(void)
|
||||
+PyObject * PyInit__rpmb(void); /* XXX eliminate gcc warning */
|
||||
+PyObject * PyInit__rpmb(void)
|
||||
{
|
||||
PyObject *m;
|
||||
|
||||
diff --git a/python/rpmsmodule.c b/python/rpmsmodule.c
|
||||
index 3eb2403..653f4bf 100644
|
||||
--- a/python/rpmsmodule.c
|
||||
+++ b/python/rpmsmodule.c
|
||||
@@ -66,8 +66,8 @@ static struct PyModuleDef moduledef = {
|
||||
NULL /* m_free */
|
||||
};
|
||||
|
||||
-PyObject * PyInit__rpm(void); /* XXX eliminate gcc warning */
|
||||
-PyObject * PyInit__rpm(void)
|
||||
+PyObject * PyInit__rpms(void); /* XXX eliminate gcc warning */
|
||||
+PyObject * PyInit__rpms(void)
|
||||
{
|
||||
PyObject *m;
|
||||
|
3
rpm.spec
3
rpm.spec
@ -58,6 +58,7 @@ Patch100: rpm-4.11.x-filter-soname-deps.patch
|
||||
Patch101: rpm-4.11.x-do-not-filter-ld64.patch
|
||||
Patch102: rpm-4.11.2-macro-newlines.patch
|
||||
Patch103: rpm-4.11.x-reset-fileactions.patch
|
||||
Patch104: rpm-4.11.2-python3-buildsign.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch301: rpm-4.6.0-niagara.patch
|
||||
@ -265,6 +266,7 @@ packages on a system.
|
||||
%patch101 -p1 -b .dont-filter-ld64
|
||||
%patch102 -p1 -b .macro-newlines
|
||||
%patch103 -p1 -b .reset-fileactions
|
||||
%patch104 -p1 -b .python3-buildsign
|
||||
|
||||
%patch301 -p1 -b .niagara
|
||||
%patch302 -p1 -b .geode
|
||||
@ -526,6 +528,7 @@ exit 0
|
||||
* Wed Mar 26 2014 Panu Matilainen <pmatilai@redhat.com> - 4.11.2-3
|
||||
- dont eat newlines on parametrized macro invocations (#1045723)
|
||||
- fully reset file actions between rpmtsRun() calls (#1076552)
|
||||
- fix build and sign module initialization in python3 (#1064758)
|
||||
|
||||
* Tue Feb 18 2014 Panu Matilainen <pmatilai@redhat.com> - 4.11.2-2
|
||||
- reduce the double separator spec parse error into a warning (#1065563)
|
||||
|
Loading…
Reference in New Issue
Block a user