Rebase to 4.15.1
Seems that one of the arm patches didn't get reverted upstream which requires us to carry it here. Oh, poo.
This commit is contained in:
parent
7cf9f46d11
commit
aa9697a386
1
.gitignore
vendored
1
.gitignore
vendored
@ -36,3 +36,4 @@
|
||||
/rpm-4.15.0-beta.tar.bz2
|
||||
/rpm-4.15.0-rc1.tar.bz2
|
||||
/rpm-4.15.0.tar.bz2
|
||||
/rpm-4.15.1.tar.bz2
|
||||
|
@ -1,76 +0,0 @@
|
||||
From 0fd4fc8f4e8f51eec9c971c1170620dd64262bea Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <0fd4fc8f4e8f51eec9c971c1170620dd64262bea.1571399685.git.pmatilai@redhat.com>
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Wed, 16 Oct 2019 10:48:12 +0100
|
||||
Subject: [PATCH] Remove problematic sub variants of armv8 and related
|
||||
|
||||
This is a partial revert of b1f81b837f46
|
||||
|
||||
The ARMv8 aarch32 variant specifies a number of required and optional
|
||||
components. NEON is a required component of ARMv8 devices so we don't
|
||||
need the 'n' variant that was added in ARMv7 (and never widely used due
|
||||
to problems). The 'c' crypto variant shouldn't be added. The use of
|
||||
the crypto extensions to by ARMv8 HW is many and varied and there's no
|
||||
means of dealing with it at a package/compile extention so the detection
|
||||
and use of it is done at runtime and handled via a number of different
|
||||
mechanisms whether in code or via kernel crypto modules and the use of
|
||||
libkcapi allowing the device to choose the fastest crypto option for
|
||||
the use case.
|
||||
|
||||
This is actively breaking Fedora and related distributions on newer
|
||||
generations of hardware actively stopping the actual install of an OS
|
||||
in some extreme cases. This architecture functionality needs to be
|
||||
reviewed by the architecture maintainers to ensure that active breakage
|
||||
doesn't happen.
|
||||
|
||||
Fixes RHBZ: https://bugzilla.redhat.com/show_bug.cgi?id=1691430
|
||||
|
||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
---
|
||||
rpmrc.in | 9 ---------
|
||||
1 file changed, 9 deletions(-)
|
||||
|
||||
diff --git a/rpmrc.in b/rpmrc.in
|
||||
index cc212d4ba..5bd9ba3e5 100644
|
||||
--- a/rpmrc.in
|
||||
+++ b/rpmrc.in
|
||||
@@ -82,8 +82,6 @@ optflags: armv7hl -O2 -g -march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16
|
||||
optflags: armv7hnl -O2 -g -march=armv7-a -mfloat-abi=hard -mfpu=neon
|
||||
optflags: armv8l -O2 -g -march=armv8-a
|
||||
optflags: armv8hl -O2 -g -march=armv8-a -mfloat-abi=hard -mfpu=vfpv4
|
||||
-optflags: armv8hnl -O2 -g -march=armv8-a -mfloat-abi=hard -mfpu=neon-fp-armv8
|
||||
-optflags: armv8hcnl -O2 -g -march=armv8-a -mfloat-abi=hard -mfpu=crypto-neon-fp-armv8
|
||||
|
||||
optflags: m68k -O2 -g -fomit-frame-pointer
|
||||
|
||||
@@ -224,8 +222,6 @@ arch_canon: armv7hl: armv7hl 12
|
||||
arch_canon: armv7hnl: armv7hnl 12
|
||||
arch_canon: armv8l: armv8l 12
|
||||
arch_canon: armv8hl: armv8hl 12
|
||||
-arch_canon: armv8hnl: armv8hnl 12
|
||||
-arch_canon: armv8hcnl: armv8hcnl 12
|
||||
|
||||
arch_canon: m68kmint: m68kmint 13
|
||||
arch_canon: atarist: m68kmint 13
|
||||
@@ -353,8 +349,6 @@ buildarchtranslate: armv7hl: armv7hl
|
||||
buildarchtranslate: armv7hnl: armv7hnl
|
||||
buildarchtranslate: armv8l: armv8l
|
||||
buildarchtranslate: armv8hl: armv8hnl
|
||||
-buildarchtranslate: armv8hnl: armv8hnl
|
||||
-buildarchtranslate: armv8hcnl: armv8hcnl
|
||||
|
||||
buildarchtranslate: mips: mips
|
||||
buildarchtranslate: mipsel: mipsel
|
||||
@@ -471,9 +465,6 @@ arch_compat: armv5tl: armv4tl
|
||||
arch_compat: armv4tl: armv4l
|
||||
arch_compat: armv4l: armv3l
|
||||
arch_compat: armv3l: noarch
|
||||
-arch_compat: armv8hcnl: armv8hnl
|
||||
-arch_compat: armv8hnl: armv8hl
|
||||
-arch_compat: armv8hnl: armv7hnl
|
||||
arch_compat: armv8hl: armv7hl
|
||||
arch_compat: armv7hnl: armv7hl
|
||||
arch_compat: armv7hl: armv6hl
|
||||
--
|
||||
2.21.0
|
||||
|
@ -1,43 +0,0 @@
|
||||
From 2dc1f85de96194922df41d819cf5077436710508 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Williamson <awilliam@redhat.com>
|
||||
Date: Tue, 15 Oct 2019 17:01:02 -0700
|
||||
Subject: [PATCH] Revert "Fully shutdown DBUS on systemd_inhibit cleanup
|
||||
(RhBug:1714657)"
|
||||
|
||||
This reverts commit d5f201345f6d27b6280750e5c6502f4418614fbc.
|
||||
It causes problems for dnfdaemon because it uses dbus itself,
|
||||
and the RPM python bindings; in some circumstances the plugin's
|
||||
cleanup routine is triggered and the `dbus_shutdown()` call
|
||||
causes dnfdaemon to crash the next time it tries to use dbus
|
||||
itself.
|
||||
---
|
||||
plugins/systemd_inhibit.c | 6 ------
|
||||
1 file changed, 6 deletions(-)
|
||||
|
||||
diff --git a/plugins/systemd_inhibit.c b/plugins/systemd_inhibit.c
|
||||
index 9cb722761..0ddca9cd8 100644
|
||||
--- a/plugins/systemd_inhibit.c
|
||||
+++ b/plugins/systemd_inhibit.c
|
||||
@@ -82,11 +82,6 @@ static rpmRC systemd_inhibit_init(rpmPlugin plugin, rpmts ts)
|
||||
return RPMRC_NOTFOUND;
|
||||
}
|
||||
|
||||
-static void systemd_inhibit_cleanup(rpmPlugin plugin)
|
||||
-{
|
||||
- dbus_shutdown();
|
||||
-}
|
||||
-
|
||||
static rpmRC systemd_inhibit_tsm_pre(rpmPlugin plugin, rpmts ts)
|
||||
{
|
||||
if (rpmtsFlags(ts) & (RPMTRANS_FLAG_TEST|RPMTRANS_FLAG_BUILD_PROBS))
|
||||
@@ -113,7 +108,6 @@ static rpmRC systemd_inhibit_tsm_post(rpmPlugin plugin, rpmts ts, int res)
|
||||
|
||||
struct rpmPluginHooks_s systemd_inhibit_hooks = {
|
||||
.init = systemd_inhibit_init,
|
||||
- .cleanup = systemd_inhibit_cleanup,
|
||||
.tsm_pre = systemd_inhibit_tsm_pre,
|
||||
.tsm_post = systemd_inhibit_tsm_post,
|
||||
};
|
||||
--
|
||||
2.23.0
|
||||
|
@ -1,73 +0,0 @@
|
||||
From 0351a07fe5fe3c82cc8bdc4d85de9ff4624945c6 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Wed, 16 Oct 2019 10:06:33 +0100
|
||||
Subject: [PATCH] Revert "rpmrc: Add architecture compatibility mapping between
|
||||
aarch64 and arm64"
|
||||
|
||||
This reverts commit 236d6f5a2b924266b1249a82875b595e8758c52b.
|
||||
|
||||
This change is fundamentally wrong. arm64 is a catch all that covers the
|
||||
naming but rpm uses "uname -m" to detect the actual architecture. The aarch64
|
||||
nonclamenture specifies the ISA (Instruction Set Architecture) for the 64-bit
|
||||
variant of the Arm architecture which was first supported with ARMv8.
|
||||
|
||||
Because all 64-bit variants of ARMv8 use aarch64 the arm64 would never be
|
||||
used in rpm. If it's useful in some context while using some Debian related
|
||||
tools those tools should have some translation added there. This just adds
|
||||
confusion and causes issues and duplication that haven't been necessary in
|
||||
any of the arch64 work up until now.
|
||||
|
||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
---
|
||||
rpmrc.in | 10 ++--------
|
||||
1 file changed, 2 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/rpmrc.in b/rpmrc.in
|
||||
index a3ad17a3a..cc212d4ba 100644
|
||||
--- a/rpmrc.in
|
||||
+++ b/rpmrc.in
|
||||
@@ -103,7 +103,6 @@ optflags: sh4 -O2 -g -mieee
|
||||
optflags: sh4a -O2 -g -mieee
|
||||
|
||||
optflags: aarch64 -O2 -g
|
||||
-optflags: arm64 -O2 -g
|
||||
|
||||
optflags: riscv64 -O2 -g
|
||||
|
||||
@@ -252,9 +251,7 @@ arch_canon: sh3: sh3 17
|
||||
arch_canon: sh4: sh4 17
|
||||
arch_canon: sh4a: sh4a 17
|
||||
arch_canon: xtensa: xtensa 18
|
||||
-
|
||||
-arch_canon: aarch64: aarch64 19
|
||||
-arch_canon: arm64: arm64 19
|
||||
+arch_canon: aarch64: aarch64 19
|
||||
|
||||
arch_canon: mipsr6: mipsr6 20
|
||||
arch_canon: mipsr6el: mipsr6el 20
|
||||
@@ -393,7 +390,6 @@ buildarchtranslate: sh4: sh4
|
||||
buildarchtranslate: sh4a: sh4
|
||||
|
||||
buildarchtranslate: aarch64: aarch64
|
||||
-buildarchtranslate: arm64: aarch64
|
||||
|
||||
buildarchtranslate: riscv: riscv64
|
||||
buildarchtranslate: riscv64: riscv64
|
||||
@@ -507,8 +503,7 @@ arch_compat: sh3: noarch
|
||||
arch_compat: sh4: noarch
|
||||
arch_compat: sh4a: sh4
|
||||
|
||||
-arch_compat: aarch64: arm64 noarch
|
||||
-arch_compat: arm64: aarch64 noarch
|
||||
+arch_compat: aarch64: noarch
|
||||
|
||||
arch_compat: riscv: noarch
|
||||
arch_compat: riscv64: noarch
|
||||
@@ -545,7 +540,6 @@ os_compat: Darwin: MacOSX
|
||||
buildarch_compat: ia64: noarch
|
||||
|
||||
buildarch_compat: aarch64: noarch
|
||||
-buildarch_compat: arm64: aarch64
|
||||
|
||||
buildarch_compat: riscv: noarch
|
||||
buildarch_compat: riscv64: noarch
|
12
rpm.spec
12
rpm.spec
@ -19,9 +19,9 @@
|
||||
|
||||
%define rpmhome /usr/lib/rpm
|
||||
|
||||
%global rpmver 4.15.0
|
||||
%global rpmver 4.15.1
|
||||
#global snapver rc1
|
||||
%global rel 7
|
||||
%global rel 1
|
||||
|
||||
%global srcver %{version}%{?snapver:-%{snapver}}
|
||||
%global srcdir %{?snapver:testing}%{!?snapver:%{name}-%(echo %{version} | cut -d'.' -f1-2).x}
|
||||
@ -49,9 +49,6 @@ Patch3: rpm-4.9.90-no-man-dirs.patch
|
||||
Patch5: rpm-4.12.0-rpm2cpio-hack.patch
|
||||
# https://github.com/rpm-software-management/rpm/pull/473
|
||||
Patch6: 0001-find-debuginfo.sh-decompress-DWARF-compressed-ELF-se.patch
|
||||
# systemd-inhibit plugin: don't call dbus_shutdown, it causes problems
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1750575
|
||||
Patch7: 0001-Revert-Fully-shutdown-DBUS-on-systemd_inhibit-cleanu.patch
|
||||
|
||||
# Patches already upstream:
|
||||
|
||||
@ -60,8 +57,6 @@ Patch906: rpm-4.7.1-geode-i686.patch
|
||||
# Probably to be upstreamed in slightly different form
|
||||
Patch907: rpm-4.15.x-ldflags.patch
|
||||
|
||||
Patch910: 0001-Remove-problematic-sub-variants-of-armv8-and-related.patch
|
||||
Patch911: revert-arm64.patch
|
||||
Patch912: 0001-Revert-Improve-ARM-detection.patch
|
||||
|
||||
# Partially GPL/LGPL dual-licensed and some bits with BSD
|
||||
@ -522,6 +517,9 @@ make check || (cat tests/rpmtests.log; exit 0)
|
||||
%doc doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Mon Nov 18 2019 Panu Matilainen <pmatilai@redhat.com> - 4.15.1-1
|
||||
- Rebase to 4.15.1 (https://rpm.org/wiki/Releases/4.15.1)
|
||||
|
||||
* Thu Nov 14 2019 Adam Williamson <awilliam@redhat.com> - 4.15.0-7
|
||||
- Really revert armv8 detection improvements (patch was not applied in -6)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (rpm-4.15.0.tar.bz2) = bca9cc9ef0ad53fa5cd257c29a0a0b9447956afe4024835f5416b13926bc8bbaf8aacd481e721b4a28983bc57f98b75b91750d39dd72de4876efa9d6db53a26c
|
||||
SHA512 (rpm-4.15.1.tar.bz2) = 6c66835da5a54349bcfba5cc69831c8c57568aabd53c5c2820ec78c361be5116fecd41777b097e9c49458f984a7beb054fa8ed453ff7263cad4a29a11f780767
|
||||
|
Loading…
Reference in New Issue
Block a user