- remove two offending hunks from anyarch patch causing that
RPMTAG_BUILDARCHS isn't written to SRPMs
This commit is contained in:
parent
84fa912e75
commit
aa38a18e85
@ -69,37 +69,6 @@ diff -up rpm-4.6.0/build.c.anyarch-actions-fix rpm-4.6.0/build.c
|
|||||||
/* Assemble source header from parsed components */
|
/* Assemble source header from parsed components */
|
||||||
initSourceHeader(spec);
|
initSourceHeader(spec);
|
||||||
|
|
||||||
diff -up rpm-4.6.0/build/parsePreamble.c.anyarch-actions-fix rpm-4.6.0/build/parsePreamble.c
|
|
||||||
--- rpm-4.6.0/build/parsePreamble.c.anyarch-actions-fix 2009-02-16 13:19:43.000000000 +0100
|
|
||||||
+++ rpm-4.6.0/build/parsePreamble.c 2009-02-16 13:19:43.000000000 +0100
|
|
||||||
@@ -859,8 +859,14 @@ int parsePreamble(rpmSpec spec, int init
|
|
||||||
goto exit;
|
|
||||||
}
|
|
||||||
if (spec->BANames && !spec->recursing) {
|
|
||||||
- res = PART_BUILDARCHITECTURES;
|
|
||||||
- goto exit;
|
|
||||||
+ /* Ignore BuildArch tags for anyarch actions */
|
|
||||||
+ if (spec->anyarch) {
|
|
||||||
+ spec->BANames = _free(spec->BANames);
|
|
||||||
+ spec->BACount = 0;
|
|
||||||
+ } else {
|
|
||||||
+ res = PART_BUILDARCHITECTURES;
|
|
||||||
+ goto exit;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
}
|
|
||||||
if ((rc =
|
|
||||||
@@ -895,8 +901,8 @@ int parsePreamble(rpmSpec spec, int init
|
|
||||||
addMacro(spec->macros, "buildroot", NULL, spec->buildRoot, RMIL_SPEC);
|
|
||||||
}
|
|
||||||
|
|
||||||
- /* XXX Skip valid arch check if not building binary package */
|
|
||||||
- if (!spec->anyarch && checkForValidArchitectures(spec)) {
|
|
||||||
+ /* This check is harmless as BuildArch tags are ignored in case of anyarch != 0 */
|
|
||||||
+ if (checkForValidArchitectures(spec)) {
|
|
||||||
goto exit;
|
|
||||||
}
|
|
||||||
|
|
||||||
diff -up rpm-4.6.0/build/rpmbuild.h.anyarch-actions-fix rpm-4.6.0/build/rpmbuild.h
|
diff -up rpm-4.6.0/build/rpmbuild.h.anyarch-actions-fix rpm-4.6.0/build/rpmbuild.h
|
||||||
--- rpm-4.6.0/build/rpmbuild.h.anyarch-actions-fix 2008-12-05 12:49:22.000000000 +0100
|
--- rpm-4.6.0/build/rpmbuild.h.anyarch-actions-fix 2008-12-05 12:49:22.000000000 +0100
|
||||||
+++ rpm-4.6.0/build/rpmbuild.h 2009-02-16 13:19:43.000000000 +0100
|
+++ rpm-4.6.0/build/rpmbuild.h 2009-02-16 13:19:43.000000000 +0100
|
||||||
|
6
rpm.spec
6
rpm.spec
@ -18,7 +18,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||||
@ -377,6 +377,10 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 17 2009 Jindrich Novy <jnovy@redhat.com> - 4.6.0-5
|
||||||
|
- remove two offending hunks from anyarch patch causing that
|
||||||
|
RPMTAG_BUILDARCHS isn't written to SRPMs
|
||||||
|
|
||||||
* Mon Feb 16 2009 Jindrich Novy <jnovy@redhat.com> - 4.6.0-4
|
* Mon Feb 16 2009 Jindrich Novy <jnovy@redhat.com> - 4.6.0-4
|
||||||
- inherit group tag from the main package (#470714)
|
- inherit group tag from the main package (#470714)
|
||||||
- ignore BuildArch tags for anyarch actions (#442105)
|
- ignore BuildArch tags for anyarch actions (#442105)
|
||||||
|
Loading…
Reference in New Issue
Block a user