- fix backport thinko in the exclude patch
This commit is contained in:
parent
f510e148ba
commit
a709ae3098
@ -16,7 +16,7 @@ diff --git a/build/files.c b/build/files.c
|
||||
index e0747f8..a520410 100644
|
||||
--- a/build/files.c
|
||||
+++ b/build/files.c
|
||||
@@ -1393,12 +1393,17 @@ static rpmRC addFile(FileList fl, const char * diskPath,
|
||||
@@ -1393,12 +1393,19 @@ static rpmRC addFile(FileList fl, const char * diskPath,
|
||||
statp->st_mtime = now;
|
||||
statp->st_ctime = now;
|
||||
} else {
|
||||
@ -31,6 +31,8 @@ index e0747f8..a520410 100644
|
||||
+ if (fl->currentFlags & RPMFILE_EXCLUDE) {
|
||||
+ lvl = RPMLOG_WARNING;
|
||||
+ rc = RPMRC_OK;
|
||||
+ } else {
|
||||
+ fl->processingFailed = 1;
|
||||
+ }
|
||||
+ rpmlog(lvl, msg, diskPath);
|
||||
+ return rc;
|
||||
|
5
rpm.spec
5
rpm.spec
@ -21,7 +21,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}13%{?dist}
|
||||
Release: %{?snapver:0.%{snapver}.}14%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/rpm-4.9.x/%{name}-%{srcver}.tar.bz2
|
||||
@ -469,6 +469,9 @@ exit 0
|
||||
%doc COPYING doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Wed Mar 07 2012 Panu Matilainen <pmatilai@redhat.com> - 4.9.1.2-14
|
||||
- fix backport thinko in the exclude patch
|
||||
|
||||
* Wed Mar 07 2012 Panu Matilainen <pmatilai@redhat.com> - 4.9.1.2-13
|
||||
- fix memory corruption on rpmdb size estimation (#766260)
|
||||
- fix couple of memleaks in python bindings (#782147)
|
||||
|
Loading…
Reference in New Issue
Block a user