- Fix wildcard database iterator (#1115824)
This commit is contained in:
parent
017fe597e0
commit
a3ae732fc9
24
rpm-4.11.90-mireskip.patch
Normal file
24
rpm-4.11.90-mireskip.patch
Normal file
@ -0,0 +1,24 @@
|
||||
commit 708fb8c35eff3acacf2b7d197f9ef59fb9551e15
|
||||
Author: Panu Matilainen <pmatilai@redhat.com>
|
||||
Date: Thu Jul 3 13:31:34 2014 +0300
|
||||
|
||||
Fix db iterator pattern matching (RhBug:1115824)
|
||||
|
||||
- Should've been in / Fixes a regression introduced in (pick your favorite)
|
||||
commit bc871e8fead5fd16f2c51a4a453bddf9994b80ba
|
||||
|
||||
diff --git a/lib/rpmdb.c b/lib/rpmdb.c
|
||||
index be08193..b6d3247 100644
|
||||
--- a/lib/rpmdb.c
|
||||
+++ b/lib/rpmdb.c
|
||||
@@ -1556,9 +1556,7 @@ top:
|
||||
* Skip this header if iterator selector (if any) doesn't match.
|
||||
*/
|
||||
if (mireSkip(mi)) {
|
||||
- if (mi->mi_set)
|
||||
- goto top;
|
||||
- return NULL;
|
||||
+ goto top;
|
||||
}
|
||||
headerSetInstance(mi->mi_h, mi->mi_offset);
|
||||
|
6
rpm.spec
6
rpm.spec
@ -27,7 +27,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}4%{?dist}
|
||||
Release: %{?snapver:0.%{snapver}.}5%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||
@ -51,6 +51,7 @@ Patch4: rpm-4.8.1-use-gpg2.patch
|
||||
Patch100: rpm-4.11.90-hardlink-groups.patch
|
||||
Patch101: rpm-4.11.90-expand-load-arg.patch
|
||||
Patch102: rpm-4.11.90-arm-vfp3.patch
|
||||
Patch103: rpm-4.11.90-mireskip.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch302: rpm-4.7.1-geode-i686.patch
|
||||
@ -529,6 +530,9 @@ exit 0
|
||||
%doc doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Thu Jul 03 2014 Panu Matilainen <pmatilai@redhat.com> - 4.11.90-0.git12844.5
|
||||
- Fix wildcard database iterator (#1115824)
|
||||
|
||||
* Wed Jul 02 2014 Panu Matilainen <pmatilai@redhat.com> - 4.11.90-0.git12844.4
|
||||
- Use autosetup for building rpm itself
|
||||
- Hopefully fix armv7 vfp/neon detection
|
||||
|
Loading…
Reference in New Issue
Block a user