- Do not filter ld64.* and ld64-* provides and requires (#988373)
This commit is contained in:
parent
73d396e4f0
commit
9ef65439e1
27
rpm-4.11.x-do-not-filter-ld64.patch
Normal file
27
rpm-4.11.x-do-not-filter-ld64.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From f6771b6722f0df097f9c61fc1b487f6f0ee402e8 Mon Sep 17 00:00:00 2001
|
||||
From: Florian Festi <ffesti@redhat.com>
|
||||
Date: Tue, 30 Jul 2013 16:35:21 +0200
|
||||
Subject: [PATCH] Do not filter ld64.* and ld64-* provides and requires Fixes
|
||||
#988373
|
||||
|
||||
---
|
||||
tools/elfdeps.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tools/elfdeps.c b/tools/elfdeps.c
|
||||
index 906de10..8679f89 100644
|
||||
--- a/tools/elfdeps.c
|
||||
+++ b/tools/elfdeps.c
|
||||
@@ -52,7 +52,8 @@ static int skipSoname(const char *soname)
|
||||
if (!strstr(soname, ".so"))
|
||||
return 1;
|
||||
|
||||
- if (rstreqn(soname, "ld.", 3) || rstreqn(soname, "ld-", 3))
|
||||
+ if (rstreqn(soname, "ld.", 3) || rstreqn(soname, "ld-", 3) ||
|
||||
+ rstreqn(soname, "ld64.", 3) || rstreqn(soname, "ld64-", 3))
|
||||
return 0;
|
||||
|
||||
if (rstreqn(soname, "lib", 3))
|
||||
--
|
||||
1.7.11.7
|
||||
|
7
rpm.spec
7
rpm.spec
@ -21,7 +21,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}3%{?dist}.1
|
||||
Release: %{?snapver:0.%{snapver}.}4%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||
@ -49,6 +49,7 @@ Patch6: rpm-4.9.0-armhfp-logic.patch
|
||||
# Filter soname dependencies by name
|
||||
Patch100: rpm-4.11.x-filter-soname-deps.patch
|
||||
Patch101: rpm-4.11.1-instprefix.patch
|
||||
Patch102: rpm-4.11.x-do-not-filter-ld64.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch301: rpm-4.6.0-niagara.patch
|
||||
@ -233,6 +234,7 @@ packages on a system.
|
||||
|
||||
%patch100 -p1 -b .filter-soname-deps
|
||||
%patch101 -p1 -b .instprefix
|
||||
%patch102 -p1 -b .dont-filter-ld64
|
||||
|
||||
%patch301 -p1 -b .niagara
|
||||
%patch302 -p1 -b .geode
|
||||
@ -468,6 +470,9 @@ exit 0
|
||||
%doc COPYING doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Tue Jul 30 2013 Florian Festi <ffesti@redhat.com> - 4.11.1-4
|
||||
- Do not filter out lib64.* dependencies (#988373)
|
||||
|
||||
* Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 4.11.1-3.1
|
||||
- Perl 5.18 rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user