Use mkdir -p for creating SPECPARTS dir
This commit is contained in:
parent
0b07964453
commit
9c3f8c32e7
41
0001-Use-mkdir-p-for-creating-SPECPARTS-dir.patch
Normal file
41
0001-Use-mkdir-p-for-creating-SPECPARTS-dir.patch
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
From 021a7d3aaa5458d8956babf0220a3e574a2b8e62 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Florian Festi <ffesti@redhat.com>
|
||||||
|
Date: Wed, 17 May 2023 17:23:59 +0200
|
||||||
|
Subject: [PATCH] Use mkdir -p for creating SPECPARTS dir
|
||||||
|
|
||||||
|
to not error out when invoking %setup more than once or shipping the
|
||||||
|
directory in the sources.
|
||||||
|
---
|
||||||
|
build/parsePrep.c | 2 +-
|
||||||
|
tests/rpmspec.at | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/build/parsePrep.c b/build/parsePrep.c
|
||||||
|
index f8e09a8c7..ea8faa953 100644
|
||||||
|
--- a/build/parsePrep.c
|
||||||
|
+++ b/build/parsePrep.c
|
||||||
|
@@ -274,7 +274,7 @@ static int doSetupMacro(rpmSpec spec, const char *line)
|
||||||
|
}
|
||||||
|
|
||||||
|
/* mkdir for dynamic specparts */
|
||||||
|
- buf = rpmExpand("%{__mkdir} SPECPARTS", NULL);
|
||||||
|
+ buf = rpmExpand("%{__mkdir_p} SPECPARTS", NULL);
|
||||||
|
appendBuf(spec, buf, 1);
|
||||||
|
free(buf);
|
||||||
|
|
||||||
|
diff --git a/tests/rpmspec.at b/tests/rpmspec.at
|
||||||
|
index 548b4b3cc..564479391 100644
|
||||||
|
--- a/tests/rpmspec.at
|
||||||
|
+++ b/tests/rpmspec.at
|
||||||
|
@@ -333,7 +333,7 @@ if [ $STATUS -ne 0 ]; then
|
||||||
|
exit $STATUS
|
||||||
|
fi
|
||||||
|
cd 'hello-1.0'
|
||||||
|
-/usr/bin/mkdir SPECPARTS
|
||||||
|
+/usr/bin/mkdir -p SPECPARTS
|
||||||
|
/usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
|
||||||
|
echo "Patch #0 (hello-1.0-modernize.patch):"
|
||||||
|
/usr/bin/patch --no-backup-if-mismatch -f -p1 -b --suffix .modernize --fuzz=0 < /build/SOURCES/hello-1.0-modernize.patch
|
||||||
|
--
|
||||||
|
2.40.1
|
||||||
|
|
6
rpm.spec
6
rpm.spec
@ -32,7 +32,7 @@
|
|||||||
|
|
||||||
%global rpmver 4.18.90
|
%global rpmver 4.18.90
|
||||||
#global snapver rc1
|
#global snapver rc1
|
||||||
%global baserelease 4
|
%global baserelease 5
|
||||||
%global sover 10
|
%global sover 10
|
||||||
%global oldsover 9
|
%global oldsover 9
|
||||||
|
|
||||||
@ -153,6 +153,7 @@ rpm-4.18.90-weak-user-group.patch
|
|||||||
0001-Add-pgpVerifySignature2-and-pgpPrtParams2.patch
|
0001-Add-pgpVerifySignature2-and-pgpPrtParams2.patch
|
||||||
0001-Fix-bzip2-detection.patch
|
0001-Fix-bzip2-detection.patch
|
||||||
0001-Enable-large-file-support-on-32-bit-systems-again.patch
|
0001-Enable-large-file-support-on-32-bit-systems-again.patch
|
||||||
|
0001-Use-mkdir-p-for-creating-SPECPARTS-dir.patch
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
rpm-4.7.1-geode-i686.patch
|
rpm-4.7.1-geode-i686.patch
|
||||||
@ -648,6 +649,9 @@ fi
|
|||||||
%doc %{_defaultdocdir}/rpm/API/
|
%doc %{_defaultdocdir}/rpm/API/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 17 2023 Florian Festi <ffesti@redhat.com> - 4.18.90-5
|
||||||
|
- Use mkdir -p for creating SPECPARTS dir
|
||||||
|
|
||||||
* Wed May 17 2023 Florian Festi <ffesti@redhat.com> - 4.18.90-4
|
* Wed May 17 2023 Florian Festi <ffesti@redhat.com> - 4.18.90-4
|
||||||
- Enable large file support on 32-bit systems again
|
- Enable large file support on 32-bit systems again
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user