Auto sync2gitlab import of rpm-4.14.3-26.el8.src.rpm
This commit is contained in:
parent
c98062a30b
commit
94437a1fb8
29
rpm-4.14.3-rpm2archive-Don-t-print-usage.patch
Normal file
29
rpm-4.14.3-rpm2archive-Don-t-print-usage.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From fe274b8f965582fdf97e6c46f90b9e7c124b0b8b Mon Sep 17 00:00:00 2001
|
||||||
|
From: Florian Festi <ffesti@redhat.com>
|
||||||
|
Date: Fri, 16 Dec 2022 15:50:12 +0100
|
||||||
|
Subject: [PATCH] rpm2archive: Don't print usage on no arguments
|
||||||
|
|
||||||
|
given as we want to default to reading from stdin and writing to stdout in
|
||||||
|
that case.
|
||||||
|
---
|
||||||
|
rpm2archive.c | 4 ----
|
||||||
|
1 file changed, 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/rpm2archive.c b/rpm2archive.c
|
||||||
|
index 09da8d16b..53f047f58 100644
|
||||||
|
--- a/rpm2archive.c
|
||||||
|
+++ b/rpm2archive.c
|
||||||
|
@@ -241,10 +241,6 @@ int main(int argc, const char *argv[])
|
||||||
|
exit(EXIT_FAILURE);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
- if (argc < 2 || poptGetNextOpt(optCon) == 0) {
|
||||||
|
- poptPrintUsage(optCon, stderr, 0);
|
||||||
|
- exit(EXIT_FAILURE);
|
||||||
|
- }
|
||||||
|
|
||||||
|
rpmts ts = rpmtsCreate();
|
||||||
|
rpmVSFlags vsflags = 0;
|
||||||
|
--
|
||||||
|
2.38.1
|
||||||
|
|
36
rpm-4.14.3-rpm2archive-parse-popt-options.patch
Normal file
36
rpm-4.14.3-rpm2archive-parse-popt-options.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
From 8f416b275a365426b07c75adfc017e0b18a85450 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Florian Festi <ffesti@redhat.com>
|
||||||
|
Date: Fri, 16 Dec 2022 15:45:20 +0100
|
||||||
|
Subject: [PATCH] rpm2archive: Properly parse popt options
|
||||||
|
|
||||||
|
and issue an error message for unknown options. Before unknown options
|
||||||
|
could mess up the argument parsing leading to reading and writing from
|
||||||
|
stdin/stdout.
|
||||||
|
|
||||||
|
Thanks to Eva Mrakova and the Red Hat QE team for spotting this!
|
||||||
|
---
|
||||||
|
rpm2archive.c | 8 ++++++++
|
||||||
|
1 file changed, 8 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/rpm2archive.c b/rpm2archive.c
|
||||||
|
index de1a17d2b..09da8d16b 100644
|
||||||
|
--- a/rpm2archive.c
|
||||||
|
+++ b/rpm2archive.c
|
||||||
|
@@ -233,6 +233,14 @@ int main(int argc, const char *argv[])
|
||||||
|
|
||||||
|
optCon = poptGetContext(NULL, argc, argv, optionsTable, 0);
|
||||||
|
poptSetOtherOptionHelp(optCon, "[OPTIONS]* <FILES>");
|
||||||
|
+ while ((rc = poptGetNextOpt(optCon)) != -1) {
|
||||||
|
+ if (rc < 0) {
|
||||||
|
+ fprintf(stderr, "%s: %s\n",
|
||||||
|
+ poptBadOption(optCon, POPT_BADOPTION_NOALIAS),
|
||||||
|
+ poptStrerror(rc));
|
||||||
|
+ exit(EXIT_FAILURE);
|
||||||
|
+ }
|
||||||
|
+ }
|
||||||
|
if (argc < 2 || poptGetNextOpt(optCon) == 0) {
|
||||||
|
poptPrintUsage(optCon, stderr, 0);
|
||||||
|
exit(EXIT_FAILURE);
|
||||||
|
--
|
||||||
|
2.38.1
|
||||||
|
|
6
rpm.spec
6
rpm.spec
@ -32,7 +32,7 @@
|
|||||||
|
|
||||||
%global rpmver 4.14.3
|
%global rpmver 4.14.3
|
||||||
#global snapver rc2
|
#global snapver rc2
|
||||||
%global rel 25
|
%global rel 26
|
||||||
|
|
||||||
%global srcver %{version}%{?snapver:-%{snapver}}
|
%global srcver %{version}%{?snapver:-%{snapver}}
|
||||||
%global srcdir %{?snapver:testing}%{!?snapver:%{name}-%(echo %{version} | cut -d'.' -f1-2).x}
|
%global srcdir %{?snapver:testing}%{!?snapver:%{name}-%(echo %{version} | cut -d'.' -f1-2).x}
|
||||||
@ -117,6 +117,8 @@ Patch163: rpm-4.14.3-skip-recorded-symlinks-in-setperms.patch
|
|||||||
Patch164: rpm-4.14.3-fapolicyd-make-write-nonblocking.patch
|
Patch164: rpm-4.14.3-fapolicyd-make-write-nonblocking.patch
|
||||||
Patch165: rpm-4.16.1.3-rpm2archive-error-handling.patch
|
Patch165: rpm-4.16.1.3-rpm2archive-error-handling.patch
|
||||||
Patch166: rpm-4.14.3-rpm2archive-nocompression.patch
|
Patch166: rpm-4.14.3-rpm2archive-nocompression.patch
|
||||||
|
Patch167: rpm-4.14.3-rpm2archive-parse-popt-options.patch
|
||||||
|
Patch168: rpm-4.14.3-rpm2archive-Don-t-print-usage.patch
|
||||||
|
|
||||||
# Python 3 string API sanity
|
# Python 3 string API sanity
|
||||||
Patch500: 0001-In-Python-3-return-all-our-string-data-as-surrogate-.patch
|
Patch500: 0001-In-Python-3-return-all-our-string-data-as-surrogate-.patch
|
||||||
@ -697,7 +699,7 @@ make check || cat tests/rpmtests.log
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Mon Dec 05 2022 Florian Festi <ffesti@redhat.com> - 4.14.4-25
|
* Mon Dec 19 2022 Florian Festi <ffesti@redhat.com> - 4.14.4-26
|
||||||
- Add --nocompression to rpm2archive (#2129345)
|
- Add --nocompression to rpm2archive (#2129345)
|
||||||
|
|
||||||
* Tue Sep 13 2022 Michal Domonkos <mdomonko@redhat.com> - 4.14.3-24
|
* Tue Sep 13 2022 Michal Domonkos <mdomonko@redhat.com> - 4.14.3-24
|
||||||
|
Loading…
Reference in New Issue
Block a user