fix excluded size
This commit is contained in:
parent
d8085d2c56
commit
93cf818246
11
rpm-4.4.2-excluded-size.patch
Normal file
11
rpm-4.4.2-excluded-size.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- rpm-4.4.2/build/files.c.excludedsize 2005-11-29 16:21:12.000000000 -0500
|
||||||
|
+++ rpm-4.4.2/build/files.c 2005-11-29 16:21:21.000000000 -0500
|
||||||
|
@@ -1678,7 +1678,7 @@
|
||||||
|
} else
|
||||||
|
i = fl->fileListRecsUsed;
|
||||||
|
|
||||||
|
- if (S_ISREG(flp->fl_mode) && i >= fl->fileListRecsUsed)
|
||||||
|
+ if (!(flp->flags & RPMFILE_EXCLUDE) && S_ISREG(flp->fl_mode) && i >= fl->fileListRecsUsed)
|
||||||
|
fl->totalFileSize += flp->fl_size;
|
||||||
|
}
|
||||||
|
|
7
rpm.spec
7
rpm.spec
@ -20,7 +20,7 @@ Name: rpm
|
|||||||
%define version 4.4.2
|
%define version 4.4.2
|
||||||
Version: %{version}
|
Version: %{version}
|
||||||
%{expand: %%define rpm_version %{version}}
|
%{expand: %%define rpm_version %{version}}
|
||||||
Release: 9
|
Release: 10
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Source: ftp://wraptastic.org/pub/rpm-4.4.x/rpm-%{rpm_version}.tar.gz
|
Source: ftp://wraptastic.org/pub/rpm-4.4.x/rpm-%{rpm_version}.tar.gz
|
||||||
Patch0: rpm-4.4.1-hkp-disable.patch
|
Patch0: rpm-4.4.1-hkp-disable.patch
|
||||||
@ -36,6 +36,7 @@ Patch9: rpm-4.4.2-contextverify.patch
|
|||||||
Patch10: rpm-4.4.2-popt-charset.patch
|
Patch10: rpm-4.4.2-popt-charset.patch
|
||||||
Patch11: rpm-4.4.2-ghost-conflicts.patch
|
Patch11: rpm-4.4.2-ghost-conflicts.patch
|
||||||
Patch12: rpm-4.4.2-exclude.patch
|
Patch12: rpm-4.4.2-exclude.patch
|
||||||
|
Patch13: rpm-4.4.2-excluded-size.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
Conflicts: patch < 2.5
|
Conflicts: patch < 2.5
|
||||||
%ifos linux
|
%ifos linux
|
||||||
@ -160,6 +161,7 @@ shell-like rules.
|
|||||||
%patch10 -p1 -b .charset
|
%patch10 -p1 -b .charset
|
||||||
%patch11 -p1 -b .ghostconflicts
|
%patch11 -p1 -b .ghostconflicts
|
||||||
%patch12 -p1 -b .exclude
|
%patch12 -p1 -b .exclude
|
||||||
|
%patch13 -p1 -b .excludedsize
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -552,6 +554,9 @@ exit 0
|
|||||||
%{__includedir}/popt.h
|
%{__includedir}/popt.h
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 29 2005 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-10
|
||||||
|
- Ignore excluded size (#89661)
|
||||||
|
|
||||||
* Tue Nov 29 2005 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-9
|
* Tue Nov 29 2005 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-9
|
||||||
- Don't skipDirs on erasures (#140055)
|
- Don't skipDirs on erasures (#140055)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user