Skip file classification dependency added when autoReq off
This commit is contained in:
parent
ab372cb72e
commit
8793c7c3c8
56
rpm-4.4.2-rpmfc-skip.patch
Normal file
56
rpm-4.4.2-rpmfc-skip.patch
Normal file
@ -0,0 +1,56 @@
|
||||
--- rpm-4.4.2/build/rpmfc.c.skip 2006-05-04 14:38:26.000000000 -0400
|
||||
+++ rpm-4.4.2/build/rpmfc.c 2006-05-04 14:45:10.000000000 -0400
|
||||
@@ -722,11 +722,13 @@
|
||||
#endif
|
||||
t++;
|
||||
/* Add to package dependencies. */
|
||||
- ds = rpmdsSingle(RPMTAG_REQUIRENAME,
|
||||
+ if (!fc->skipReq) {
|
||||
+ ds = rpmdsSingle(RPMTAG_REQUIRENAME,
|
||||
buf, "", RPMSENSE_FIND_REQUIRES);
|
||||
- rpmdsMerge(&fc->requires, ds);
|
||||
- rpmfcSaveArg(&fc->ddict, rpmfcFileDep(t, fc->ix, ds));
|
||||
- ds = rpmdsFree(ds);
|
||||
+ rpmdsMerge(&fc->requires, ds);
|
||||
+ rpmfcSaveArg(&fc->ddict, rpmfcFileDep(t, fc->ix, ds));
|
||||
+ ds = rpmdsFree(ds);
|
||||
+ }
|
||||
break;
|
||||
}
|
||||
}
|
||||
@@ -1187,6 +1189,7 @@
|
||||
int ix;
|
||||
int i;
|
||||
int xx;
|
||||
+ int skipping;
|
||||
|
||||
/* Generate package and per-file dependencies. */
|
||||
for (fc->ix = 0; fc->fn[fc->ix] != NULL; fc->ix++) {
|
||||
@@ -1234,15 +1237,18 @@
|
||||
Flags = strtol(se, NULL, 16);
|
||||
|
||||
dix = -1;
|
||||
+ skipping = 0;
|
||||
switch (deptype) {
|
||||
default:
|
||||
/*@switchbreak@*/ break;
|
||||
case 'P':
|
||||
+ skipping = fc->skipProv;
|
||||
ds = rpmdsSingle(RPMTAG_PROVIDENAME, N, EVR, Flags);
|
||||
dix = rpmdsFind(fc->provides, ds);
|
||||
ds = rpmdsFree(ds);
|
||||
/*@switchbreak@*/ break;
|
||||
case 'R':
|
||||
+ skipping = fc->skipReq;
|
||||
ds = rpmdsSingle(RPMTAG_REQUIRENAME, N, EVR, Flags);
|
||||
dix = rpmdsFind(fc->requires, ds);
|
||||
ds = rpmdsFree(ds);
|
||||
@@ -1264,7 +1270,7 @@
|
||||
previx = ix;
|
||||
xx = argiAdd(&fc->fddictx, ix, argiCount(fc->ddictx)-1);
|
||||
}
|
||||
- if (fc->fddictn && fc->fddictn->vals)
|
||||
+ if (fc->fddictn && fc->fddictn->vals && !skipping)
|
||||
fc->fddictn->vals[ix]++;
|
||||
}
|
||||
/*@=boundswrite@*/
|
9
rpm.spec
9
rpm.spec
@ -20,7 +20,7 @@ Name: rpm
|
||||
%define version 4.4.2
|
||||
Version: %{version}
|
||||
%{expand: %%define rpm_version %{version}}
|
||||
Release: 23
|
||||
Release: 24
|
||||
Group: System Environment/Base
|
||||
Source: ftp://wraptastic.org/pub/rpm-4.4.x/rpm-%{rpm_version}.tar.gz
|
||||
Source1: mono-find-provides
|
||||
@ -51,7 +51,7 @@ Patch22: rpm-4.4.2-vercmp.patch
|
||||
Patch23: rpm-4.4.2-doxy.patch
|
||||
Patch24: rpm-4.4.2-trust.patch
|
||||
Patch25: rpm-4.4.2-devel-autodep.patch
|
||||
Patch26: rpm-4.4.2-teCount-assert.patch
|
||||
Patch26: rpm-4.4.2-rpmfc-skip.patch
|
||||
License: GPL
|
||||
Conflicts: patch < 2.5
|
||||
%ifos linux
|
||||
@ -188,7 +188,7 @@ shell-like rules.
|
||||
%patch23 -p1 -b .doxy
|
||||
%patch24 -p1 -b .trust
|
||||
%patch25 -p1 -b .develdeps
|
||||
%patch26 -p1 -b .assertte
|
||||
%patch26 -p1 -b .fcskip
|
||||
|
||||
%build
|
||||
|
||||
@ -582,6 +582,9 @@ exit 0
|
||||
%{__includedir}/popt.h
|
||||
|
||||
%changelog
|
||||
* Thu May 04 2006 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-24
|
||||
- File classification with autoReq off (#190488)
|
||||
|
||||
* Thu May 4 2006 Jeremy Katz <katzj@redhat.com> - 4.4.2-23
|
||||
- make rpm-libs requires on base package stronger
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user