- Fix Python import directive for more strict Python3 search rules
- Resolves: #1236493
This commit is contained in:
parent
7aff53e3ab
commit
8341ec3f15
29
rpm-4.12.0-Fix-Python3-import.patch
Normal file
29
rpm-4.12.0-Fix-Python3-import.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From 97989236c0f39ccbc7f2c1d52cc30f167fd827fe Mon Sep 17 00:00:00 2001
|
||||||
|
From: Florian Festi <ffesti@redhat.com>
|
||||||
|
Date: Mon, 26 Jan 2015 14:22:34 +0100
|
||||||
|
Subject: [PATCH] Fix Python import directive for more strict Python3 search
|
||||||
|
rules
|
||||||
|
|
||||||
|
Fixes http://rpm.org/ticket/885
|
||||||
|
---
|
||||||
|
python/rpm/transaction.py | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/python/rpm/transaction.py b/python/rpm/transaction.py
|
||||||
|
index db7ca67..91a6cc1 100644
|
||||||
|
--- a/python/rpm/transaction.py
|
||||||
|
+++ b/python/rpm/transaction.py
|
||||||
|
@@ -37,8 +37,8 @@ class TransactionSet(TransactionSetCore):
|
||||||
|
return self._wrapSetGet('_probFilter', ignoreSet)
|
||||||
|
|
||||||
|
def parseSpec(self, specfile):
|
||||||
|
- import _rpmb
|
||||||
|
- return _rpmb.spec(specfile)
|
||||||
|
+ import rpm._rpmb
|
||||||
|
+ return rpm._rpmb.spec(specfile)
|
||||||
|
|
||||||
|
def getKeys(self):
|
||||||
|
keys = []
|
||||||
|
--
|
||||||
|
2.1.0
|
||||||
|
|
6
rpm.spec
6
rpm.spec
@ -27,7 +27,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: %{?snapver:0.%{snapver}.}16%{?dist}
|
Release: %{?snapver:0.%{snapver}.}17%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/rpm-4.12.x/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/rpm-4.12.x/%{name}-%{srcver}.tar.bz2
|
||||||
@ -68,6 +68,7 @@ Patch106: rpm-4.12.0-golang-debuginfo.patch
|
|||||||
Patch107: rpm-4.12.0-whatrecommends.patch
|
Patch107: rpm-4.12.0-whatrecommends.patch
|
||||||
Patch108: rpm-4.12.0-gpg-passphrase1.patch
|
Patch108: rpm-4.12.0-gpg-passphrase1.patch
|
||||||
Patch109: rpm-4.12.0-gpg-passphrase2.patch
|
Patch109: rpm-4.12.0-gpg-passphrase2.patch
|
||||||
|
Patch110: rpm-4.12.0-Fix-Python3-import.patch
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch302: rpm-4.7.1-geode-i686.patch
|
Patch302: rpm-4.7.1-geode-i686.patch
|
||||||
@ -552,6 +553,9 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 29 2015 Florian Festi <ffesti@rpm.org> - 4.12.0.1-17
|
||||||
|
- Fix Python import directive for more strict Python3 search rules (#1236493)
|
||||||
|
|
||||||
* Fri Jun 19 2015 Lubos Kardos <lkardos@redhat.com> 4.12.0.1-16
|
* Fri Jun 19 2015 Lubos Kardos <lkardos@redhat.com> 4.12.0.1-16
|
||||||
- Allow gpg to get passphrase by itself (#1228234)
|
- Allow gpg to get passphrase by itself (#1228234)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user