Rebase to rpm 4.14.1
This commit is contained in:
parent
193c8871cc
commit
8219d71cbb
1
.gitignore
vendored
1
.gitignore
vendored
@ -27,3 +27,4 @@
|
||||
/rpm-4.14.0-rc1.tar.bz2
|
||||
/rpm-4.14.0-rc2.tar.bz2
|
||||
/rpm-4.14.0.tar.bz2
|
||||
/rpm-4.14.1.tar.bz2
|
||||
|
@ -1,70 +0,0 @@
|
||||
From 92b718bb0e98ecaea6d4229eab9ef3bc0220d9c2 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <92b718bb0e98ecaea6d4229eab9ef3bc0220d9c2.1507815046.git.pmatilai@redhat.com>
|
||||
From: Panu Matilainen <pmatilai@redhat.com>
|
||||
Date: Thu, 12 Oct 2017 15:51:26 +0300
|
||||
Subject: [PATCH] Don't assume per-user groups in test-suite
|
||||
|
||||
The tests from commits f2d3be2a8741234faaa96f5fd05fdfdc75779a79 and
|
||||
c815822c8bdb138066ff58c624ae83e3a12ebfa9 assume per-user groups,
|
||||
but this is not a generally valid assumption and causes unnecessary
|
||||
bogus failures in the test-suite in some setups (eg mock)
|
||||
---
|
||||
tests/data/SPECS/replacetest.spec | 3 ++-
|
||||
tests/rpmreplace.at | 2 ++
|
||||
tests/rpmverify.at | 1 +
|
||||
3 files changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tests/data/SPECS/replacetest.spec b/tests/data/SPECS/replacetest.spec
|
||||
index c764adc27..54974567b 100644
|
||||
--- a/tests/data/SPECS/replacetest.spec
|
||||
+++ b/tests/data/SPECS/replacetest.spec
|
||||
@@ -1,6 +1,7 @@
|
||||
%{!?filetype: %global filetype file}
|
||||
%{?fixit: %global havepretrans 1}
|
||||
%{!?user: %global user root}
|
||||
+%{!?grp: %global grp root}
|
||||
|
||||
Name: replacetest%{?sub:-%{sub}}
|
||||
Version: %{ver}
|
||||
@@ -44,5 +45,5 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%files
|
||||
-%defattr(-,%{user},%{user},-)
|
||||
+%defattr(-,%{user},%{grp},-)
|
||||
/opt/*
|
||||
diff --git a/tests/rpmreplace.at b/tests/rpmreplace.at
|
||||
index 11e6221d7..6f0444bb7 100644
|
||||
--- a/tests/rpmreplace.at
|
||||
+++ b/tests/rpmreplace.at
|
||||
@@ -403,6 +403,7 @@ runroot rpmbuild --quiet -bb \
|
||||
--define "filetype datadir" \
|
||||
--define "filedata README1" \
|
||||
--define "user $(id -u -n)" \
|
||||
+ --define "grp $(id -g -n)" \
|
||||
/data/SPECS/replacetest.spec
|
||||
|
||||
runroot rpmbuild --quiet -bb \
|
||||
@@ -410,6 +411,7 @@ runroot rpmbuild --quiet -bb \
|
||||
--define "filetype datadir" \
|
||||
--define "filedata README2" \
|
||||
--define "user $(id -u -n)" \
|
||||
+ --define "grp $(id -g -n)" \
|
||||
/data/SPECS/replacetest.spec
|
||||
|
||||
mkdir "${RPMTEST}"/opt/f00f
|
||||
diff --git a/tests/rpmverify.at b/tests/rpmverify.at
|
||||
index c5530de69..78f50fd33 100644
|
||||
--- a/tests/rpmverify.at
|
||||
+++ b/tests/rpmverify.at
|
||||
@@ -78,6 +78,7 @@ runroot rpmbuild --quiet -bb \
|
||||
--define "filetype datadir" \
|
||||
--define "filedata README1" \
|
||||
--define "user $(id -u -n)" \
|
||||
+ --define "grp $(id -g -n)" \
|
||||
/data/SPECS/replacetest.spec
|
||||
|
||||
runroot rpm -U /build/RPMS/noarch/replacetest-1.0-1.noarch.rpm
|
||||
--
|
||||
2.13.6
|
||||
|
8
rpm.spec
8
rpm.spec
@ -21,9 +21,9 @@
|
||||
|
||||
%define rpmhome /usr/lib/rpm
|
||||
|
||||
%global rpmver 4.14.0
|
||||
%global rpmver 4.14.1
|
||||
#global snapver rc2
|
||||
%global rel 5
|
||||
%global rel 1
|
||||
|
||||
%global srcver %{version}%{?snapver:-%{snapver}}
|
||||
%global srcdir %{?snapver:testing}%{!?snapver:%{name}-%(echo %{version} | cut -d'.' -f1-2).x}
|
||||
@ -58,7 +58,6 @@ Patch4: rpm-4.8.1-use-gpg2.patch
|
||||
Patch5: rpm-4.12.0-rpm2cpio-hack.patch
|
||||
|
||||
# Patches already upstream:
|
||||
Patch100: 0001-Don-t-assume-per-user-groups-in-test-suite.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch906: rpm-4.7.1-geode-i686.patch
|
||||
@ -575,6 +574,9 @@ make check || cat tests/rpmtests.log
|
||||
%doc doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Tue Jan 16 2018 Panu Matilainen <pmatilai@redhat.com> - 4.14.1-1
|
||||
- Rebase to rpm 4.14.1 (http://rpm.org/wiki/Releases/4.14.1)
|
||||
|
||||
* Tue Nov 07 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.14.0-5
|
||||
- Fix typo in Obsoletes
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (rpm-4.14.0.tar.bz2) = df6c063b4c30c3652cdf09e709b96f89b61c89aa4726b25f1132a51da3da67e33598d8acaf0134fad27ad4b38c619b9e1d77571697f2efa227fcfcac56651c82
|
||||
SHA512 (rpm-4.14.1.tar.bz2) = 29e95eaaf40a6ddf7f23446ea6cb8a1dcd12a45d4965595a705cb9130890d772a40ecfa475b189865da51248b3d2414e4f4b1a40cbfd7ca538c482d87c50a218
|
||||
|
Loading…
Reference in New Issue
Block a user