Don't warn about missing user/group on skipped files
Resolves: RHEL-18037
This commit is contained in:
parent
056ea9da7e
commit
8126eec7e0
@ -0,0 +1,30 @@
|
||||
From 6c66abd34cccbb5b3c063f8f613e0c2faffc415f Mon Sep 17 00:00:00 2001
|
||||
From: Panu Matilainen <pmatilai@redhat.com>
|
||||
Date: Wed, 13 Dec 2023 11:57:50 +0200
|
||||
Subject: [PATCH] Don't warn about missing user/group on skipped files
|
||||
|
||||
There's no reason to complain about missing user/group for entities
|
||||
we don't create at all. It's cosmetical only, but "regressed" in the
|
||||
4.17 fsm robustness rewrite.
|
||||
|
||||
Reported in https://issues.redhat.com/browse/RHEL-18037
|
||||
---
|
||||
lib/fsm.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/fsm.c b/lib/fsm.c
|
||||
index 2189bd84c..a54e43bae 100644
|
||||
--- a/lib/fsm.c
|
||||
+++ b/lib/fsm.c
|
||||
@@ -903,7 +903,7 @@ int rpmPackageFilesInstall(rpmts ts, rpmte te, rpmfiles files,
|
||||
fp->fpath = fsmFsPath(fi, fp->suffix);
|
||||
|
||||
/* Remap file perms, owner, and group. */
|
||||
- rc = rpmfiStat(fi, 1, &fp->sb);
|
||||
+ rc = rpmfiStat(fi, (fp->skip == 0), &fp->sb);
|
||||
|
||||
/* Hardlinks are tricky and handled elsewhere for install */
|
||||
fp->setmeta = (fp->skip == 0) &&
|
||||
--
|
||||
2.43.0
|
||||
|
2
rpm.spec
2
rpm.spec
@ -103,6 +103,7 @@ Patch130: 0001-Use-file-state-machine-from-rpm-4.19.patch
|
||||
Patch131: 0001-Emit-full-paths-for-file-disposition-diagnostics-on-.patch
|
||||
Patch132: 0001-Fix-wrong-return-code-on-O_DIRECTORY-open-of-invalid.patch
|
||||
Patch133: 0001-Print-full-path-if-file-removal-fails.patch
|
||||
Patch134: 0001-Don-t-warn-about-missing-user-group-on-skipped-files.patch
|
||||
|
||||
Patch140: 0001-Fix-short-circuiting-of-version-strings-in-expressio.patch
|
||||
Patch141: 0001-Fix-a-copy-paste-help-description-of-whatconflicts-R.patch
|
||||
@ -658,6 +659,7 @@ fi
|
||||
%changelog
|
||||
* Wed Dec 13 2023 Florian Festi <ffesti@redhat.com> - 4.16.1.3-29
|
||||
- Actually add --verifydb to the man page (RHEL-14591)
|
||||
- Don't warn about missing user/group on skipped files (RHEL-18037)
|
||||
|
||||
* Mon Dec 11 2023 Florian Festi <ffesti@redhat.com> - 4.16.1.3-28
|
||||
- Fix warning if file removal fails
|
||||
|
Loading…
Reference in New Issue
Block a user