- Continue ordering loop elimination as long as progress is made (#437041)
This commit is contained in:
parent
3db3e72457
commit
7f2427d0a1
25
rpm-4.4.2.3-no-order-rescan-limit.patch
Normal file
25
rpm-4.4.2.3-no-order-rescan-limit.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
diff -up rpm-4.4.2.3-rc1/lib/depends.c.no-limit rpm-4.4.2.3-rc1/lib/depends.c
|
||||||
|
--- rpm-4.4.2.3-rc1/lib/depends.c.no-limit 2008-03-12 08:40:08.000000000 +0200
|
||||||
|
+++ rpm-4.4.2.3-rc1/lib/depends.c 2008-03-12 08:58:15.000000000 +0200
|
||||||
|
@@ -1229,7 +1229,7 @@ int rpmtsOrder(rpmts ts)
|
||||||
|
int numOrderList;
|
||||||
|
int npeer = 128; /* XXX more than deep enough for now. */
|
||||||
|
int * peer = memset(alloca(npeer*sizeof(*peer)), 0, (npeer*sizeof(*peer)));
|
||||||
|
- int nrescans = 10;
|
||||||
|
+ int nrescans = 0;
|
||||||
|
int _printed = 0;
|
||||||
|
char deptypechar;
|
||||||
|
size_t tsbytes;
|
||||||
|
@@ -1563,8 +1563,10 @@ rescan:
|
||||||
|
|
||||||
|
/* If a relation was eliminated, then continue sorting. */
|
||||||
|
/* XXX TODO: add control bit. */
|
||||||
|
- if (nzaps && nrescans-- > 0) {
|
||||||
|
- rpmMessage(RPMMESS_DEBUG, _("========== continuing tsort ...\n"));
|
||||||
|
+ if (nzaps > 0) {
|
||||||
|
+ rpmMessage(RPMMESS_DEBUG,
|
||||||
|
+ _("========== continuing tsort ... (rescan %d)\n"),
|
||||||
|
+ ++nrescans);
|
||||||
|
goto rescan;
|
||||||
|
}
|
||||||
|
|
7
rpm.spec
7
rpm.spec
@ -6,7 +6,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: 4.4.2.3
|
Version: 4.4.2.3
|
||||||
Release: 0.2.rc1
|
Release: 0.3.rc1
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source: http://rpm.org/releases/rpm-4.4.x/%{name}-%{version}-rc1.tar.gz
|
Source: http://rpm.org/releases/rpm-4.4.x/%{name}-%{version}-rc1.tar.gz
|
||||||
@ -21,6 +21,7 @@ Patch8: rpm-4.4.2.3-nss.patch
|
|||||||
Patch9: rpm-4.4.2.2-autofoo.patch
|
Patch9: rpm-4.4.2.2-autofoo.patch
|
||||||
Patch10: rpm-4.4.2.2-pkgconfig-path.patch
|
Patch10: rpm-4.4.2.2-pkgconfig-path.patch
|
||||||
Patch11: rpm-4.4.2.3-queryformat-arch.patch
|
Patch11: rpm-4.4.2.3-queryformat-arch.patch
|
||||||
|
Patch12: rpm-4.4.2.3-no-order-rescan-limit.patch
|
||||||
|
|
||||||
Patch50: rpm-4.4.2.3-geode-instplat.patch
|
Patch50: rpm-4.4.2.3-geode-instplat.patch
|
||||||
|
|
||||||
@ -145,6 +146,7 @@ that will manipulate RPM packages and databases.
|
|||||||
%patch9 -p1 -b .autofoo
|
%patch9 -p1 -b .autofoo
|
||||||
%patch10 -p1 -b .pkgconfig-path
|
%patch10 -p1 -b .pkgconfig-path
|
||||||
%patch11 -p1 -b .qfmt-arch
|
%patch11 -p1 -b .qfmt-arch
|
||||||
|
%patch12 -p1 -b .no-order-limit
|
||||||
|
|
||||||
%patch50 -p1 -b .geode-instplat
|
%patch50 -p1 -b .geode-instplat
|
||||||
|
|
||||||
@ -399,6 +401,9 @@ exit 0
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 12 2008 Panu Matilainen <pmatilai@redhat.com> 4.4.2.3-0.3.rc1
|
||||||
|
- Continue ordering loop elimination as long as progress is made (#437041)
|
||||||
|
|
||||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.4.2.3-0.2.rc1
|
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.4.2.3-0.2.rc1
|
||||||
- Autorebuild for GCC 4.3
|
- Autorebuild for GCC 4.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user