Rebase to rpm 4.18.1 (https://rpm.org/wiki/Releases/4.18.1)
This commit is contained in:
parent
1cb2cea4c3
commit
7bfe20af40
1
.gitignore
vendored
1
.gitignore
vendored
@ -55,3 +55,4 @@
|
||||
/rpm-4.18.0-beta1.tar.bz2
|
||||
/rpm-4.18.0-rc1.tar.bz2
|
||||
/rpm-4.18.0.tar.bz2
|
||||
/rpm-4.18.1.tar.bz2
|
||||
|
@ -1,15 +0,0 @@
|
||||
diff -up rpm-4.9.1.1/macros.in.jx rpm-4.9.1.1/macros.in
|
||||
--- rpm-4.9.1.1/macros.in.jx 2011-08-03 16:19:05.000000000 -0400
|
||||
+++ rpm-4.9.1.1/macros.in 2011-08-08 09:41:52.981064316 -0400
|
||||
@@ -674,9 +674,10 @@ print (t)\
|
||||
RPM_BUILD_DIR=\"%{u2p:%{_builddir}}\"\
|
||||
RPM_OPT_FLAGS=\"%{optflags}\"\
|
||||
+ RPM_LD_FLAGS=\"%{?build_ldflags}\"\
|
||||
RPM_ARCH=\"%{_arch}\"\
|
||||
RPM_OS=\"%{_os}\"\
|
||||
RPM_BUILD_NCPUS=\"%{_smp_build_ncpus}\"\
|
||||
- export RPM_SOURCE_DIR RPM_BUILD_DIR RPM_OPT_FLAGS RPM_ARCH RPM_OS RPM_BUILD_NCPUS\
|
||||
+ export RPM_SOURCE_DIR RPM_BUILD_DIR RPM_OPT_FLAGS RPM_LD_FLAGS RPM_ARCH RPM_OS RPM_BUILD_NCPUS RPM_LD_FLAGS\
|
||||
RPM_DOC_DIR=\"%{_docdir}\"\
|
||||
export RPM_DOC_DIR\
|
||||
RPM_PACKAGE_NAME=\"%{NAME}\"\
|
@ -1,12 +0,0 @@
|
||||
diff -up rpm-4.11.1-rc1/macros.in.siteconfig rpm-4.11.1-rc1/macros.in
|
||||
--- rpm-4.11.1-rc1/macros.in.siteconfig 2013-06-07 13:19:21.000000000 +0300
|
||||
+++ rpm-4.11.1-rc1/macros.in 2013-06-11 15:06:59.525747503 +0300
|
||||
@@ -647,6 +647,8 @@ package or when debugging this package.\
|
||||
export CLASSPATH}\
|
||||
PKG_CONFIG_PATH=\"${PKG_CONFIG_PATH}:%{_libdir}/pkgconfig:%{_datadir}/pkgconfig\"\
|
||||
export PKG_CONFIG_PATH\
|
||||
+ CONFIG_SITE=${CONFIG_SITE:-NONE}\
|
||||
+ export CONFIG_SITE\
|
||||
\
|
||||
%[%{verbose}?"set -x":""]\
|
||||
umask 022\
|
16
rpm-4.18.x-ldflags.patch
Normal file
16
rpm-4.18.x-ldflags.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -up rpm-4.18.1/macros.in.orig rpm-4.18.1/macros.in
|
||||
--- rpm-4.18.1/macros.in.orig 2023-03-15 13:57:06.385361527 +0100
|
||||
+++ rpm-4.18.1/macros.in 2023-03-15 13:58:09.613971713 +0100
|
||||
@@ -727,10 +727,11 @@ package or when debugging this package.\
|
||||
RPM_SOURCE_DIR=\"%{_sourcedir}\"\
|
||||
RPM_BUILD_DIR=\"%{_builddir}\"\
|
||||
RPM_OPT_FLAGS=\"%{optflags}\"\
|
||||
+ RPM_LD_FLAGS=\"%{?build_ldflags}\"\
|
||||
RPM_ARCH=\"%{_arch}\"\
|
||||
RPM_OS=\"%{_os}\"\
|
||||
RPM_BUILD_NCPUS=\"%{_smp_build_ncpus}\"\
|
||||
- export RPM_SOURCE_DIR RPM_BUILD_DIR RPM_OPT_FLAGS RPM_ARCH RPM_OS RPM_BUILD_NCPUS\
|
||||
+ export RPM_SOURCE_DIR RPM_BUILD_DIR RPM_OPT_FLAGS RPM_ARCH RPM_OS RPM_BUILD_NCPUS RPM_LD_FLAGS\
|
||||
RPM_DOC_DIR=\"%{_docdir}\"\
|
||||
export RPM_DOC_DIR\
|
||||
RPM_PACKAGE_NAME=\"%{NAME}\"\
|
12
rpm-4.18.x-revert-pandoc-cond.patch
Normal file
12
rpm-4.18.x-revert-pandoc-cond.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up rpm-4.18.1/docs/Makefile.am.orig rpm-4.18.1/docs/Makefile.am
|
||||
--- rpm-4.18.1/docs/Makefile.am.orig 2023-03-15 14:48:27.955720807 +0100
|
||||
+++ rpm-4.18.1/docs/Makefile.am 2023-03-15 14:48:43.634626934 +0100
|
||||
@@ -1,8 +1,6 @@
|
||||
## Process this file with automake to produce Makefile.in
|
||||
|
||||
-if PANDOC
|
||||
SUBDIRS = man
|
||||
-endif
|
||||
|
||||
EXTRA_DIST =
|
||||
|
14
rpm-4.18.x-siteconfig.patch
Normal file
14
rpm-4.18.x-siteconfig.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -up rpm-4.18.1/macros.in.orig rpm-4.18.1/macros.in
|
||||
--- rpm-4.18.1/macros.in.orig 2023-03-15 13:52:55.211928040 +0100
|
||||
+++ rpm-4.18.1/macros.in 2023-03-15 13:55:04.113129930 +0100
|
||||
@@ -746,7 +746,9 @@ package or when debugging this package.\
|
||||
%{?_javaclasspath:CLASSPATH=\"%{_javaclasspath}\"\
|
||||
export CLASSPATH}\
|
||||
PKG_CONFIG_PATH=\"${PKG_CONFIG_PATH}:%{_libdir}/pkgconfig:%{_datadir}/pkgconfig\"\
|
||||
- export PKG_CONFIG_PATH
|
||||
+ export PKG_CONFIG_PATH\
|
||||
+ CONFIG_SITE=${CONFIG_SITE:-NONE}\
|
||||
+ export CONFIG_SITE
|
||||
|
||||
%___build_pre \
|
||||
%{___build_pre_env} \
|
18
rpm.spec
18
rpm.spec
@ -30,9 +30,9 @@
|
||||
|
||||
%define rpmhome /usr/lib/rpm
|
||||
|
||||
%global rpmver 4.18.0
|
||||
%global rpmver 4.18.1
|
||||
#global snapver rc1
|
||||
%global baserelease 11
|
||||
%global baserelease 1
|
||||
%global sover 9
|
||||
|
||||
%global srcver %{rpmver}%{?snapver:-%{snapver}}
|
||||
@ -129,21 +129,20 @@ Requires(pre): sed
|
||||
# Set rpmdb path to /usr/lib/sysimage/rpm
|
||||
rpm-4.17.x-rpm_dbpath.patch
|
||||
# Disable autoconf config.site processing (#962837)
|
||||
rpm-4.17.x-siteconfig.patch
|
||||
rpm-4.18.x-siteconfig.patch
|
||||
# In current Fedora, man-pages pkg owns all the localized man directories
|
||||
rpm-4.9.90-no-man-dirs.patch
|
||||
|
||||
# Patches already upstream:
|
||||
# ...
|
||||
0001-Fix-potential-uninitialized-variable-use-in-rpmtsImp.patch
|
||||
0001-Generate-Python-egg-info-from-automake-builds.patch
|
||||
0001-Exclude-kernel-modules-from-ELF-dependency-generatio.patch
|
||||
0002-Disable-debuginfod-server-lookups-in-build-and-depen.patch
|
||||
|
||||
# These are not yet upstream
|
||||
rpm-4.7.1-geode-i686.patch
|
||||
# Probably to be upstreamed in slightly different form
|
||||
rpm-4.15.x-ldflags.patch
|
||||
rpm-4.18.x-ldflags.patch
|
||||
# We either need pandoc in buildroot or this patch in order for man pages to
|
||||
# actually be installed, choose the latter
|
||||
rpm-4.18.x-revert-pandoc-cond.patch
|
||||
|
||||
%description
|
||||
The RPM Package Manager (RPM) is a powerful command line driven
|
||||
@ -619,6 +618,9 @@ fi
|
||||
%doc docs/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Wed Mar 15 2023 Michal Domonkos <mdomonko@redhat.com> - 4.18.1-1
|
||||
- Rebase to rpm 4.18.1 (https://rpm.org/wiki/Releases/4.18.1)
|
||||
|
||||
* Thu Feb 16 2023 Panu Matilainen <pmatilai@redhat.com> - 4.18.0-11
|
||||
- Disable debuginfod lookups in rpmbuild scripts
|
||||
- Exclude kernel modules from ELF dependency generation
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (rpm-4.18.0.tar.bz2) = c218b811c0c2db368a2919f60742904a4a5abf09dc20804d649eb42f1853d1c21d121086d6014cd210b2040643c37b5d86b53052958cf702ae2e54fe65f1c0ec
|
||||
SHA512 (rpm-4.18.1.tar.bz2) = 0ede2138b9b4c3b50d7e914cf82655507fcc207ba67804c749ea17560002976cb26b95801e9138a51589b60459494a991213a1131dbef5af2eca9b5050a4f29c
|
||||
|
Loading…
Reference in New Issue
Block a user