Add find-debuginfo-and-macro-docs.patch.
This commit is contained in:
parent
1501796e3f
commit
79f78cc3d5
106
find-debuginfo-and-macro-docs.patch
Normal file
106
find-debuginfo-and-macro-docs.patch
Normal file
@ -0,0 +1,106 @@
|
|||||||
|
commit 173e5642a97c535f8bdaac5bf88854a103cc125b
|
||||||
|
Author: Mark Wielaard <mark@klomp.org>
|
||||||
|
Date: Mon Jun 26 13:35:48 2017 +0200
|
||||||
|
|
||||||
|
Update find-debuginfo.sh options and macros documentation.
|
||||||
|
|
||||||
|
This adds some missing documentation for rpm macros and find-debuginfo.sh
|
||||||
|
options that were recently added (or renamed). -j N, --build-id-seed SEED,
|
||||||
|
--unique-debug-suffix SUFFIX and --unique-debug-src-base BASE.
|
||||||
|
|
||||||
|
Signed-off-by: Mark Wielaard <mark@klomp.org>
|
||||||
|
|
||||||
|
diff --git a/macros.in b/macros.in
|
||||||
|
index b095719..3e9b73f 100644
|
||||||
|
--- a/macros.in
|
||||||
|
+++ b/macros.in
|
||||||
|
@@ -522,8 +522,9 @@ package or when debugging this package.\
|
||||||
|
|
||||||
|
# Whether build-ids should be made unique between package version/releases
|
||||||
|
# when generating debuginfo packages. If set to 1 this will pass
|
||||||
|
-# --ver-rel "%{VERSION}-%{RELEASE}" to find-debuginfo.sh which will pass it
|
||||||
|
-# onto debugedit --build-id-seed to be used to prime the build-id note hash.
|
||||||
|
+# --build-id-seed "%{VERSION}-%{RELEASE}" to find-debuginfo.sh which will
|
||||||
|
+# pass it onto debugedit --build-id-seed to be used to prime the build-id
|
||||||
|
+# note hash.
|
||||||
|
%_unique_build_ids 1
|
||||||
|
|
||||||
|
# Do not recompute build-ids but keep whatever is in the ELF file already.
|
||||||
|
@@ -533,15 +534,16 @@ package or when debugging this package.\
|
||||||
|
|
||||||
|
# Whether .debug files should be made unique between package version,
|
||||||
|
# release and architecture. If set to 1 this will pass
|
||||||
|
-# --unique-debug-arch "%{_arch}" to find-debuginfo.sh to create
|
||||||
|
-# debuginfo files which end in -<ver>-<rel>.<arch>.debug
|
||||||
|
+# --unique-debug-suffix "-%{VERSION}-%{RELEASE}.%{_arch} find-debuginfo.sh
|
||||||
|
+# to create debuginfo files which end in -<ver>-<rel>.<arch>.debug
|
||||||
|
# Requires _unique_build_ids.
|
||||||
|
%_unique_debug_names 1
|
||||||
|
|
||||||
|
# Whether the /usr/debug/src/<package> directories should be unique between
|
||||||
|
# package version, release and architecture. If set to 1 this will pass
|
||||||
|
-# --unique-debug-src-base "%{name}" to find-debuginfo.sh to name the
|
||||||
|
-# directory under /usr/debug/src as <name>-<ver>-<rel>.<arch>
|
||||||
|
+# --unique-debug-src-base "%{name}-%{VERSION}-%{RELEASE}.%{_arch}" to
|
||||||
|
+# find-debuginfo.sh to name the directory under /usr/debug/src as
|
||||||
|
+# <name>-<ver>-<rel>.<arch>.
|
||||||
|
%_unique_debug_srcs 1
|
||||||
|
|
||||||
|
# Whether rpm should put debug source files into its own subpackage
|
||||||
|
diff --git a/scripts/find-debuginfo.sh b/scripts/find-debuginfo.sh
|
||||||
|
index 0233d92..85a862f 100755
|
||||||
|
--- a/scripts/find-debuginfo.sh
|
||||||
|
+++ b/scripts/find-debuginfo.sh
|
||||||
|
@@ -3,11 +3,14 @@
|
||||||
|
#for inclusion in an rpm spec file.
|
||||||
|
#
|
||||||
|
# Usage: find-debuginfo.sh [--strict-build-id] [-g] [-r] [-m] [-i] [-n]
|
||||||
|
+# [-j N]
|
||||||
|
# [-o debugfiles.list]
|
||||||
|
# [-S debugsourcefiles.list]
|
||||||
|
# [--run-dwz] [--dwz-low-mem-die-limit N]
|
||||||
|
# [--dwz-max-die-limit N]
|
||||||
|
-# [--build-id-seed VERSION-RELEASE]
|
||||||
|
+# [--build-id-seed SEED]
|
||||||
|
+# [--unique-debug-suffix SUFFIX]
|
||||||
|
+# [--unique-debug-src-base BASE]
|
||||||
|
# [[-l filelist]... [-p 'pattern'] -o debuginfo.list]
|
||||||
|
# [builddir]
|
||||||
|
#
|
||||||
|
@@ -19,6 +22,9 @@
|
||||||
|
# The -i flag says to include a .gdb_index section in the .debug file.
|
||||||
|
# The -n flag says to not recompute the build-id.
|
||||||
|
#
|
||||||
|
+# The -j N option will spawn N processes to do the debuginfo extraction
|
||||||
|
+# in parallel.
|
||||||
|
+#
|
||||||
|
# A single -o switch before any -l or -p switches simply renames
|
||||||
|
# the primary output file from debugfiles.list to something else.
|
||||||
|
# A -o switch that follows a -p switch or some -l switches produces
|
||||||
|
@@ -31,11 +37,21 @@
|
||||||
|
# if available, and --dwz-low-mem-die-limit and --dwz-max-die-limit
|
||||||
|
# provide detailed limits. See dwz(1) -l and -L option for details.
|
||||||
|
#
|
||||||
|
-# If --build-id-seed VERSION-RELEASE is given then debugedit is called to
|
||||||
|
-# update the build-ids it finds adding the VERSION-RELEASE string as
|
||||||
|
-# seed to recalculate the build-id hash. This makes sure the
|
||||||
|
-# build-ids in the ELF files are unique between versions and releases
|
||||||
|
-# of the same package.
|
||||||
|
+# If --build-id-seed SEED is given then debugedit is called to
|
||||||
|
+# update the build-ids it finds adding the SEED as seed to recalculate
|
||||||
|
+# the build-id hash. This makes sure the build-ids in the ELF files
|
||||||
|
+# are unique between versions and releases of the same package.
|
||||||
|
+# (Use --build-id-seed "%{VERSION}-%{RELEASE}".)
|
||||||
|
+#
|
||||||
|
+# If --unique-debug-suffix SUFFIX is given then the debug files created
|
||||||
|
+# for <FILE> will be named <FILE>-<SUFFIX>.debug. This makes sure .debug
|
||||||
|
+# are unique between package version, release and architecture.
|
||||||
|
+# (Use --unique-debug-suffix "-%{VERSION}-%{RELEASE}.%{_arch}".)
|
||||||
|
+#
|
||||||
|
+# If --unique-debug-src-base BASE is given then the source directory
|
||||||
|
+# will be called /usr/debug/src/<BASE>. This makes sure the debug source
|
||||||
|
+# directories are unique between package version, release and architecture.
|
||||||
|
+# (Use --unique-debug-src-base "%{name}-%{VERSION}-%{RELEASE}.%{_arch}".)
|
||||||
|
#
|
||||||
|
# All file names in switches are relative to builddir (. if not given).
|
||||||
|
#
|
4
rpm.spec
4
rpm.spec
@ -111,6 +111,9 @@ Patch291: find-debuginfo-filter-built-ins.patch
|
|||||||
# Don't create dwz multi file if there is only one .debug.
|
# Don't create dwz multi file if there is only one .debug.
|
||||||
Patch292: find-debuginfo-dwz-multi.patch
|
Patch292: find-debuginfo-dwz-multi.patch
|
||||||
|
|
||||||
|
# Update find-debuginfo.sh options and macros documentation.
|
||||||
|
Patch293: find-debuginfo-and-macro-docs.patch
|
||||||
|
|
||||||
# OpenSSL backend
|
# OpenSSL backend
|
||||||
Patch300: 0001-Add-OpenSSL-support-for-digest-and-signatures.patch
|
Patch300: 0001-Add-OpenSSL-support-for-digest-and-signatures.patch
|
||||||
|
|
||||||
@ -624,6 +627,7 @@ exit 0
|
|||||||
- Add debugedit-prefix.patch.
|
- Add debugedit-prefix.patch.
|
||||||
- Add find-debuginfo-filter-built-ins.patch.
|
- Add find-debuginfo-filter-built-ins.patch.
|
||||||
- Add find-debuginfo-dwz-multi.patch.
|
- Add find-debuginfo-dwz-multi.patch.
|
||||||
|
- Add find-debuginfo-and-macro-docs.patch.
|
||||||
|
|
||||||
* Wed Jun 28 2017 Mark Wielaard <mjw@fedoraproject.org> - 4.13.0.1-27
|
* Wed Jun 28 2017 Mark Wielaard <mjw@fedoraproject.org> - 4.13.0.1-27
|
||||||
- Add find-debuginfo-split-traversal-and-extraction-fix.patch (#1465170)
|
- Add find-debuginfo-split-traversal-and-extraction-fix.patch (#1465170)
|
||||||
|
Loading…
Reference in New Issue
Block a user