parent
ee316a0bf8
commit
77efb7ee50
26
rpm-4.12.90-Fix-compressed-patches.patch
Normal file
26
rpm-4.12.90-Fix-compressed-patches.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 8fab4539051091f71d88f6b1d8c6660a40d5a5bd Mon Sep 17 00:00:00 2001
|
||||
From: Florian Festi <ffesti@redhat.com>
|
||||
Date: Mon, 27 Jul 2015 18:52:25 +0200
|
||||
Subject: [PATCH] Fix compressed patches
|
||||
|
||||
Regression caused by d9f673bf2841bb8c854e6676871078ab563a51c9 caused uncompressed patch content to be printed out to std instead of being piped into patch command.
|
||||
---
|
||||
build/parsePrep.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/build/parsePrep.c b/build/parsePrep.c
|
||||
index 5ba5aee..b94aad2 100644
|
||||
--- a/build/parsePrep.c
|
||||
+++ b/build/parsePrep.c
|
||||
@@ -101,7 +101,7 @@ static char *doPatch(rpmSpec spec, uint32_t c, int strip, const char *db,
|
||||
|
||||
/* Avoid the extra cost of fork and pipe for uncompressed patches */
|
||||
if (compressed != COMPRESSED_NOT) {
|
||||
- patchcmd = rpmExpand("%{uncompress: ", fn, "} || echo patch_fail | "
|
||||
+ patchcmd = rpmExpand("{ %{uncompress: ", fn, "} || echo patch_fail ; } | "
|
||||
"%{__patch} ", args, NULL);
|
||||
} else {
|
||||
patchcmd = rpmExpand("%{__patch} ", args, " < ", fn, NULL);
|
||||
--
|
||||
2.1.0
|
||||
|
6
rpm.spec
6
rpm.spec
@ -27,7 +27,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}2%{?dist}
|
||||
Release: %{?snapver:0.%{snapver}.}3%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/rpm-4.12.x/%{name}-%{srcver}.tar.bz2
|
||||
@ -51,6 +51,7 @@ Patch5: rpm-4.12.0-rpm2cpio-hack.patch
|
||||
|
||||
# Patches already upstream:
|
||||
Patch100: rpm-4.12.90-braces-expansion.patch
|
||||
Patch101: rpm-4.12.90-Fix-compressed-patches.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch302: rpm-4.7.1-geode-i686.patch
|
||||
@ -535,6 +536,9 @@ exit 0
|
||||
%doc doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Mon Jul 27 2015 Florian Festi <ffesti@rpm.org> - 4.12.90-3
|
||||
- Fix compressed patches (#1247248)
|
||||
|
||||
* Mon Jul 27 2015 Lubos Kardos <lkardos@redhat.com> - 4.12.90-2
|
||||
- Enable braces expansion in rpmGlob() (#1246743)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user