- Update to 4.12.0-beta1
- Fixes #1122004, #1111349, #1117912, #1123722 - Drop upstreamed patches
This commit is contained in:
parent
19dfee2e9e
commit
74824106c8
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@
|
|||||||
/rpm-4.11.2-rc2.tar.bz2
|
/rpm-4.11.2-rc2.tar.bz2
|
||||||
/rpm-4.11.2.tar.bz2
|
/rpm-4.11.2.tar.bz2
|
||||||
/rpm-4.11.90-git12844.tar.bz2
|
/rpm-4.11.90-git12844.tar.bz2
|
||||||
|
/rpm-4.12.0-beta1.tar.bz2
|
||||||
|
@ -1,18 +0,0 @@
|
|||||||
diff -up rpm-4.11.90-git12844/lib/rpmrc.c.arm-vfp3 rpm-4.11.90-git12844/lib/rpmrc.c
|
|
||||||
--- rpm-4.11.90-git12844/lib/rpmrc.c.arm-vfp3 2014-07-02 13:06:07.626643228 +0300
|
|
||||||
+++ rpm-4.11.90-git12844/lib/rpmrc.c 2014-07-02 13:06:24.290591042 +0300
|
|
||||||
@@ -1156,11 +1156,11 @@ static void defaultMachine(rpmrcCtx ctx,
|
|
||||||
# if !defined(HWCAP_ARM_NEON)
|
|
||||||
# define HWCAP_ARM_NEON (1 << 12)
|
|
||||||
# endif
|
|
||||||
-# if !defined(HWCAP_ARM_VFPv3D16)
|
|
||||||
-# define HWCAP_ARM_VFPv3D16 (1 << 13)
|
|
||||||
+# if !defined(HWCAP_ARM_VFPv3)
|
|
||||||
+# define HWCAP_ARM_VFPv3 (1 << 13)
|
|
||||||
# endif
|
|
||||||
if (rstreq(un.machine, "armv7l")) {
|
|
||||||
- if (rpmat.hwcap & HWCAP_ARM_VFPv3D16) {
|
|
||||||
+ if (rpmat.hwcap & HWCAP_ARM_VFPv3) {
|
|
||||||
if (rpmat.hwcap & HWCAP_ARM_NEON)
|
|
||||||
strcpy(un.machine, "armv7hnl");
|
|
||||||
else
|
|
@ -1,30 +0,0 @@
|
|||||||
commit d4ab1d82d7888f41b866751d0ef340a82be7cff2
|
|
||||||
Author: Panu Matilainen <pmatilai@redhat.com>
|
|
||||||
Date: Tue Jul 1 12:04:40 2014 +0300
|
|
||||||
|
|
||||||
Macro-expand %{load:...} argument to make the thing more useful...
|
|
||||||
|
|
||||||
diff --git a/rpmio/macro.c b/rpmio/macro.c
|
|
||||||
index b00155c..1d9bd1c 100644
|
|
||||||
--- a/rpmio/macro.c
|
|
||||||
+++ b/rpmio/macro.c
|
|
||||||
@@ -1093,16 +1093,15 @@ expandMacro(MacroBuf mb, const char *src, size_t slen)
|
|
||||||
|
|
||||||
/* Expand builtin macros */
|
|
||||||
if (STREQ("load", f, fn)) {
|
|
||||||
- if (g && gn > 0) {
|
|
||||||
- char arg[gn + 1];
|
|
||||||
- strncpy(arg, g, gn);
|
|
||||||
- arg[gn] = '\0';
|
|
||||||
+ char *arg = NULL;
|
|
||||||
+ if (g && gn > 0 && expandThis(mb, g, gn, &arg) == 0) {
|
|
||||||
/* Print failure iff %{load:...} or %{!?load:...} */
|
|
||||||
if (loadMacroFile(mb->mc, arg) && chkexist == negate) {
|
|
||||||
rpmlog(RPMLOG_ERR,
|
|
||||||
_("failed to load macro file %s"), arg);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
+ free(arg);
|
|
||||||
s = se;
|
|
||||||
continue;
|
|
||||||
}
|
|
@ -1,25 +0,0 @@
|
|||||||
commit c64a4b54dd16537ad0c609037e96d295a60d9ace
|
|
||||||
Author: Florian Festi <ffesti@redhat.com>
|
|
||||||
Date: Mon Jun 30 13:30:38 2014 +0200
|
|
||||||
|
|
||||||
Fix handling of hardlinks during rpmbuild
|
|
||||||
|
|
||||||
After looping over the hardlinks and writing their headers entries to the
|
|
||||||
archive we need to return to the first entry to make sure we do not leave out
|
|
||||||
other groups of hardlinked files that start between the group we are currently
|
|
||||||
processing
|
|
||||||
|
|
||||||
(cherry picked from commit b7b8b3343f8668f77baf8f2cddbdd99d9d62c1f4)
|
|
||||||
|
|
||||||
diff --git a/lib/rpmfi.c b/lib/rpmfi.c
|
|
||||||
index 27186dd..ed51d44 100644
|
|
||||||
--- a/lib/rpmfi.c
|
|
||||||
+++ b/lib/rpmfi.c
|
|
||||||
@@ -1819,6 +1819,7 @@ static int iterWriteArchiveNextFile(rpmfi fi)
|
|
||||||
return rc;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
+ rpmfiSetFX(fi, hardlinks[0]);
|
|
||||||
} else {
|
|
||||||
int rc = rpmfiArchiveWriteHeader(fi);
|
|
||||||
if (rc) {
|
|
@ -1,24 +0,0 @@
|
|||||||
commit 708fb8c35eff3acacf2b7d197f9ef59fb9551e15
|
|
||||||
Author: Panu Matilainen <pmatilai@redhat.com>
|
|
||||||
Date: Thu Jul 3 13:31:34 2014 +0300
|
|
||||||
|
|
||||||
Fix db iterator pattern matching (RhBug:1115824)
|
|
||||||
|
|
||||||
- Should've been in / Fixes a regression introduced in (pick your favorite)
|
|
||||||
commit bc871e8fead5fd16f2c51a4a453bddf9994b80ba
|
|
||||||
|
|
||||||
diff --git a/lib/rpmdb.c b/lib/rpmdb.c
|
|
||||||
index be08193..b6d3247 100644
|
|
||||||
--- a/lib/rpmdb.c
|
|
||||||
+++ b/lib/rpmdb.c
|
|
||||||
@@ -1556,9 +1556,7 @@ top:
|
|
||||||
* Skip this header if iterator selector (if any) doesn't match.
|
|
||||||
*/
|
|
||||||
if (mireSkip(mi)) {
|
|
||||||
- if (mi->mi_set)
|
|
||||||
- goto top;
|
|
||||||
- return NULL;
|
|
||||||
+ goto top;
|
|
||||||
}
|
|
||||||
headerSetInstance(mi->mi_h, mi->mi_offset);
|
|
||||||
|
|
17
rpm.spec
17
rpm.spec
@ -15,10 +15,10 @@
|
|||||||
|
|
||||||
%define rpmhome /usr/lib/rpm
|
%define rpmhome /usr/lib/rpm
|
||||||
|
|
||||||
%define rpmver 4.11.90
|
%define rpmver 4.12.0
|
||||||
%define snapver git12844
|
%define snapver beta1
|
||||||
%define srcver %{rpmver}%{?snapver:-%{snapver}}
|
%define srcver %{rpmver}%{?snapver:-%{snapver}}
|
||||||
%define eggver %{rpmver}
|
%define eggver %{rpmver}%{?snapver:_%{snapver}}
|
||||||
|
|
||||||
%define bdbname libdb
|
%define bdbname libdb
|
||||||
%define bdbver 5.3.15
|
%define bdbver 5.3.15
|
||||||
@ -27,7 +27,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: %{?snapver:0.%{snapver}.}5%{?dist}.1
|
Release: %{?snapver:0.%{snapver}.}1%{?dist}.1
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||||
@ -48,10 +48,6 @@ Patch3: rpm-4.9.90-no-man-dirs.patch
|
|||||||
Patch4: rpm-4.8.1-use-gpg2.patch
|
Patch4: rpm-4.8.1-use-gpg2.patch
|
||||||
|
|
||||||
# Patches already upstream:
|
# Patches already upstream:
|
||||||
Patch100: rpm-4.11.90-hardlink-groups.patch
|
|
||||||
Patch101: rpm-4.11.90-expand-load-arg.patch
|
|
||||||
Patch102: rpm-4.11.90-arm-vfp3.patch
|
|
||||||
Patch103: rpm-4.11.90-mireskip.patch
|
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch302: rpm-4.7.1-geode-i686.patch
|
Patch302: rpm-4.7.1-geode-i686.patch
|
||||||
@ -530,6 +526,11 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 18 2014 Panu Matilainen <pmatilai@redhat.com> - 4.12.0-0.beta1.1
|
||||||
|
- Update to 4.12.0-beta1 (http://rpm.org/wiki/Releases/4.12.0)
|
||||||
|
- Fixes #1122004, #1111349, #1117912, #1123722
|
||||||
|
- Drop upstreamed patches
|
||||||
|
|
||||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.11.90-0.git12844.5.1
|
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.11.90-0.git12844.5.1
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user