- more fixes to postscript provides extractor (#562228)
This commit is contained in:
parent
41225dc3c0
commit
6b08a4c01a
30
rpm-4.8.0-psdriver-more-fixes.patch
Normal file
30
rpm-4.8.0-psdriver-more-fixes.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
--- rpm-4.8.0/scripts/postscriptdriver.prov 2010-02-05 15:40:34.451050057 +0000
|
||||||
|
+++ rpm-4.8.0/scripts/postscriptdriver.prov~ 2010-02-05 15:44:10.141926520 +0000
|
||||||
|
@@ -196,9 +196,15 @@ class DrvDriver(PPDDriver):
|
||||||
|
self.drv ]
|
||||||
|
|
||||||
|
signal.alarm (60)
|
||||||
|
- p = subprocess.Popen (argv,
|
||||||
|
- stdout=subprocess.PIPE,
|
||||||
|
- stderr=subprocess.PIPE)
|
||||||
|
+ try:
|
||||||
|
+ p = subprocess.Popen (argv,
|
||||||
|
+ stdout=subprocess.PIPE,
|
||||||
|
+ stderr=subprocess.PIPE)
|
||||||
|
+ except OSError:
|
||||||
|
+ # ppdc not available.
|
||||||
|
+ os.rmdir (outputdir)
|
||||||
|
+ return Driver.list (self)
|
||||||
|
+
|
||||||
|
try:
|
||||||
|
(stdout, stderr) = p.communicate ()
|
||||||
|
signal.alarm (0)
|
||||||
|
@@ -230,7 +236,7 @@ class TagBuilder:
|
||||||
|
self.ids += DynamicDriver (path).list ()
|
||||||
|
except TimedOut:
|
||||||
|
pass
|
||||||
|
- except OSError, e:
|
||||||
|
+ except OSError, (e, s):
|
||||||
|
if e == errno.EACCES or e == errno.ENOENT:
|
||||||
|
# Not executable
|
||||||
|
pass
|
7
rpm.spec
7
rpm.spec
@ -21,7 +21,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||||
@ -39,6 +39,7 @@ Patch3: rpm-4.7.90-fedora-specspo.patch
|
|||||||
# TODO: merge these when things stabilize
|
# TODO: merge these when things stabilize
|
||||||
Patch4: rpm-4.8.0-psdriver.patch
|
Patch4: rpm-4.8.0-psdriver.patch
|
||||||
Patch5: rpm-4.8.0-psdriver-fixes.patch
|
Patch5: rpm-4.8.0-psdriver-fixes.patch
|
||||||
|
Patch6: rpm-4.8.0-psdriver-more-fixes.patch
|
||||||
|
|
||||||
# Patches already in upstream
|
# Patches already in upstream
|
||||||
Patch200: rpm-4.8.0-url-segfault.patch
|
Patch200: rpm-4.8.0-url-segfault.patch
|
||||||
@ -190,6 +191,7 @@ packages on a system.
|
|||||||
%patch3 -p1 -b .fedora-specspo
|
%patch3 -p1 -b .fedora-specspo
|
||||||
%patch4 -p1 -b .psdriver
|
%patch4 -p1 -b .psdriver
|
||||||
%patch5 -p1 -b .psdriver-fixes
|
%patch5 -p1 -b .psdriver-fixes
|
||||||
|
%patch6 -p1 -b .psdriver-more-fixes
|
||||||
|
|
||||||
%patch200 -p1 -b .url-segfault
|
%patch200 -p1 -b .url-segfault
|
||||||
%patch201 -p1 -b .verify-exitcode
|
%patch201 -p1 -b .verify-exitcode
|
||||||
@ -411,6 +413,9 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 05 2010 Panu Matilainen <pmatilai@redhat.com> - 4.8.0-8
|
||||||
|
- more fixes to postscript provides extractor (#562228)
|
||||||
|
|
||||||
* Fri Feb 05 2010 Panu Matilainen <pmatilai@redhat.com> - 4.8.0-7
|
* Fri Feb 05 2010 Panu Matilainen <pmatilai@redhat.com> - 4.8.0-7
|
||||||
- couple of fixes to the postscript provides extractor (#538101)
|
- couple of fixes to the postscript provides extractor (#538101)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user