- fix segfault in spec parser (#597835)
This commit is contained in:
parent
019f97fda6
commit
6462ae4d5c
19
rpm-4.8.0-spec-readline.patch
Normal file
19
rpm-4.8.0-spec-readline.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
commit daec6ebf58331776279f389738af4788b865033d
|
||||||
|
Author: Michael Schroeder <mls@suse.de>
|
||||||
|
Date: Mon Apr 12 12:10:20 2010 +0200
|
||||||
|
|
||||||
|
readLineFromOFI may modify the fileStack, thus we have to re-set
|
||||||
|
ofi after calling it
|
||||||
|
|
||||||
|
diff --git a/build/parseSpec.c b/build/parseSpec.c
|
||||||
|
index 06b5a3d..f45022b 100644
|
||||||
|
--- a/build/parseSpec.c
|
||||||
|
+++ b/build/parseSpec.c
|
||||||
|
@@ -274,6 +274,7 @@ int readLine(rpmSpec spec, int strip)
|
||||||
|
retry:
|
||||||
|
if ((rc = readLineFromOFI(spec, ofi)) != 0)
|
||||||
|
return rc;
|
||||||
|
+ ofi = spec->fileStack;
|
||||||
|
|
||||||
|
/* Copy next file line into the spec line buffer */
|
||||||
|
rc = copyNextLineFromOFI(spec, ofi);
|
7
rpm.spec
7
rpm.spec
@ -21,7 +21,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: 16%{?dist}
|
Release: 17%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||||
@ -52,6 +52,7 @@ Patch207: rpm-4.8.0-python-nocontexts.patch
|
|||||||
Patch208: rpm-4.8.0-python-mibool.patch
|
Patch208: rpm-4.8.0-python-mibool.patch
|
||||||
Patch209: rpm-4.8.0-python-emptyds.patch
|
Patch209: rpm-4.8.0-python-emptyds.patch
|
||||||
Patch210: rpm-4.8.0-findlang-localedirs.patch
|
Patch210: rpm-4.8.0-findlang-localedirs.patch
|
||||||
|
Patch211: rpm-4.8.0-spec-readline.patch
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch301: rpm-4.6.0-niagara.patch
|
Patch301: rpm-4.6.0-niagara.patch
|
||||||
@ -210,6 +211,7 @@ packages on a system.
|
|||||||
%patch208 -p1 -b .python-mibool
|
%patch208 -p1 -b .python-mibool
|
||||||
%patch209 -p1 -b .python-emptyds
|
%patch209 -p1 -b .python-emptyds
|
||||||
%patch210 -p1 -b .findlang-localedirs
|
%patch210 -p1 -b .findlang-localedirs
|
||||||
|
%patch211 -p1 -b .spec-readline
|
||||||
|
|
||||||
%patch301 -p1 -b .niagara
|
%patch301 -p1 -b .niagara
|
||||||
%patch302 -p1 -b .geode
|
%patch302 -p1 -b .geode
|
||||||
@ -426,6 +428,9 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 27 2010 Panu Matilainen <pmatilai@redhat.com> - 4.8.0-17
|
||||||
|
- fix segfault in spec parser (#597835)
|
||||||
|
|
||||||
* Thu May 27 2010 Panu Matilainen <pmatilai@redhat.com> - 4.8.0-16
|
* Thu May 27 2010 Panu Matilainen <pmatilai@redhat.com> - 4.8.0-16
|
||||||
- adjust to new pkg-config behavior wrt private dependencies (#596433)
|
- adjust to new pkg-config behavior wrt private dependencies (#596433)
|
||||||
- rpm-build now requires pkgconfig >= 0.24
|
- rpm-build now requires pkgconfig >= 0.24
|
||||||
|
Loading…
Reference in New Issue
Block a user